Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 Re : [dc2] Plugins » Gallery 0.4 : support du plugin » 2015-09-02 11:49:45

Hello,

un petit soucis relevé avec la version 0.5 utilisée sur une 2.8 standard avec le thème Berlin : dans la sidebar, le titre Galeries n'a pas le bon style. Pour régler ça il faut :
* passer ce titre en h3 (au lieu de h2 actuellement)
* ajouter la classe widget à la div supérieure.

La modification est à réaliser dans le fichier _public_widgets.php

'<div class="galleries categories"><h2>'.$title.'</h2>';

à

'<div class="galleries categories widget"><h3>'.$title.'</h3>';

le résultat est visible là -> http://amapplus.fr/blog/index.php?

#2 [dc2] Thèmes » Berlin : base64 vs CSS sprites... » 2015-08-22 10:41:50

poupoul2
Réponses : 0

Hello,

ça faisait un petit moment que je n'avais pas mis les mains sur Dotclear et je suis en train de tester la toute dernière version et son thème Berlin. En explorant la feuille de style, je remarque que les images sont directement encodées en base64 dans le fichier CSS.

J'avoue que ça m'a surpris. Je comprends l'intérêt du point de vue http : une seule requête http pour charger la feuille de style et toutes les images utilisées sont disponibles. Mais cela signifie aussi qu'à chaque utilisation d'une image, le navigateur doit décoder l'image, je n'ai pas vu de stratégie de mise en cache des images décodées, je ne sais même pas si c'est possible.

Je n'ai pas trop d'avis tranché sur la question, mais j'aurais naturellement tendance à penser que d'autres techniques telles que les sprites pourraient apporter un gain en performance sans nécessiter un travail supplémentaire de décodage du browser, non ?

Ce n'est pas du tout une question/remarque polémique. Je me pose la question, je m'interroge, je suppute... Je ne suis d'ailleurs même pas certain qu'il y ait un problème à résoudre. Des avis ?

NB : j'aime beaucoup ce thème :)

#3 Re : [dc2] Installation et hébergement » Installation locale / problème de droits » 2011-02-23 12:43:37

@Moe
Parce que je teste une procédure de mise à niveau pour une installation existante. En l'occurence, le planet ubuntu-fr fonctionne actuellement avec le code disponible dans la branche bazaar du projet Launchpad. Il faut donc que je reparte de ce code là pour tester la mise à niveau.

Pour le plugin OpenPlanet, c'est aussi celui qui est utilisé actuellement pour le Planet Ufr. Il fonctionne très bien et a l'énorme avantage de proposer toutes les fonctionnalités dont nous avons besoin. Il n'y a donc pas besoin de changer :) (sauf si ça ne marche plus évidemment)

#4 Re : [dc2] Installation et hébergement » Installation locale / problème de droits » 2011-02-23 10:33:22

Problème résolu. Il semble que la procédure de mise à jour que j'ai utilisée ne soit incomplète. J'ai donc agi différemment en suivant la procédure standard : Installation de la version initiale à partir de Launchapd, désactivation des plugins persos, mise à niveau manuelle en suivant les indications de la doc et réinstallation des plugins.

À ce sujet, le plugin openplanet 1.0 disponible sur dotaddict ne fonctionne pas avec DC 2.2.2 : Il fait planter le blog. Le site de l'auteur est inaccessible. J'ai trouvé une version patchée qui a fonctionné sans problème.

Merci Moe pour ton aide.

#6 Re : [dc2] Installation et hébergement » Installation locale / problème de droits » 2011-02-22 21:24:21

Warning: Parameter 1 to rsExtUser::options() expected to be a reference, value given in /var/www/UPlanet/inc/clearbricks/dblayer/dblayer.php on line 708 Warning: array_merge(): Argument #2 is not an array in /var/www/UPlanet/inc/core/class.dc.auth.php on line 136 Notice: Undefined index: pl_author in /var/www/UPlanet/inc/clearbricks/dblayer/dblayer.php on line 750

Hmmm, ça y ressemble effectivement, sauf que je suis bien en php 5.3 :/

PHP 5.3.2-1ubuntu4.7 with Suhosin-Patch (cli) (built: Jan 12 2011 18:36:55)

#7 Re : [dc2] Installation et hébergement » Installation locale / problème de droits » 2011-02-22 19:34:23

Moe a écrit :

ça veut dire que tu es ramené sur la page d'identification ?

Non, non, le processus va à son terme, mais je n'ai pas accès au billet en visualisation ou en modification :
Avant création
[img]http://pix.toile-libre.org/upload/thumb/1298403169.png[/img]
Après création
[img]http://pix.toile-libre.org/upload/thumb/1298403199.png[/img]
Je prévisualise sur le blog
[img]http://pix.toile-libre.org/upload/thumb/1298403223.png[/img]

#9 Re : [dc2] Installation et hébergement » Installation locale / problème de droits » 2011-02-22 18:45:52

Moe a écrit :

il faut donner les droits suffisants à l'utilisateur

C'est bien le cas, y compris avec l'utilisateur créé dans la procédure d'installation. J'ai aussi créé un nouvel utilisateur, avec les droits super admins et ce n'est pas mieux.

C'est également la même chose pour un nouvel utilisateur, à qui je donne les bons droits (genre créer et gérer ses propres billets) : Une fois le billet enregistré, impossible d'y retourner ou de le modifier :(

#10 [dc2] Installation et hébergement » Installation locale / problème de droits » 2011-02-22 13:51:08

poupoul2
Réponses : 13

Bonjour à tous.

J'ai réalisé une installation en local (donc sur localhost/mon_dotclear). Une précision : L'installation a été réalisée à partir de ce code là. Ce code est celui du planet Ubuntu-fr, qui est basé sur Dotclear et le plugin Openplanet.

Mon problème (en local donc) est le suivant : Bien que l'installation se soit déroulée sans problème, l'utilisateur créé au départ ne peut pas modifier, ni même visualiser les billets dans l'interface d'administration. Par exemple, le billet créé par défaut apparait bien dans la liste des billets, mais impossible d'y accéder que ce soit pour le visualiser ou le modifier. C'est la même chose avec un billet créé : Le billet se crée puis impossible d'accéder à son contenu o_O

Ça me semble être un problème de droits quelque part, mais comme je ne suis pas développeur, je n'arrive pas à trouver où chercher.

Merci de votre aide. Évidemment si des informations supplémentaires sont nécessaires, n'hésitez pas.

#11 Re : [dc2] Questions et aide » Base de données vide. Impossible, non? » 2008-04-15 15:52:45

Bonsoir je reviens vers vous avec le fin mot de l'histoire.

C'est peut-être à ajouter dans une doc quelque part sur le site (je vais regarder): J'ai interrogé OVH concernant ce problème de base de données. Réponse d'OVH: Dans le cas où dotclear est installé via le manager OVH (gestionnaire de modules), l'accès à la BDD n'est pas donné. Pour accéder à la BDD, il faut donc installer soit même le logiciel.
Je ne fais pas de développement et n'avais pas l'intention de modifier cette base. Par contre, l'accès à la BDD est intéressant lorsqu'on souhaite ajouter certaines fonctionnalités (genre stats...)

Ca me servira de leçon pour la suite.

#12 Re : [dc2] Questions et aide » Base de données vide. Impossible, non? » 2008-02-23 11:02:58

J'ai un peu avancé: Remplacement du dossier plugins du site par celui d'une version vanille de la beta 7. ca m'a permis de faire une sauvegarde du blog. J'ai testé cette sauvegarde sur mon serveur maison (dotclear en beta 7) et je retrouve bien mon contenu.

Ce point là est réglé. Prochaine étape: Je refais le blog sur la bonne base.

#13 Re : [dc2] Questions et aide » Base de données vide. Impossible, non? » 2008-02-20 19:51:22

Chiant...et vous avez raison. Peut être que je ne le ferai plus...

#14 Re : [dc2] Questions et aide » Base de données vide. Impossible, non? » 2008-02-20 07:52:12

amalgame a écrit :

Oui mais as-tu mis à jour aussi les plugins ?

J'ai suivi à la lettre les instructions de la documentation. A l'époque, avant mise à jour, j'avais fait un export du blog sans problème. Du coup, j'ai un doute: J'ai peut-être, après installation de la nouvelle version, recopié le contenu du dossier plugins (ce qui n'est sans doute pas ce qu'il fallait faire).

Ce que je peux tenter, c'est reprendre le dossier plugins de la beta 7 (je n'ai rien de spécifique) et voir si ça permet de résoudre le problème de Precondition.

Ensuite, refaire une installation "fraîche", ce qui me permettra de remonter le blog sur MA base (non, mais...).

Des avis contraires ou d'autres idées?

#15 Re : [dc2] Questions et aide » Base de données vide. Impossible, non? » 2008-02-18 19:49:48

OVH m'a installé la beta 6. J'ai migré en beta 7 depuis, sans problème particulier et avec moultes précautions, et surtout sans modifier les plugins installés avec la beta 7.

Voilà ce que me donne le _define.php du plugin

/* Name */			"Blog import",
	/* Description*/		"Import your blog backup file",
	/* Author */			"Olivier Meunier",
	/* Version */			'1.1.5',
	/* Permissions */		'admin'

Je dois avoir sous le coude le dossier /plugins de la beta 7. Est ce qu'un annule/remplace pourrait être une solution à tester?

#16 Re : [dc2] Questions et aide » Base de données vide. Impossible, non? » 2008-02-18 19:38:28

Impossible: Connexion au serveur MySQL non permise, quel que soit le mot de passe saisi (nic-handle ou autre)

#17 Re : [dc2] Questions et aide » Base de données vide. Impossible, non? » 2008-02-18 19:30:41

J'ai installé initialement dotclear via les modules proposés par OVH. Est ce que ça peut venir de là?
Ce que je comprends, c'est que le manager ne me donne pas accès à la BDD du blog, right? (désolé, je suis neuneu en base de données...)

#18 Re : [dc2] Questions et aide » Base de données vide. Impossible, non? » 2008-02-18 19:19:37

Voilà ce que me dit le manager:
Base de données     Taille     Limite     État     Serveur     Version
pouvoircplibre                Vide    5 Mo    ok        mysql5-4      MySQL 5

Ca donne ça
[img]http://pix.nofrag.com/0/8/3/c28838afb5ab017b38023f909af57.html[/img]

Voilà ce que me dit le config.php (entre autres)

// Database hostname (usually "localhost")
define('DC_DBHOST','sql1.modules');
// Database name
define('DC_DBNAME','558408-1');

#19 Re : [dc2] Questions et aide » Base de données vide. Impossible, non? » 2008-02-18 18:26:39

Je suis aller regarder du côté de l'hébergeur. A priori le manager ne fournit un accès à la base que dans certaines conditions. La base doit exister, mais je ne peux pas y accéder via PhpMyAdmin.

Seule solution: débloquer ce problème de Precondition Failed

#20 Re : [dc2] Questions et aide » Base de données vide. Impossible, non? » 2008-02-18 18:20:44

A priori, c'est bien du mysql:

// Database driver (mysql, pgsql, sqlite)
define('DC_DBDRIVER','mysql');

Autre possibilité: Le manager d'OVH ne me fournit pas les bonnes informations. Je vais regarder de ce côté là. Si d'autres ont le même soucis avec le manager V3, ça m'intéresse

Concernant mes plugins, je n'en ai pas installé, parce que justement, je ne suis pas sûr. Toutes les modifications que je souhaite faire sur le blog sont d'abord testées chez moi (sur mon petit serveur perso), sur lequel j'ai une copie (hors contenu) de mon blog. C'est ce que j'ai fait pour la css par exemple (que je suis loin de maitriser). le contenu du dossier /plugins est le suivant:
[img]http://pix.nofrag.com/5/0/1/002b9e1443913839aaf948a237e38.png[/img]
Y a-t-il quelque chose que je puisse faire?

PS: Merci pour la correction du lien mal foutu
PS2: pourquoi ne peut on pas modifier ses propres posts?
PS3: Sans photocopieur, on est mort.

#21 [dc2] Questions et aide » Base de données vide. Impossible, non? » 2008-02-17 20:27:22

poupoul2
Réponses : 20

Bonsoir à tous.

Mon blog est hébergé chez OVH. Il utilise dotclear 2.0 beta 7. J'essaie de réaliser une sauvegarde.

D'après ce que j'ai compris, tous les billets/commentaires... sont stockés dans la base de données. Sauf que le manager OVH m'annonce que la base de données est...vide. Idem via PhpMyAdmin: Aucune table n'a été trouvée dans cette base. Il me semble que c'est impossible

Je n'ai accès à aucune autre base depuis le manager OVH.

J'ai également tenté un export via l'interface d'administration: Precondition Failed.

Je n'ai apporté de modifications au site, si ce n'est la CSS, que j'ai bidouillée un peu.

Merci de votre aide

#22 Re : [dc2] Bugs » Ajout de tag impossible » 2008-01-27 08:44:33

Je relance ce post parce que le problème persiste.

L'ajout de tag est possible lors de la création du billet et c'est ce que je fais pour es nouveaux billets. En revanche, une fois le billet sauvegardé, impossible d'y ajouter une tag. La liste des tags apparait bien, mais le clic sur le bouton Ok est inopérant.

#23 Re : [dc2] Bugs » Ajout de tag impossible » 2008-01-14 20:46:22

J'ai contourné le problème en recréant le billet et en lui ajoutant manuellement le tag avant sauvegarde. Ca a fonctionné.

Je verrai dans les prochains billets si le problème persiste

#24 Re : [dc2] Bugs » Ajout de tag impossible » 2008-01-14 20:17:48

Merci de ta réponse. La connection est effectivement assez erratique ce soir. Je ne touche pas à la base de données, parce que ce n'est pas mon domaine de compétences. Il y a peut-être un lien entre les 2 (comportement de dotclear / comportement de la base).

#25 [dc2] Bugs » Ajout de tag impossible » 2008-01-14 19:22:55

poupoul2
Réponses : 4

Bonjour.

Depuis ce soir, alors que je n'ai fait aucune modification sur mon site, il m'est impossible d'ajouter un tag sur le dernier billet. La liste des tags apparait bien, mais le clic sur le bouton Ok (après sélection du bon Tag) est inopérant.

Quelqu'un(e) a déjà rencontré ce problème?

Vous n'êtes pas identifié(e).

Pied de page des forums

Propulsé par FluxBB

Sites map