Dotclear

Vous n'êtes pas identifié(e).

Annonce

#2 [dc2] Questions et aide » Afficher les billets qui ont un tag donné » 2010-10-28 07:57:44

graphiklili
Réponses : 2

Bonjour à tous,

Je voudrais vous prévenir tout d'abord que mon code est loin d'être parfait, et n'est pas W3C... Je m'excuse d'avance donc si ce que j'ai fait n'est pas très propre (j'ai simplement fait ce que j'ai pu).

Ce que je souhaite faire sans succès, c'est de faire remonter tous les billets tagués "Newsletter" :
http://www.carnets-de-traverse.com/blog … Newsletter
sur cette page-là (issue du plugin "contact-me") :
http://www.carnets-de-traverse.com/blog … hp?contact

Le but est de donner aux gens un aperçu des newsletters passées.

Mais je ne sais pas comment "récupérer" et afficher ces billets ?

#4 Re : [dc2] Questions et aide » Les Tags » 2009-10-29 08:30:09

D'accord je vais le tester (donc pas de solution pour l'instant pour les tags ?)
Mais si ça prend en compte les catégories c'est déjà pas mal.

Il s'installe comme un plugin "normal" ?
Quand je décompresse l'archive .zip il me crée un fichier "plugin-dcOpenSearch-1.0.4.zip.cpgz", bizarre non ?

#5 Re : [dc2] Questions et aide » Les Tags » 2009-10-28 17:06:26

Je ne comprends pas tout mais merci Kozlika, il se peut que ce soit ça ?
Je l'installe comme un plugin standard et ça viendra remplacer mon moteur de recherche par défaut ?

(On parle bien du moteur de recherche interne du blog et non de google ou autre ?)

#6 Re : [dc2] Questions et aide » Les Tags » 2009-10-28 15:59:33

Bonjour à tous,

Je profite de ce sujet pour vous poser une question sur les tags et les moteurs de recherche internes des blogs dotclear.

Y'a t'il une manip à faire pour que le moteur de recherche de mon blog prennent en compte les tags (et pourquoi pas les catégories) de mes billets ?

Je vous donne un exemple, j'écris un post sur l'Italie que je place dans la catégorie ITALIE, et sur lequel je place également un tag ITALIE. Et bien si je n'écris pas en toutes lettres le mot "ITALIE" dans le post, le moteur de recherche interne du blog ne remonte pas ce billet pour la recherche "ITALIE".

#7 Re : [dc2] Thèmes » [Nouveau Thème] Qrazy Times » 2009-10-13 06:40:37

Bonjour pierre,
De quelles vignettes parles-tu ? (Ce week-end j'ai fais pas mal de changements sur le thème !)

#8 Re : [dc2] Questions et aide » Plugin Dotmap et thème Qrazy Times » 2009-10-04 10:47:28

salut david
ça marche maintenant, je ne saurais dire pourquoi, peut être (sans doute) une erreur de frappe
Encore un grand merci donc.

#9 Re : [dc2] Questions et aide » Plugin Dotmap et thème Qrazy Times » 2009-10-03 10:39:21

Ce n'est peut-être pas possible ? Je ne trouve pas, si quelqu'un a une idée...

#10 Re : [dc2] Questions et aide » Plugin Dotmap et thème Qrazy Times » 2009-09-30 17:34:41

Malheureusement cela n'a pas l'air de suffire. Google map est encore par dessus

#11 Re : [dc2] Questions et aide » Plugin Dotmap et thème Qrazy Times » 2009-09-30 06:26:10

J'ai encore un petit souci :

Les cartes google map viennent se mettre par dessus les menus déroulants : par exemple essayez de dérouler le menu "Europe" sur cette page :
http://www.carnets-de-traverse.com/dotc … a-Takayama
et vous ne voyez pas "Italie", qui est le dernier item.

Vous croyez qu'il y a moyen de faire passer le menu par dessus tout ça ?

#12 Re : [dc2] Questions et aide » Plugin Dotmap et thème Qrazy Times » 2009-09-28 06:48:48

Bonjour David
Merci énormément, ça marche. Bizarrement puisque ça reprend un titre "Archive" et me met une colonne de droite étrange, mais ça marche !
http://www.carnets-de-traverse.com/dotc … otmap.html

Je désespérais un peu...!

#14 Re : [dc2] Thèmes » [Nouveau Thème] Qrazy Times » 2009-09-27 16:01:46

Ce n'est pas une question de typo puisque cela marchait avant que je mette à jour firefox, ni de cache... c'est assez mystérieux
Si quelqu'un a une idée un de ces 4, je suis preneuse.

Bien à vous

#15 Re : [dc2] Questions et aide » Plugin Dotmap et thème Qrazy Times » 2009-09-27 15:54:12

il me vient une idée

croyez-vous que cela pourrait provenir de la méthode de lecture de l'URL ? je suis en query string

#16 Re : [dc2] Questions et aide » probleme path info billet : Document non trouvé » 2009-09-27 15:51:51

Bon pour info et pour ceux qui aurait fait la même bêtise, ça remarche en mettant un "?" à la fin de l'adresse :

Nom du blog : http://www.carnets-de-traverse.com/dotclear/index.php?
Méthode de lecture de l'URL : QUERY STRING

Dites-moi à votre avis, cela peut poser un problème plus tard ? C'est peut-être trop de la bidouille...

Et du coup si je veux changer mon répertoire DOTCLEAR en BLOG, il faut que je réinstalle tout ? C'est ce que je voulais faire à la base et que je n'ai pas réussi.

Merci d'avance pour votre aide précieuse.

Lilou

#17 Re : [dc2] Questions et aide » probleme path info billet : Document non trouvé » 2009-09-27 15:43:59

J'ai fait un test en mettant PATH_INFO et en ajoutant "index.php" dans l'URL du blog :

URL du blog : http://www.carnets-de-traverse.com/dotclear/index.php/

Et là, les pages s'affiche mais avec des bugs (le plugin dotmap ne marche plus, mon logo n'apparaît plus...
C'est étrange !

Est-ce un problème de "Méthode de lecture de l'URL" à votre avis ?

#18 Re : [dc2] Questions et aide » probleme path info billet : Document non trouvé » 2009-09-27 15:14:45

Bonjour,

J'ai peut-être un problème similaire...

Voilà je voulais renommer le répertoire contenant mon blog. Avant, le blog était ici : http://www.carnets-de-traverse.com/dotclear

J'ai voulu changer le nom de ce répertoire en "blog", ce qui aurait donné : http://www.carnets-de-traverse.com/blog

J'ai donc renommé mon dossier sur le FTP (à la barbare!), et changé : "URL du blog", dans "Paramètres du blog" depuis le back-office, ainsi que l'adresse du favicon.
Dans le même temps je suis passé en PATH_INFO alors que j'étais en QUERY STRING jusque là.

Là plus rien n'a fonctionné, et cela m'a fait peur alors j'ai vite tout remis comme avant...!! J'ai renommé le dossier sur le FTP "blog" en "dotclear" et rechangé les paramètres que j'avais changé dans "Paramètres du blog".

Mais malheureusement, maintenant je n'ai plus que la page d'accueil qui fonctionne. Toutes les autres pages me font une erreur du type :

"Not Found
The requested URL /dotclear/post/2009/09/Les-tapas-de-Takayama was not found on this server."

Et là je ne sais pas comment réparer.
Si quelqu'un peut m'aider svp !

#19 Re : [dc2] Questions et aide » Plugin Dotmap et thème Qrazy Times » 2009-09-21 08:07:02

Je n'ai pas de réponse de l'auteur du plugin, si quelqu'un a une idée... ?

Bonne journée

#20 Re : [dc2] Thèmes » [Nouveau Thème] Qrazy Times » 2009-09-20 12:03:28

Lomalarch a écrit :

Oui, l’idée était que le cache navigateur (pas le cache des templates, hein) pouvait n’être pas vidé… En ce cas, ça peut effectivement être un souci de typo, mais, à moins que tu utilises une version très exotique d’Helvetica ou Arial, ça semble curieux :-/

oui c'est bizarre !

#21 Re : [dc2] Thèmes » [Nouveau Thème] Qrazy Times » 2009-09-20 12:01:40

Ca marche chez un copain aussi, pour les flèches (avec toujours la même version de Firefox). Vous avez une idée du pourquoi cela ne marche pas chez moi ?

#22 Re : [dc2] Thèmes » [Nouveau Thème] Qrazy Times » 2009-09-19 21:18:45

Merci Lomalarch
Ca alors... qu'appelle-tu problème de cache ? En tous cas j'ai l'ai vidé mais cela ne change rien.

#23 Re : [dc2] Thèmes » [Nouveau Thème] Qrazy Times » 2009-09-19 16:26:16

djouls, moi je n'ai pas de scrollbar mais je suis sous firefox 3.5.3...

dites, d'ailleurs, les "puces" en forme de flèche ont disparues avec la mise à jour de firefox !
Il faut installer une police ??
sous safari ca marche par contre

Je parle des caractères :   ? ,? et ?
(tiens en faisant copier coller, ca marche ici... ?)

Ca vient d'ou à votre avis ?

#25 Re : [dc2] Thèmes » [Nouveau Thème] Qrazy Times » 2009-09-18 13:20:10

salut djouls
je suis sous firefox 3.5.3 et rien ne s'affiche quand je clique sur ton lien (???), ni dans safari 4.0.3

Vous n'êtes pas identifié(e).

Pied de page des forums

Propulsé par FluxBB

Sites map