Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 Re : Multilingual » Upgrading from PHP 5.3.9 to PHP 5.4.0 » 2012-09-24 08:36:01

Hi,
Just for information, same error occurs with DC 2.4.4 and PHP 5.4.4 here. Ritsu's patch works fine and saved my day, many thanks!

Salut,
Juste pour info, la même erreur se produit avec DC 2.4.4 et PHP 5.4.4 chez moi. Le patch de Ritsu fonctionne et m'a évité de m'arracher tous les cheveux devant la page "widgets" blanche, un grand merci donc !

Giu_

#2 Re : [dc2] Installation et hébergement » Multiblog : thèmes trouvé mais ne s'affiche pas…? » 2011-07-20 17:55:04

@pierrevg : merci pour ta réponse. Je sais bien où se trouve ma CSS. Peut-être mon message est-il confus : le problème est que la CSS n'est pas lue… alors que Dotclear "voit" pourtant les thèmes correctement.

#3 [dc2] Installation et hébergement » Multiblog : thèmes trouvé mais ne s'affiche pas…? » 2011-07-16 15:57:33

giuseppebergman
Réponses : 3

Bonjour à tous,

Je me tourne vers vous avec un problème que j'essaie de résoudre depuis plusieurs jours maintenant.

Les infos :
- Clean install de dotclear 2.3.1 dans un dossier "blog",
- Mon hébergement fonctionne avec un dossier htdocs, dans lequel pointe www.mondomaine.com
- "blog" est au même niveau qu'htdocs, l'adresse du blog est donc http://blog.mondomaine.com/index.php/
Jusqu'ici, pas de souci.

Je veux faire un deuxième blog, à l'adresse http://ion.mondomaine.com/index.php/
- j'ai créé le dossier "ion" au même niveau que "blog", y ai créé les sous-dossiers "public" et "themes", et copié le dossier "default" d'origine dans ce nouveau "themes".
- j'ai créé le sous-domaine http://ion.mondomaine.com auprès de mon hébergeur.
- j'ai créé une deuxième blog dans l'admin, "ion".
- public_path et themes_path sont respectivement renseignés comme suit : "../ion/public" et "../ion/themes", et leurs url sont "/ion/public" et "/ion/themes"

Lors de mes précédents essais, avant de modifier les _path et _url comme indiqué ci-dessus, Dotclear m'affichait un message d'erreur comme quoi le thème par défaut était introuvable.
Une fois about:config modifié, je n'ai plus ce message, et le contenu du blog apparaît, mais aucune mise en forme n'est appliquée (pas d'image, pas de couleur de fond, juste du texte sur fond blanc).
Dans l'admin, je voix les deux thèmes installés dans ion/themes ("Blowup" et "aorakit-4A-ion"), je peux les sélectionner, mais cela ne change rien à l'apparence du blog.

Une précision qui est peut-être le cœur de mon problème :
Quand j'essaie d'éditer mon thème via l'admin :
- quand je clique sur "feuille de style", une 404 s'affiche : dotclear cherche le fichier à l'adresse http://ion.etplusencore.com/ion/themes/ … /style.css (le deuxième ion semble en trop…)
- quand je clique sur "Editeur de thèmes", je vois bien tous mes fichiers templates et CSS, mais les CSS sont vides (style.css et layout.css, + deux sauvegardes perso de ces fichiers) alors que les .html s'affichent correctement. Le moteur trouve donc les uns mais pas les autres…??

Grand mystère pour moi, apparemment les fichiers CSS sont trouvés mais ne sont pas lus !

Une idée ?

Merci par avance de toute l'aide que vous pourrez m'apporter.

#4 Re : [dc2] Questions et aide » Blog invisible après changement d'URL [détresse!] » 2010-03-04 17:14:29

Ok… en fait de bug, c'est plutôt Safari qui accuse… Dans Firefox le site s'affiche, et dans Safari également après l'avoir relancé. Je me sens encore plus bête qu'avant.

Désolé pour la pollution, que les modos se sentent libres d'effacer ce fil.

Merci à l'équipe Dotclear pour leur travail !

#5 Re : [dc2] Questions et aide » Widget "Derniers billets" : changer l'ordre d'affichage » 2010-03-04 16:06:53

Oh ! Ça fait un bail que je ne suis pas passé par ici, je viens de voir ta réponse, JcDenis ! Merci, je vais me pencher sur tes widgets dès que mon blog sera de nouveau sur pieds (grosse bourde aujourd'hui) :/

#6 [dc2] Questions et aide » Blog invisible après changement d'URL [détresse!] » 2010-03-04 16:04:24

giuseppebergman
Réponses : 2

Bonjour à tous,

Je sentais bien venir la bourde, mais je l'ai faite quand même.

Je précise que mes connaissances sont très… légères en la matière. Voilà l'histoire :

1- J'ai voulu déplacer mon http://blog.chezmoi.com vers http://www.chezmoi.com/blog
2- J'ai créé le deuxième répertoire "blog", et y ai copié le contenu du premier (qui était celui par défaut créé par l'installation "clean").
3- Dans les paramètres du blog, j'ai modifié "URL du blog", changeant http://blog.chezmoi.com/index.php? (il me semble…? c'était l'url par défaut) en http://www.chezmoi.com/blog/index.php?
4- Évidemment, ça n'a pas fonctionné (mais à quoi avais-je la tête !?…)
5- J'ai donc remis l'URL de départ, http://blog.chezmoi.com/index.php?
6- Mais le blog ne s'affiche plus. Ou bien est-ce seulement le contenu ?

Si ça peut aider, le blessé est ici : http://blog.etplusencore.com/

Bref, quiconque pourra me sortir de cette très mauvaise passe dans laquelle je me suis engagé tout seul aura ma gratitude éternelle… HELP!

Giu_

#7 Re : [dc2] Questions et aide » Widget "Derniers billets" : changer l'ordre d'affichage » 2009-08-25 17:34:25

Ça m'étonne pas de moi ça. Merci pour la correction ! Ça peut être une solution provisoire, donc. Merci encore.

#8 Re : [dc2] Questions et aide » Widget "Derniers billets" : changer l'ordre d'affichage » 2009-08-25 16:27:54

Wow… la tâche s'annonce plus ardue que prévue pour la bille en développement que je suis… je crois bien que je vais les laisser tels quels pour l'instant… D'autant plus que le widget texte ne peut afficher de liens, si je ne m'abuse — comme navigation on a vu mieux-)
Merci pour ta réponse, Kozlika ! Je posterai de nouveau ici si j'ai des nouvelles.

#9 [dc2] Questions et aide » Widget "Derniers billets" : changer l'ordre d'affichage » 2009-08-22 12:18:02

giuseppebergman
Réponses : 6

Bonjour à tous,

Après moult recherches sur ce forum et ailleurs, je ne parviens pas à trouver la réponse à cette question : dans quel fichier puis-je modifier l'ordre d'affichage des posts listés dans le widget “Derniers billets", (sans changer celui en Home et ailleurs) ? Impossible de trouver…

Merci par avance, et désolé si cette question a déjà été évoquée ici, je n'ai pas réussi à la trouver.

Bonne continuation à tous, et bravo pour cet excellent moteur de blog.

Vous n'êtes pas identifié(e).

Pied de page des forums

Propulsé par FluxBB

Sites map