Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 Re : [dc2] Installation et hébergement » .htacces .ovhconfig compression ovh perso mutu » 2015-07-12 13:10:03

Bonjour,

merci pour l'info sur le fichier ovhconfig, j'ai ainsi pu régler l'accès qui était devenu trop lent pour 2 de mes sites.

Mais j'en ai d'autres qui ont été créés avec des anciennes versions de Dotclear (2.3.1 à 2.4.4) qui fonctionnent correctement en php5.6 sauf... la mise à jour des widgets dans le tableau de bord : impossible d'y accéder, rien n'apparaît dans la barre adresse quand on clique sur l'icône du TDB, et rien ne se passe.
Je sais qu'il faudrait passer à des versions plus récentes de Dotclear, mais mes essais sur un de mes sites n'ont pas été couronnés de succès car je ne sais plus très bien quels sont les modules que j'ai adaptés (peu, mais il suffit d'un, n'est-ce pas ?).
Ma question : où puis-je trouver le lien qui est utilisé par l'icône du TDB pour afficher le formulaire de mise à jour des widgets ?
Merci de m'aider, ça me permettra d'avoir le temps de revoir ces sites (5 en tout, tous faits bénévolement pour des assos) sans être bousculé par l'échéancier OVH.

Cordialement,

#2 Re : [dc2] Plugins » ContactMe et Accessible Captcha » 2015-05-12 09:54:03

Bonjour,

je relance le sujet car j'utilise accessible captcha pour les commentaires et j'ai deux soucis :
- la position juste avant le bouton Envoyer n'est pas idéale car, une fois le commentaire rempli, les visiteurs passent directement sur Envoyer
- si la question n'a pas la bonne réponse, le visiteur n'est pas informé qu'il doit corriger et le commentaire n'est pas envoyé, il est donc perdu.

Une solution à ces problèmes ?

#3 Re : [dc2] Questions et aide » Délai d'accès aux images du gestionnaire de médias » 2013-03-19 23:39:04

D'autres problèmes chez OVH :

- j'avais ouvert un ticket sur la question des ralentissements, et en voulant envoyer un nouveau message dans ce ticket, je bascule sur un de mes autres comptes chez eux avec, bien sûr, refus car ce n'est pas le compte du ticket d'origine.
- j'ai reçu récemment un mail m'informant d'une connexion au manager d'un compte que je ne connais pas... Oups !
- il semble qu'on ne puisse plus s'inscrire sur leur forum (pour poster).

C'est bien compliqué tout ça !

#4 Re : [dc2] Questions et aide » Délai d'accès aux images du gestionnaire de médias » 2013-03-15 16:23:08

pacha35 a écrit :

Quant à moi, toujours en 2.2, mais le passage en 2.4 ou ultérieur est un peu compliqué - l'installateur automatique me met beaucoup de plugins (officiels) en anomalie - ...

OK. Pour préparer ton update, on pourrait peut-être faire un point en l'état sur ton install actuelle. Qu'entends-tu par "l'installateur automatique me met bcp de plugins en anomalie" ?

faut-il que j'ouvre un autre sujet pour discuter de cette question ? J'ai un fichier texte avec tous les messages d'erreurs de la migration automatique, comment l'envoyer (autrement qu'en le recopiant dans le sujet ?

#5 Re : [dc2] Questions et aide » Délai d'accès aux images du gestionnaire de médias » 2013-03-13 17:35:00

Quant à moi, toujours en 2.2, mais le passage en 2.4 ou ultérieur est un peu compliqué - l'installateur automatique me met beaucoup de plugins (officiels) en anomalie - c'est de plus en plus lent, mais, plus d'erreurs 500 pour le moment, ce qui est quand même un plus.
Lorsque la 2.5 sortira je ferai la migration manuelle en espérant ne rien perdre en passant (après un sauvegarde complète base et processes).

C'était les infos du jour.

#6 Re : [dc2] Questions et aide » Délai d'accès aux images du gestionnaire de médias » 2013-03-06 11:03:31

Bonjour,

j'ai testé les patches sur ma version 2.2 et plantage au lancement de Dotclear avec le message suivant :

Fatal error: Class 'dcPostMedia' not found in /homez.9/sermonvi/www/lemordelais/dotclear2/inc/core/class.dc.media.php on line 59

#7 Re : [dc2] Questions et aide » Délai d'accès aux images du gestionnaire de médias » 2013-03-04 19:29:58

pierrevg a écrit :

...

http://www.lemordelais.fr/ c'est ton blog ? Pourquoi ne pas l'indiquer dans ton profil ?
Déjà, je pige pas trop l'intérêt de mettre ton blog dans une frame, bourrée d'erreurs de code en plus. Ça apporte quoi ?

Ensuite, faudrait aussi corriger les erreurs de code dans dotclear, réduire les images en grand qui sont démesurées. Tu gagneras en poids au moins...

Tu peux aussi régler le nombre de billets par page à autre chose que 20, ta page d'accueil est bien longue à scroller.

Ton code statcounter, en sus d'être mal placé, n'est pas un foudre de guerre...

...

Bonjour,

oups ! j'en ai pris plein la musette sur ce coup. Quelques explications :

- je n'ai pas indiqué ce site dans mon profil parce que j'en gère plusieurs, tous faits sur le même modèle (ancien et critiquable, je sais), mais qui ne m'a jamais posé de problème depuis près de 15 ans chez OVH.
Le site internet gérant d'autre chose que le blog Dotclear, ceci explique qu'il y est encapsulé.
Je sais qu'il faudra un jour que je refasse mon menu, mais il marche bien, alors j'attends d'avoir plus de temps et plus de compétences. En tous les cas ce n'est pas ça qui est générateur des erreurs 500.
- images "en grand" ? J'utilise lightbox et les images zoomées sont en 800x600, je ne trouve pas ça grand, est-ce de celles-là qu'il s'agit ?
- erreurs de codes dans Dotclear ? J'utilise un html basique (mode source) quand ça ne passe pas en mode normal.
- nombre de billets par page : c'est voulu pour car je me suis aperçu (en faisant une petite enquête) que les lecteurs "scrollaient la Une, mais cliquait rarement sur les pages précédentes. Je corrigerai ça si ça résout les problèmes actuels.
- le code statcounter : quelle est la meilleure place ?

Merci donc de vos conseils et soyez indulgents.

Question : y a t-il un optimum pour le nombre d'images dans un répertoire du gestionnaire de média

#8 Re : [dc2] Questions et aide » Délai d'accès aux images du gestionnaire de médias » 2013-03-04 16:52:23

Bonjour,

voici la dernière réponse d'OVH :

De notre coté nous continuons à améliorer le temps de réponse des serveurs mutualisé.
Toutefois, il est également possible de réaliser quelques optimisations sur votre site que vous trouverez sur le lien suivant:
http://gtmetrix.com/reports/www.lemordelais.fr/dBH8j2ub

Cordialement, 
Philippe.

Je suis allé voir le lien, mais j'avoue ne pas y comprendre grand chose.
Peut-être qu'un "sorcier" pourra en tirer une indication utile.

PS : peut-on, sur ce forum, être informé par mail lorsqu'une réponse est postée sur ce sujet ?

#9 Re : [dc2] Questions et aide » Délai d'accès aux images du gestionnaire de médias » 2013-03-02 09:21:52

Bonjour,

"le canard est toujours vivant..."
Ce matin j'ai ajouté quelques images dans le gestionnaire de médias, c'est lent, très lent et après quelques manipulations diverses (modification des titres), erreur 500.

- Concernant le patch, je l'avais essayé dès sa sortie sur ce forum mais ça n'avait pas marché (peut-être une fausse manip de ma part) : je vais essayer à nouveau.

- Concernant le passage à la dernière version, j'avoue avoir un peu peur de casser mon blog (journal local bénévole qui commence à être bien lu), je vais attendre la version officielle. Mais je peux essayer la 2.5 sur un autre blog "moins délicat" si ça peut aider.

#10 Re : [dc2] Questions et aide » Délai d'accès aux images du gestionnaire de médias » 2013-02-27 11:21:33

voici la dernière réponse d'OVH suite à mon étonnement concernant leur mail automatique mettant en cause un script de Dotclear :

Bonjour,

Le soucis que vous rencontrez est lié à une contrainte technique sur les robots de sécurité sur les hébergement mutualisé.
Nous corrigeons le soucis.
Merci d'ignorer ce message, il ne s'agit pas d'attaque depuis ou vers votre site.
Nous nous excusons de la gène occasionnée.

Cordialement, 
Philippe.

Rassurant (pour moi).

NB : non, il n'y a pas qu'un seul utilisateur de Dotclear chez OVH qui a des problèmes avec le gestionnaire de média (très lent et erreurs 500) : je les ai aussi.

#11 Re : [dc2] Questions et aide » Délai d'accès aux images du gestionnaire de médias » 2013-02-27 06:31:38

Bonjour,

je viens de recevoir la même réponse d'OVH. Ce qui me surprend c'est que par ailleurs, en réponse au ticket d'incident que j'ai ouvert, il est indiqué :

---------------------------------------------------------------------------------
Commentaire de OVH - samedi, 16 février 2013, 10:36

http://forum.ovh.com/showthread.php?t=86797

Bonjour,
Comme expliqué dans
http://forum.ovh.com/showthread.php?t=86728
nous avons modifié le type de répartition de charge
qui permet délivrer une meilleure performance sur
les sites dynamique comme CMS ou PrestaShop.

Certains d'entre vous ont par contre des erreurs
500 dû à l'intervention d'okillerd qui surveille qu'un
site ne prennent pas trop de ressources par rapport
aux autres:
http://forum.ovh.com/showthread.php?t=86791

On va améliorer l'information de la part d'okillerd
cette semaine afin de mieux vous prévenir que
vous êtes à la limite ou au delà de la limite d'un
plan. Nous avons aussi un problème interne dû
à de sites qui bourrinent trop: parfois il peut
arriver qu'un site casse l'un de serveur et rende
l'ensemble de sites qui utilisent le même serveur
down. Vous aurez alors de erreurs 500 alors que
vous n'y êtes pour rien: okillerd fait le max mais
n'est pas très précis
On doit améliorer le code d'okillerd qui n'a pas
été prévu pour ce type de répartition de charge.

En attendant, nous sommes repassé sur l'ancien
type de répartition de charge.

Amicalement
Octave
-----------------------------------------------------------

que faut-il en penser ?

#12 Re : [dc2] Questions et aide » Délai d'accès aux images du gestionnaire de médias » 2013-02-21 17:00:59

Bonjour,

j'ai fait de nouveaux essais d'utilisation du gestionnaire de médias après les dernières évolutions chez OVH : c'est lent et au bout de quelques médias ajoutés, erreur 500.
Mais il semble qu'ils y travaillent encore. Patience !

Concernant le patch proposé, étant en DC 2.2 sur mon site, est-il utilisable ?
Merci d'avance pour votre réponse.

#13 Re : [dc2] Questions et aide » Délai d'accès aux images du gestionnaire de médias » 2013-02-19 13:10:12

Bonjour,

voici la réponse d'OVH de cet après-midi :

Bonjour,

De notre coté nous continuons à améliorer les performances de nos serveurs mutualisé:
http://travaux.ovh.com/?do=details&id=7959
http://travaux.ovh.com/?do=details&id=8038
http://travaux.ovh.com/?do=details&id=8039

Cordialement, 
Philippe.

Conclusion, le défaut est bien constaté par OVH et ils travaillent pour le résoudre.

#14 Re : [dc2] Questions et aide » Délai d'accès aux images du gestionnaire de médias » 2013-02-18 23:22:37

Voici la réponse d'OVH reçue hier (CF ma question plus haut) :

"Bonjour,

Navré pour la réponse tardive.
Je vous informe que votre site est bien accessible de notre coté, aucun problème dans la navigation n'a été rencontré, aucune erreur rencontré.
Le soucis ne doit plus se présenter.

Cordialement, 
Philippe."

J'ai donc relancé mes mises en page d'images via le gestionnaire de médias et... ça marche un peu mieux. Je m'explique :
- c'est toujours très lent (entre 5 et 10s) et ça ne se plante plus systématiquement en erreur 500, mais "de temps en temps).
Je vais donc écrire tout ça à OVH.

#15 Re : [dc2] Questions et aide » Délai d'accès aux images du gestionnaire de médias » 2013-02-14 17:01:17

Je viens d'avoir la réponse suivante d'OVH :
-----------------------------------------------------------
De : Philippe B.
Pour :
Date : 2013-02-14 15:41:23


Bonjour,

Le problème rencontré est relatif à    la tâche travaux
suivante:
http://travaux.ovh.com/?do=details&id=8057
http://travaux.ovh.com/?do=details&id=8056
Nous nous excusons de la gène occasionnée.

Cordialement, 
Philippe.

Les deux adresses pointent sur les voyants d'incidents en cours indiquant bien que les serveurs mutualisés sont en cause et qu'OVH travaille sur la résolution de leurs problèmes : l'espoir remonte !

#16 Re : [dc2] Questions et aide » Délai d'accès aux images du gestionnaire de médias » 2013-02-14 10:57:03

Bonjour,

depuis hier soir, les erreurs 500 bloquant le gestionnaire de média (dotclear 2.2) sont systématiques : la gestion du blog devient impossible.
J'ai mis un ticket incident chez OVH (serveur mutualisé) et j'attends la réponse.
J'ai lu le post sur leur pb de serveurs mutualisés, j'espère que la solution viendra de là.
A noter qu'il semble qu'on ne puisse plus s'inscrire sur leur forum ("inscriptions interdites par l'administrateur").

La dégradation de l'usage du gestionnaire de média a été progressive et rapide (1 semaine pour arriver à un blocage quasiment systématique).
Mon serveur DC n'a subit aucune modification depuis sa création il y a presque 2 ans, juste des créations de billets et d'images.
J'ai d'autres serveurs DC chez OVH, toujours en mutualisé, et, pour le moment, pas de problème, mais ils sont plus informatifs et bougent peu. Celui-ci est mis à jour quotidiennement mais il me semble être encore loin des valeurs indiquées ici et là sur le forum.

Je pensais, mais je ne suis pas expert, que ce type de dégradation avait pour origine l'hébergeur qui travaille beaucoup sur ses serveurs. Mais j'ai trouvé aussi, en fouillant sur le web, des posts concernant  "erreurs 500" chez d'autres hébergeurs (1&1 par exemple).
Difficile donc de se faire une idée précise, et je crains que nous soyons dans un problème complexe où, l'hébergeur, mais aussi peut-être du code dans Dotclear (code de base et/ou plugins), ne sont pas "totalement compatibles". Si c'est le cas, on n'est pas "sortis de l'auberge" car il faudrait un travail commun entre les deux (OVH et Dotclear) pour arriver à une solution.
Mais, je reconnais que ce ne sont que des suppositions générées par mon inquiétude de voir mon blog (un journal bénévole local) devenir inopérant.

Merci de votre écoute.

NB : j'ai un fichier .htaccess avec, en plus de l'option "SetEnv PHP_VER 5",  la ligne "Options -Indexes", mais avec ou sans, c'est la même chose

#17 Re : [dc2] Questions et aide » Délai d'accès aux images du gestionnaire de médias » 2013-02-09 17:49:23

Bonjour,

j'ai également ce problème de grande lenteur dans le gestionnaire de médias (jusqu'à 20s) ainsi que des plantages en "internal error 500". J'ai exposé ce problème dans un autre post demandant si je pouvais facilement séparer mon blog en deux pensant qu'il était trop gros, mais il semble que je sois loin des limites.
Je confirme donc mes difficultés avec le gestionnaire de média depuis le début de l'année semble-t-il.
Je suis en environnement mutualisé chez OVH. Mon blog est encore en 2.2 mais à lire différents posts, ça ne semble pas être lié à cette version.
J'ai d'autres blogs Dotclear chez eux (en 2.4) sans aucun problème.

#18 Re : [dc2] Questions et aide » Séparer son blog en deux » 2013-02-09 13:52:55

Tout à fait d'accord, je vais donc continuer sur le fil des performances puisque c'est l'origine de mes problèmes.
On peut clore celui-ci (le découpage du blog).

Merci à tous.

#19 Re : [dc2] Questions et aide » Séparer son blog en deux » 2013-02-09 13:13:39

OK je vais voir dans l'autre post.
Mathieu M., tu es chez quel hébergeur ?

#20 Re : [dc2] Questions et aide » des clearbricks, des error et admin inaccessible » 2013-02-09 13:10:04

Bonjour,

j'ai également ce problème de grande lenteur dans le gestionnaire de médias (jusqu'à 20s) ainsi que des plantages en "internal error 500". J'ai exposé ce problème dans un autre post demandant si je pouvais facilement séparer mon blog en deux pensant qu'il était trop gros, mais il semble que je soit loin des limites.
Je confirme donc mes difficultés avec le gestionnaire de média depuis le début de l'année semble-t-il.
Je suis en environnement mutualisé chez OVH. Mon blog est encore en 2.2 mais à vous lire ça ne semble pas être lié à cette version.
J'ai d'autres blogs Dotclear chez eux (en 2.4) sans aucun problème.

#21 Re : [dc2] Questions et aide » Séparer son blog en deux » 2013-02-09 11:16:21

Peux-tu me dire ce qui te fait penser que c'est un bug chez OVH ?
Je gère une dizaine de sites chez eux dont pas mal de blogs dotclear, et je n'ai de problème de performances qu'avec celui-ci et seulement dans le gestionnaire de média.

Peut-être une piste : c'est le seul blog qui est encore en version 2.2 (j'ai fait quelques modifs que j'ai peur de perdre en le passant en 2.4).

Autre chose : je n'ai encore jamais utilisé les options de "maintenance" : est-ce une solution aux performances?

#22 Re : [dc2] Questions et aide » Séparer son blog en deux » 2013-02-09 10:13:22

Merci pour l'idée, c'est une bonne piste que je vais regarder de plus près.

Mais, je me demande si ça résoudra mon problème de performance avec le gestionnaire de médias. En effet, depuis que j'ai passé les dossiers à 755, j'ai systématiquement une "internal error 500" dès que je veux modifier une photo (par exemple modifier le titre pour qu'il ne soit pas égal au nom du fichier).

...

Je viens d'enlever "Options -Indexes" du fichier htaccess qui est à la racine de dotclear (pas celui qui est à la racine du site) et "l'internal error" semble avoir disparue - ouf !
Mais les manipulations du gestionnaire de médias sont très très lentes (15 à 20 secondes pour modifier le titre d'une photo).

#23 Re : [dc2] Questions et aide » Séparer son blog en deux » 2013-02-09 09:01:21

Merci pour vos remarques.

J'ai mis 755 à tous les dossiers de dotclear et j'ai revalidé "mymeta" et "miniseo" : à priori, les erreur n'apparaissent plus.
A suivre donc car je n'ai pas tout balayé.

Pour ce qui concerne le découpage "facile" d'un blog Dotclear en 2, pas de solution?

#24 Re : [dc2] Questions et aide » Séparer son blog en deux » 2013-02-08 18:55:49

J'ai lu le topic sur le ralentissement, mais je n'ai pas trouvé de réponse satisfaisante d'où ma demande pour couper mon bloc en deux.
Les lenteurs constatée sont  > à 15s dans le gestionnaire de medias

Le lien pour le blog : http://www.lemordelais.fr/dotclear2

Concernant le htaccess, je l'ai mis à la racine du site (le blog est inclus dans le site internet : http://www.lemordelais.fr).
il contient exactement les paramètres suivants :
  SetEnv PHP_VER 5_TEST
  SetEnv REGISTER_GLOBALS 0
  Options -Indexes
Il y en a un également dans le répertoire dotclear2 qui contient "SetEnv PHP_VER 5".
Il n'y en a pas d'autre.

J'ai également, de temps en temps une "internal error 500" en travaillant sur le gestionnaire de médias.
OVH indique que ça peut venir d'un htaccess incorrect ou de droits d'accès incorrects aux dossiers et fichiers la limite étant 755. Effectivement, 2 dossiers dotclear2, "cache" et public ont été générés avec 777 : faut-il les ramener à 755 comme le préconise OVH?

Merci de votre intérêt

#25 [dc2] Questions et aide » Séparer son blog en deux » 2013-02-08 10:27:08

pacha35
Réponses : 18

Bonjour,

un de mes blogs, hébergé chez OVH,  devient très lent en ce qui concerne le manager, pas son accès par les visiteurs.
Supposant que ça peut venir du nombre d'articles et de médias, j'aurai aimé pouvoir le scinder en deux. Je n'ai pas trouvé de question à ce sujet.
Est-ce possible, et si oui, y-a-t il une procédure automatisée qui inclurait bien sur la base de données ?

Merci de vos réponses

PS : j'ai du mettre un htaccess "options -Indexes" pour éviter que l'arborescence du site soit visible. Depuis, j'ai du enlever les plugins mymeta et miniseo qui me généraient des erreurs. Je ne sais pas si c'est lié à mon problème de ralentissement.

Vous n'êtes pas identifié(e).

Pied de page des forums

Propulsé par FluxBB

Sites map