Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-08 18:37:25

Bon. Je ne sais pas si je dois m'en réjouir mais cela est tombé en marche en modifiant l'url du site saisi dans les paramètres du blog :
J'ai saisi http://je-mattarde.com/index.php? au lieu de http://www.je-mattarde.com/index.php?

Est ce normal de devoir enlever les "www." ?

#2 Re : [dc2] Bugs » Les commentaires ne sont pas enregistrés » 2021-02-08 16:13:51

Active temporairement un thème non modifié : Blowup, Berlin ou Ductile livrés avec la version 1.8
et vérifie que tu peux envoyer des commentaires avec ces moutures. Si c'est le cas, il faudra te pencher sur les modifications que tu as apporté à ton thème.

#3 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-08 15:59:31

Merci Philippe.

J'avais dû laisser tomber le basculement vers la méthode d'url PATH_INFO puisque :
- je suis toujours configuré en QUERY_STRING
- je ne trouve pas de fichier web.config (l"équivalent de htaccess pour IIS) qui pourrait opérer une redirection

Philippe a écrit :

Lorsqu'on tente de poster un commentaire, une redirection est opérée vers la racine du blog, à tort manifestement. Reste à savoir ce qui la provoque, mais je ne connais pas du tout IIs, et ne pourrai pas vous aider pour ce type de serveur, désolé.

Est-ce qu'il ne faudrait pas que je traduise les règles que vous avez écrite pour DoubleZoe dans le format xml de web.config afin de faire la "bonne" réécriture d'url?

#4 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-08 14:10:06

Ah mer... !!!
Je viens de me souvenir que j'avais déjà fait quelque chose autour de ça en 2011 : https://forum.dotclear.org/viewtopic.php?id=45763

Mon blog est sur un serveur web IIS et non pas Apache.

#5 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-08 14:01:00

Bonjour Philippe, trouvé dans /httpdocs/inc/ et voici le contenu :

# Apache 2.2
<IfModule !authz_core_module>
  Deny from all
</IfModule>

# Apache 2.4+
<IfModule authz_core_module>
  Require all denied
</IfModule>

Vous pensez que je peux utiliser les lignes de la règle que vous avez indiqué à DoubleZoe ?

#6 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-08 08:49:46

Je suis passé à côté de ce fil lors de mes recherches sur le forum :
https://forum.dotclear.org/viewtopic.ph … 16#p310016

Je vérifierai ce soir le contenu de mon fichier .htaccess si ce dernier n'est pas en cause comme pour DoubleZoe.

Cependant je ne sais pas ce que je dois m'attendre à y trouver, la documentation dotclear associée à ce fichier est brève :
https://fr.dotclear.org/documentation/2 … g/htaccess
Pouvez-vous me dire quel est le contenu par défaut de ce fichier suite à l'installation d'un blog ?

#7 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-07 13:45:08

Le dernier commentaire passé était en novembre 2019. On ne s'était pas spécialement étonné d'avoir aucun commentaire en 2020 de nos visiteurs. Cela coïnciderait avec la mise à jour Dotclear 2.15.3 qui corrige :

   

Effet de bord avec le compresseur de script javascript
    Insertion d'un média non image, vidéo ou audi dans une entrée au format XHTML
    Gestion de la case à cocher « Se souvenir de moi » pour les vieux thèmes

Ce peut-il que cette correction sur le "compresseur de script javascript" soit en cause ?

#8 Re : [dc2] Bugs » Les commentaires ne sont pas enregistrés » 2021-02-07 12:20:55

Bonjour Pollux, peux tu apporter des éléments supplémentaires : thème utilisé, url de ton blog, le paramétrage du blog (Méthode de lecture de l'URL, bibliothèque jquery activée dans la section Paramètres du blog,...)

#9 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-07 12:15:04

Je me demande si le bug de Pollux (coincidence étrange) remonté aujourd'hui ne pourrait pas être le même problème que sur notre site.

Pour résumé, ce qui a déjà été testé :
- remplacer les dossiers dans httpdocs/themes/ et /allblogs/ par les thèmes non modifiés de l'archive 1.18
- activation du theme ductile et blowup non modifié
- vidage du cache des templates
- désactivation de TOUS les plugins

Rien y fait, les commentaires ne fonctionnent toujours pas.
(je suis revenu à notre thème provisoirement en attendant d'autres idées)

#10 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-06 20:07:42

De mémoire, tester d'abord :

connexion admin, en bas, undefined-pb de connexion -> me connecter en mode sans echec
=>  Vous êtes en mode de secours. Tous les plugins ont été temporairement désactivés.

Pas trouvé.


Mais il y a un bouton pour désactiver TOUS les plugins dans la page des plugins. Je les ai donc TOUS désactiver. Mais la prévisu et l'envoi des commentaires ne fonctionnent toujours pas.
C'est embêtant.

#11 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-06 17:09:47

La liste des plugins est longue, 40 en tout !!
Je vais voir si en les désactivant cela s'arrange...

nanart a écrit :

--> amha ductile n'est pas en cause

Merci beaucoup pour vos tests en local.
J'aurais fais la même chose mais cela fait longtemps que je n'ai plus une copie de mon site en exécution en local sur wamp. Merci donc

C'est curieux quand même ce bug. Les fichiers .js ne sont pas en cause ? Les fichiers js sont dans les dossiers des thèmes ?

#12 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-06 17:02:32

A propos des modifications de thème, cela remonte à loin en terme d'années.
Mes souvenirs sont : j'avais copié le dossier du thème dotclear et apporté des modifications aux fichiers css.
Le plus gros ajout est à voir côté du côté de la page Chroniques qui permet d'avoir un abécédaire interactif qui utilise peut-être un script javascript spécifique. Il y a un certains nombre de plugins activés qui altèrent peut être le bon fonctionnement. Ca m'embete de les désactiver car j'ai peur de perdre leur paramétrage, mais il va peut-être falloir passer par là. Pour l'instant, j'ai seulement désactivé SocialMeta car vous aviez relevé une anomalie W3C

D'où ma question:
- avez-vous fait une autre modification de ductile autre que par le passage sur 'personnaliser le thème' ?

Je ne faisais pas les modifications en passant par les pages d'administration du blog et des thèmes. J'ai modifié directement les fichiers dans le dossier du thème Ductile que j'avais duppliqué pour créer le thème lesAttardés

#13 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-06 15:55:23

Le dossier dotclear est bien /allblogs/ car c'est lui qui contient le thème personnalisé "lesAttardés" qui est une dupplication de "Ductile". C'est celui que nous utilisions avant que je bascule sur Ductile pour essayer de résoudre le bug des commentaires.

Dans les captures en lien ci-dessous, vous pouvez voir le contenu de /allblogs/ et de /httpdocs/themes/

https://www.fromsmash.com/themes-dotclear


Les deux contiennent les thèmes default et ductile...

Je suis aussi perdu que vous :) Je suppose que le thème chargé de Ductile est celui se trouvant dans le dossier /allblogs/

#14 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-06 15:38:06

A vérifier puisque vous travaillez en mode multiblog

Je n'ai pas plusieurs blogs. Si ce mode est activé, c'est une erreur. Comment voyez vous que je suis en mode multiblog ?


Vous avez modifié le thème ductile
Ce thème est un thème par defaut de Dotclear
A ce titre, sauf erreur de ma part il devrait se trouver dans votre dossier dotclear/themes/ (ou au moins celui défini dans config ?) comme lors de l'installation et des mises à jour (vérifiées dans le fichier digests)

Donc: les themes par defaut (comme ductile, berlin...) non modifiés
* doivent être dans ce dossier et, pas, par ex, dans /othersblogs/ (sinon pas de mise à jour, "sauf manuelle")
* ne peuvent être modifiés qu'après copie du thème (qui comportera un autre nom de type et pourra être rangé ailleurs)

Cela m'étonne car j'ai supprimé Blowup et Dotclear non modifiés pendant mes essais de correction du bug des commentaires. Je ne pense pas que cela résoudra le problème des commentaires. Cependant je vais essayer de ranger les thèmes comme vous le suggérez.
C'est le fait de les télécharger à partir de la fonction de dépot à partir d'un fichier zip qui les a placés dans /othersblogs/

Je vais regarder, merci en tout cas pour votre aide.

#15 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-06 14:48:03

Les commentaires sont toujours en panne.

Pour le htaccess, pouvez-vous m'en dire plus svp ?

#16 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-06 14:45:48

nanart a écrit :

il y aurait donc de la modification du thème ductile qui serait persistante ???

Je viens d'activer le thème Ductile livré avec la version 1.8 et j'ai effacé le cache des templates jusqu'à ce que je trouve la source du problème.
Au moins pas de doute sur le contenu du thème.

nanart a écrit :

Quant à la page (index) une tentative de validation W3C m'affiche plusieurs erreurs notamment dans des liens de type <a href...

qui seraient dans la partie :

Partager cette chronique : TwitterFacebookLinkedInMastodonemail

J'ai désactivé le plugin SocialMeta au cas-où

#17 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-06 14:22:55

Dans vos capture je constate une erreur dans l'url du blog : http//www. <- POINT !!!

J'ai vérifié : le point est bien présent dans l'url du blog sur la page des paramètre du blog. Et il est bien visible dans les captures d'écran que je vous ai envoyé.

#18 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-06 09:44:43

Je viens de vider le cache des templates. Ca n'est pas retombé en marche...

J'ai également téléchargé les thèmes ductile et blowup (default) de l'archive 2.18, puis je les activais chacun leur tour. Mais j'ai le même comportement.

Je ne sais pas si cela peut avoir une importance mais la méthode d'écriture de l'URL paramétrée pour notre blog est QUERY_STRING

Avez vous d'autres suggestions ?

#19 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-05 21:57:29

bonsoir, ce n'est pas malin mais j'ai supprimé le thème Blowup et il n'est pas dans la liste des thèmes disponibles en téléchargement. Toutefois, j'ai testé également avec le thème Berlin. Même constat.

Quant à la ligne <script src="{{tpl:BlogQmarkURL}}pf=util.js"></script>, je confirme qu'elle est bien présente dans le fichier _head.html du thème



PS : J'ai supprimé Blowup et Ductile en pensant que je pourrais les re-télécharger dans leur dernière version pour être bien sûr que j'étais at the state of the art. Cependant je me retrouve idiot de ne pas les retrouver.
- ni là : https://themes.dotaddict.org/galerie-dc2/?q=ductile
- ni là : http://ductile.dotaddict.org/
Pouvez-vous m'indiquer où trouver leur archive .zip pour les installer manuellement?
Je pourrais ainsi vérifier à nouveau que le bug d'envoi et de prévisualisation des commentaires ne dépend pas du thème...

#20 Re : [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-05 14:13:44

J'ai fait réapparaître le bouton "Envoyer" des commentaires de billet en allant dans les paramètres du thème Ductile où on retrouve une case à cocher pour rendre la prévisualisation des commentaires facultative. Cette case à cocher semble redondante avec celle apparaissant dans la section "Paramètres du blog".

Toutefois, les commentaires ne sont pas envoyés. Les boutons Prévisualiser et Envoyer dans les commentaires de billet rechargent le billet en vidant les champs et aucun nouveau message n'est visible depuis l'administration du blog...

J'espère que vous pourrez m'aider...


___________________________
Comme le thème que j'utilise est un thème personnalisé à partir de Ductile, il est possible qu'il ne suive pas les maj de ce dernier. Pour test, j'ai quand même essayé d'activer à la place le thème Ductile en version 1.5 mais le constat est le même : les commentaires ne sont pas envoyés...

#21 [dc2] Bugs » Prévisualisation et envoi de commentaires impossibles » 2021-02-05 09:36:07

je-mattarde
Réponses : 37

Bonjour,
L'envoi de commentaires de billet sur notre blog n'est plus possible.
Je ne sais pas dire à quel moment cela ne fonctionne plus. Cependant cela pourrait être lié à la dernière mise à jour 2.18.

Voici la configuration du blog :
https://fromsmash.com/Capture-admin

Malgré avoir coché la prévisualisation comme "facultative", seul le bouton prévisualiser est accessible dans les commentaires des billets.

Lorsque je clique sur Prévisualiser suite à l'écriture d'un commentaire dans un billet, cela a pour effet d'actualiser la page avec le suffixe -pr et tous les champs sont vidés. (Firefox et Edge -> idem et adblocks désactivé)

Avez-vous des suggestions pour résoudre ce bug ?

Bonne journée

#22 Re : [dc2] Migration et mises à jour » version php et Dotclear 2.18 » 2021-01-05 11:24:51

Merci Gvx et adjaya pour vos réponses très rapides !

Gvx a écrit :

Il faut vérifier / mettre a jour la ligne suivante dans le fichier dotclear/inc/config.php

// Database driver (mysql, mysqli, pgsql, sqlite)
define('DC_DBDRIVER','mysqli');

si, la ligne est a mysql il faut la passer a mysqli (ajouter un "i" a la fin)

Ca a résolu le problème, merci beaucoup

#23 [dc2] Migration et mises à jour » version php et Dotclear 2.18 » 2021-01-04 16:12:51

je-mattarde
Réponses : 20

Bonjour,
J'ai vu le message suivant apparaître lors de la dernière mise à jour dotclear :
"Les prochaines versions de Dotclear ne supporteront par les versions de PHP < 7.0, la votre est actuellement la 5.6.40."

J'ai donc fait une demande auprès de mon hébergeur dans ce sens : la version est désormais en PHP 7.4.8 qui est la version la plus récente supportée par l'hôte mutualisé hébergeant notre site.

Cependant l'upgrade a eu pour conséquence de rendre mon site inaccessible : www.je-mattarde.com et je n'ai plus accès à l'interface d'administration :  http://je-mattarde.com/admin/

Avez vous des pistes pour m'aider à résoudre ce souci ? Mis à part de redemander à mon hébergeur de revenir à la version php précédente (5.6.4) ce qui n'est peut-être pas possible de faire facilement...

Merci par avance pour votre aide

Bonne année Dotcleariens !
Gilles

#24 [dc2] Migration et mises à jour » Mise à jour automatique v.2.12 vers v.2.12.1 » 2017-08-13 08:47:21

je-mattarde
Réponses : 3

Bonjour,
Merci beaucoup pour ces deux nouvelles mises à jour..!

En voulant passer à la 2.12.1, je constate que la mise à jour automatique est bloquée due à de nombreux fichiers modifiés.
Pourtant, je n'ai fait aucune modification sur les fichiers qui apparaissent dans le listing depuis la récente MaJ v2.12.

Extrait de la liste de la notification, il y a par exemple tous les fichiers situés dans :

plugins/dcCKEditor/js/ckeditor/skins/moono/

Pour lever le doute, j'ai récupéré le répertoire concerné

plugins/dcCKEditor/

directement dans l'archive originale de la 2.12, et j'ai transféré/remplacé le dossier idoine sur mon installation.

Je re-essaie ensuite de procéder à la MaJ automatique vers 2.12.1, mais le répertoire apparaît toujours dans la liste des fichiers modifiés.

Pouvez-vous m'éclairer svp ?

#25 [dc2] Thèmes » Menu hamburger du thème Berlin » 2017-03-28 08:45:26

je-mattarde
Réponses : 2

Je souhaite intégrer le menu hamburger (c'est son nom) du thème Berlin dans le thème Ductile.

Pour extraire cette partie, j'ai identifié dans le style.css de Berlin les lignes utiles à la mise en forme du menu en question. Pour vérifier, j'ai généré l'affichage du thème Berlin uniquement avec les lignes css associées à la partie _top. Le menu s'affiche correctement sur une page du reste nue.

Afin de l'intégrer au thème Ductile, j'ai testé de manière brutale de copier le _top.html du template currywurst (sur lequel est structuré Berlin) pour le mettre à la place de celui de Ductile. J'ai inséré les lignes de la feuille de style identifiées précédemment dans celle de Ductile. J'ai actualisé... et le bouton nommé "hamburger" n'apparaît pas...

Est-ce-qu'il y a un script js qui permet sa génération ou quelque chose que j'aurai manqué ?
Y a-t-il une page dédiée à son fonctionnement?

Vous n'êtes pas identifié(e).

Pied de page des forums

Propulsé par FluxBB

Sites map