Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 Re : [dc2] Installation et hébergement » Dotclear incompatible PHP 5.4.5 (last versions) » 2012-08-06 08:25:28

J'ai trouvé un lien (FAQ DotClear) qui indique la version PHP 5.3 maximum...

http://fr.dotclear.org/documentation/2.0/faq

Quelle est la roadmap ? Est-ce qu'une modification du code est prévue, de façon à supporter les dernières versions ?

#2 Re : [dc2] Installation et hébergement » Dotclear incompatible PHP 5.4.5 (last versions) » 2012-08-03 13:40:05

Quelle est la dernière version de PHP supportée par dotclear ?
Est-il possible de le préciser clairement dans la documentation ?

#3 Re : [dc2] Installation et hébergement » Dotclear incompatible PHP 5.4.5 (last versions) » 2012-07-21 07:59:29

Merci pour la réponse geceo !

Cela ne provient pas d'une extension.
Voici la page incriminée :   /plugins/widgets/index.php (ligne 327).

Dès lors, dois-je :

* adapter le code de dotclear, pour supporter les dernières version de PHP (au risque que l'automatic update de dotclear rende mes corrections éphémères) ?
* utiliser une version antérieure de PHP et du coup, rendre mon serveur vulnérable ? D'autant que les vulnérabilités PHP sont particulièrement utilisées...

Et dernière question : qui d'autre a remarqué ce problème ? S'agit-il d'un autre problème, lié à mon installation ?

Qu'en pensez-vous ?

#4 [dc2] Installation et hébergement » Dotclear incompatible PHP 5.4.5 (last versions) » 2012-07-15 20:01:49

SebastienP
Réponses : 26

Bonjour à tous,

Je crois avoir le même problème que cet utilisateur-là, qui a posté une discussion à cet endroit, dans le forum (partie Multilingual) :

http://forum.dotclear.org/viewtopic.php?id=46189

Je me permets d'activer cette discussion dans la partie francophone, dans l'espoir d'obtenir une réponse.

Avez-vous une solution ? Comment expliquer que la solution de l'utilisateur en question n'est pas fonctionnelle chez moi ?

Cet autre post me semble aussi intéressant, et relève peut-être de la même erreur, non ?
http://forum.dotclear.org/viewtopic.php?id=45935

Dans tous les cas, je pense qu'il serait bon de modifier la documentation d'installation. En effet, la mention PHP 5 ou supérieur est erronée. Est-il possible de connaitre la dernière version supportée ?

Merci d'avance pour votre aide !

PS : Dotclear en dernière verison à ce jour.

#5 Re : Multilingual » Upgrading from PHP 5.3.9 to PHP 5.4.0 » 2012-07-15 19:57:40

Hello !

I have the same issue and tried the solution you mentionned. However, it doesn't work and I get a synthax error.
Are your sure your solution is working ?

French : est-ce que qqun a le même problème et aurait trouvé une solution ?
Que dois-je faire ?

Merci d'avance pour votre aide !

Vous n'êtes pas identifié(e).

Pied de page des forums

Propulsé par FluxBB

Sites map