Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 Re : [dc2] Migration et mises à jour » [résolu?]DcCkEditor xhtml+DcLegacyEditor/wiki=>aucun outil/contenu » 2020-10-16 06:32:18

Bonjour,

Merci pour votre réactivité, il semblerait que ce soit bien le bloqueur de pubs.
En désactivant celui-ci et en mode de navigation privé l'insertion d'image fonctionne en édition xhtml.
Bien à vous

#2 Re : [dc2] Migration et mises à jour » [résolu?]DcCkEditor xhtml+DcLegacyEditor/wiki=>aucun outil/contenu » 2020-10-16 06:17:57

mousli a écrit :

Bonjour,

Je suis en Dotclear  2.17.2
Serveur Release:        7.11
Codename:       wheezy
PHP 5.6.40-1~dotdeb+7.1 (cli) (built: Jan 12 2019 20:13:26)

J’ai activé le plugin DcCKEditor qui propose une interface beaucoup plus conviviale, avec des fonctionnalités proches des logiciels de traitement de texte. Cela est plus simple pour les utilisateurs. Le plugin « texte » le plus couramment utilisé est « dcLegacyEditor ». Il est installé, mais non activé.
Dans les préférences de l’utilisateur non sommes bien « dcCKEditor » pour l’éditeur préféré pour le format xhtml et « xhtml » pour le format d’édition préféré.

J’ai des utilisateurs me signalant ne pas pouvoir insérer des images dans un billet en mode xhtml.
En passant par le bouton « sélecteur de média » en cliquant sur le bouton « Insérer » celui-ci n’a aucune action.

Contournement :
1/ J’active le plugin dcLegacyEditor.

2/ Dans les préférences de l’utilisateur dans mes options puis édition, je reste en « dcCKEditor » pour l’éditeur préféré pour le format «xhtml » et pour l’éditeur préféré pour le format « wiki » en «dcLegacyEditor »   avec « xhtml » pour le format d’édition préféré.

3/ J’édite un billet en insérant une image avec un formatage Wiki : code html
((/ecolesaintgobain02410/public/.DSC04430_m.jpg|DSC04430.JPG, oct. 2020|DSC04430.JPG, oct. 2020)) puis j’enregistre.

4/ / Dans les options du billet, je passe du formatage « wiki vers xhtml » les images apparaissent bien dans le corps du texte.

5/ Je repasse de « xhtml vers wiki » Après cette manipulation je ne peux plus insérer d’autres images en mode xhtml le bouton insérer reste sans action. 

6/ En repassant au formatage Wiki j’insère bien de nouvelle images mais en repassant en mode xhtml ou convertir en xhtml, les nouvelles images comme les anciennes  n’affichent que le code html.

l'URL de l'admin dans dotclear/inc/config.php est bien la même que celle utilisée réellement.
En vidant le cache tu navigateur, cela ne change rien. 

Merci d’avance pour vos réponses.

#3 Re : [dc2] Migration et mises à jour » [résolu?]DcCkEditor xhtml+DcLegacyEditor/wiki=>aucun outil/contenu » 2020-10-15 14:08:43

Bonjour,

Je suis en Dotclear  2.17.2
Serveur Release:        7.11
Codename:       wheezy
PHP 5.6.40-1~dotdeb+7.1 (cli) (built: Jan 12 2019 20:13:26)

J’ai activé le plugin DcCKEditor qui propose une interface beaucoup plus conviviale, avec des fonctionnalités proches des logiciels de traitement de texte. Cela est plus simple pour les utilisateurs. Le plugin « texte » le plus couramment utilisé est « dcLegacyEditor ». Il est installé, mais non activé.
Dans les préférences de l’utilisateur non sommes bien « dcCKEditor » pour l’éditeur préféré pour le format xhtml et « xhtml » pour le format d’édition préféré.

J’ai des utilisateurs me signalant ne pas pouvoir insérer des images dans un billet en mode xhtml.
En passant par le bouton « sélecteur de média » en cliquant sur le bouton « Insérer » celui-ci n’a aucune action.

Contournement :
1/ J’active le plugin dcLegacyEditor.

2/ Dans les préférences de l’utilisateur dans mes options puis édition, je reste en « dcCKEditor » pour l’éditeur préféré pour le format «xhtml » et pour l’éditeur préféré pour le format « wiki » en «dcLegacyEditor »   avec « xhtml » pour le format d’édition préféré.

3/ J’édite un billet en insérant une image avec un formatage Wiki : code html
((/ecolesaintgobain02410/public/.DSC04430_m.jpg|DSC04430.JPG, oct. 2020|DSC04430.JPG, oct. 2020)) puis j’enregistre.

4/ / Dans les options du billet, je passe du formatage « wiki vers xhtml » les images apparaissent bien dans le corps du texte.

5/ Je repasse de « xhtml vers wiki » Après cette manipulation je ne peux plus insérer d’autres images en mode xhtml le bouton insérer reste sans action. 

6/ En repassant au formatage Wiki j’insère bien de nouvelle images mais en repassant en mode xhtml ou convertir en xhtml, les nouvelles images comme les anciennes  n’affichent que le code html.

l'URL de l'admin dans dotclear/inc/config.php est bien la même que celle utilisée réellement.
En vidant le cache tu navigateur, cela ne change rien. 

Merci d’avance pour vos réponses.

#4 Re : [dc2] Plugins » GalleryInsert v0.412 » 2019-02-19 07:42:54

Bonjour,

Merci, nous avons environ plus de 230 espaces ( établissements) qui utilisent le plugin  GalleryInsert v0.412.

Crémos

#5 Re : [dc2] Plugins » GalleryInsert v0.412 » 2019-02-18 14:21:54

Merci pour votre retour , en suivant les recommandations du post : https://forum.dotclear.org/viewtopic.ph … 87#p342687
par : thorfin89 et kagou comme suite :

Depuis la mise à jour de Dotclear, le code  "::gallery dir='..." n'est plus interprété correctement, on constate que ":" a été mangé lors de l'affichage. J'ai trouvé provisoirement la solution en ajoutant ":" devant le code, ce qui donne  ":::gallery dir='..." dans l'écriture du billet...

Solution provisoir depuis 2019-02-07

Auteur : Fred

Premier dépôt : 06/11/2013, dernière mise à jour au 06/12/2017

Savez vous si un correctif est prévu ? 

Cordialement

#6 [dc2] Plugins » GalleryInsert v0.412 » 2019-02-18 10:44:23

mousli
Réponses : 13

Bonjour,

Je viens d'avoir un signalement d'une enseignante qui n'arrive plus à charger des photos dans un billet avec la fonction Gallery Insert , le code s'affiche correctement mais après enregistrement, le code n'est pas lu, il reste tel que dans le billet publié.

:gallery imgurl='ski_2018/01_02_2018;IMG_2567.jpg;IMG_2571.jpg;IMG_3750.JPG;IMG_3751.JPG;IMG_3752.JPG;IMG_3753.JPG;IMG_3754.JPG' thumb='t'::

Avez-vous une réponse ou une aide à apporter, si vous avez déjà rencontré ce problème.

Nous sommes en :

Dotclear :  dotclear-2.14.3
GalleryInsert v0.412
PHP 5.6.40

Merci

#7 Re : [dc2] Plugins » [Writers] génère erreur affichage dans page gestion plugins [résolu] » 2018-11-22 15:41:55

Merci à tous pour votre réactivités et votre implications.
Je viens de mettre en place le plugin Rédacteurs (writers) 1.2.1 dernière mise à jour au 22/11/2018
Cela semble fonctionner , merci pour les précisons.

Crémos

#8 Re : [dc2] Plugins » Gestion des plugin impossible » 2018-11-22 15:38:50

Merci à tous pour votre réactivités et votre implications.
Je viens de mettre en place le plugin Rédacteurs (writers) 1.2.1 dernière mise à jour au 22/11/2018
Cela semble fonctionner.

Crémos

#9 Re : [dc2] Plugins » Gestion des plugin impossible » 2018-11-22 09:22:27

Oui, Une fois le plugin Writers désactivé, tout rentre dans l'ordre.
D'autres espaces Dotclear fonctionnent sans problème sur le même serveur.

Crémos

#10 Re : [dc2] Plugins » Gestion des plugin impossible » 2018-11-22 09:08:40

Bonjour,

Nous avons un seul repertoire plugin avec des droits en 755

Inc/config.php:
define('DC_PLUGINS_ROOT',dirname(__FILE__).'/../plugins');

Même problème qu'a déjà signalé nanart ci-dessus :  https://forum.dotclear.org/viewtopic.php?id=49442

Pas de menu gauche ni footer affichés aussi

Crémos

#11 Re : [dc2] Plugins » Gestion des plugin impossible » 2018-11-21 15:50:14

Problème souvent rencontré avec certains CMS la compatibilité des plugins, nous avions dans notre cas le plugin Writers 1.2 qui semble poser problème. Pourtant celui-ci est bien compatible avec la version de nos Dotclear.

Writers 1.2
Allow administrators to assign or remove permissions to other users / Permettre aux administrateurs d'affecter ou de supprimer des permissions aux autres utilisateurs
Informations générales
Permettre aux administrateurs d'affecter ou de supprimer des permissions aux autres utilisateurs (exceptés les super-administrateurs).

Informations techniques
Version du plugin : 1.2
Version minimale de Dotclear : 2.6
Licence : GNU GPL v2
Support : Forum Dotclear

Crémos

#12 Re : [dc2] Plugins » Gestion des plugin impossible » 2018-11-21 15:30:13

Merci pour vos précisions nous avons plus de 800 sites sous Dotclear , avec un cloisonnement des sites avec suPHP pour apache.  Nous avons bien l'utilisateur/groupe qui fait bien tourner dotclear avec le droit d'écrire sur son répertoire. Je ne vois pas où se trouve l’erreur et bien sur rien dans les logs. C’est le seul à priori qui pose problème.
Crémos

#13 Re : [dc2] Plugins » Gestion des plugin impossible » 2018-11-21 07:15:44

Bonjour,

Je confirme cette enseignante a bien un compte super administrateur.

Nous avons aussi un compte d'assistance en super administrateur même problème les ongles d'ajout, d'installation et de mise à jour ne sont pas présents.

Crémos

#14 [dc2] Plugins » Gestion des plugin impossible » 2018-11-20 15:01:38

mousli
Réponses : 15

Bonjour,

Nous hébergeons plusieurs sites en Dotclear version 2.14.3 sur un serveur académique.

Une enseignante me signale ne plus pouvoir gérer des plugins, elle n'arrive plus à en ajouter car elle n’a plus accès aux boutons ajouter des plugins et Installer ou mettre à jour manuellement. Elle ne peux que voir les plugins qui sont déjà installés. Il est possible de désactiver un plugin mais la liste des plugins désactivés n’apparait pas.

Je ne suis connecté à l’espace d’administration d'un autre problème pas de problème. 

Merci d’avance pour vos réponses, dans l’attente de pouvoir échanger.

Crémos

Vous n'êtes pas identifié(e).

Pied de page des forums

Propulsé par FluxBB

Sites map