Dotclear

Vous n'êtes pas identifié(e).

Annonce

#51 2007-07-27 10:47:34

kapitoster
Membre
Inscription : 2006-05-08
Site Web

Re : [MàJ 1.2.7] Questions et aide, c'est ici

Encore un soucis... lorsque l'on veut poster un commentaire on tombe sur le message suivant :

Precondition Failed

Même lorsque je désactive le captcha que j'ai installé...

Hors ligne

#52 2007-07-27 10:54:47

brol
Membre
Inscription : 2005-10-16

Re : [MàJ 1.2.7] Questions et aide, c'est ici

et quand tu le supprimes ?

Hors ligne

#53 2007-07-27 10:56:11

kapitoster
Membre
Inscription : 2006-05-08
Site Web

Re : [MàJ 1.2.7] Questions et aide, c'est ici

Sans parler du plugin contact qui ne fonctionne pas...

Hors ligne

#54 2007-07-27 11:01:34

brol
Membre
Inscription : 2005-10-16

Re : [MàJ 1.2.7] Questions et aide, c'est ici

oui, c'est normal, ils n'ont pas été mis à jour puisqu'ils fonctionnent avec un formulaire.

Hors ligne

#55 2007-07-27 11:02:57

kapitoster
Membre
Inscription : 2006-05-08
Site Web

Re : [MàJ 1.2.7] Questions et aide, c'est ici

brol a écrit :

et quand tu le supprimes ?

pareil...

Hors ligne

#56 2007-07-27 11:18:50

kapitoster
Membre
Inscription : 2006-05-08
Site Web

Re : [MàJ 1.2.7] Questions et aide, c'est ici

brol a écrit :

oui, c'est normal, ils n'ont pas été mis à jour puisqu'ils fonctionnent avec un formulaire.

vivement que leurs auteurs mettent en ligne les versions corrigées de leurs plugins

Hors ligne

#57 2007-07-27 11:43:22

brol
Membre
Inscription : 2005-10-16

Re : [MàJ 1.2.7] Questions et aide, c'est ici

quand tu le supprimes, tu supprimes également les appels au plugin que tu as mis dans tes fichiers du thème, et dans ceux du core éventuellement ?!

et tu penses également à vider le cache navigateur (voire supprimer les cookies associés à ton blog et les cookies session) ?

Hors ligne

#58 2007-07-27 15:32:47

onel
Membre
Inscription : 2007-07-27

Re : [MàJ 1.2.7] Questions et aide, c'est ici

Bonjour à tous, j'ai exactement le même problème que kapitoster (post #51), et ce sans captcha. DC 1.2.7
C'est forcément dû à un plugin ? Est-ce que cela pourrait venir de spamplemousse (0.1.7) ? Parce que comme beaucoup, j'en ai vraiment besoin...

Hors ligne

#59 2007-07-27 20:06:47

ba2
Membre
Inscription : 2006-04-03

Re : [MàJ 1.2.7] Questions et aide, c'est ici

hello,
moi j'ai fait la MAJ apparemment tout s'est bien passé, dotclear marche sans erreurs !
seul bizarrerie, dans l'admin, il me met toujours dotclear 1.2.6 :)

Hors ligne

#60 2007-07-27 20:23:20

onel
Membre
Inscription : 2007-07-27

Re : [MàJ 1.2.7] Questions et aide, c'est ici

Problème résolu.
Toc (table des matières) passé en 1.20.1
Si le site officiel (navré mais vraiment...) pouvait marquer clairement "Dernière version : v1.xxx" sans nous forcer à faire une recherche et fouiller le site... bref. Sur dotclear, les versions ne correspondent pas non plus dans le wiki plugins, dommage. Bon j'arrête de pleurnicher.

Mettez à jour vos plugins si vous avez "Precondition Failed" en postant des commentaires...

Hors ligne

#61 2007-07-27 20:35:14

onel
Membre
Inscription : 2007-07-27

Re : [MàJ 1.2.7] Questions et aide, c'est ici

Et au passage (quand même il ne faut pas oublier) un grand MERCI pour cette grosse mise à jour sécuritaire. ;)

Hors ligne

#62 2007-07-27 20:49:44

Kozlika
Modo dcTeam
Inscription : 2004-05-08
Site Web

Re : [MàJ 1.2.7] Questions et aide, c'est ici

onel, pour tout te dire, on décompresse un peu et personne n'a trop le courage de refaire la page des plugins (d'où le fil spécial aussi). Cela dit, si quelqu'un veut m'envoyer le fichier au format syntaxe du wiki avec la page des plugins mise à jour avec le recensement des plugins du fil dédié our ajouter à ceux qu'il faut "compatible 1.1.7" , je crois qu'un copier-coller je trouverais le courage ! ;)


La documentation : http://doc.dotclear.net/2.0/fulltoc
Le module de recherche du forum : http://www.dotclear.net/forum/search.php ?

Hors ligne

#63 2007-07-27 20:55:09

Kozlika
Modo dcTeam
Inscription : 2004-05-08
Site Web

Re : [MàJ 1.2.7] Questions et aide, c'est ici

Oups moi aussi j'oubliais : merci du merci ! :)


La documentation : http://doc.dotclear.net/2.0/fulltoc
Le module de recherche du forum : http://www.dotclear.net/forum/search.php ?

Hors ligne

#64 2007-07-27 21:08:32

onel
Membre
Inscription : 2007-07-27

Re : [MàJ 1.2.7] Questions et aide, c'est ici

Je suis assez nul en wiki, mais pour spamplemousse compatible 1.2.7 c'est le 0.1.7 le dernier :
http://www.sous-anneau.org/public/plugi … 1.7.pkg.gz
http://www.sous-anneau.org/public/plugi … 1.7.tar.gz
(site indisponible en ce moment, blogs officiels des auteurs pas à jour)

Table des matières c'est le 1.20.1 le dernier :
http://franck.paul.free.fr/dotclear/sha … 0.1.pkg.gz
http://franck.paul.free.fr/dotclear/sha … 0.1.tar.gz
http://franck.paul.free.fr/dotclear/?20 … ieres-1201


Votre repos à tous est mérité, l'interface admin de la 1.2.7 est super ! Les traitements par lots (je passais par mcomments sinon pour les commentaires), les améliorations d'ergonomie (et au passage d'ailleurs le dernier spamplemousse est mieux), c'est super aussi ! Et la sécurité... on aime. ;-)

Courage !

Hors ligne

#65 2007-07-27 21:29:09

anca2
Membre
Lieu : Marseille
Inscription : 2007-06-07
Site Web

Re : [MàJ 1.2.7] Questions et aide, c'est ici

Bonsoir,

Je me suis mis à jour de la version 127.
Semble fonctionner sauf qu'il est impossible de faire fontionner le plugin de paginnation. Qu'elle que soit la case que l'on coche il y a l'erreur "Precondition Failed"

Hors ligne

#66 2007-07-27 21:46:04

i_love_dc
Membre
Inscription : 2007-07-13

Re : [MàJ 1.2.7] Questions et aide, c'est ici

lu a tous et toutes.

l'installation au propre de la v1.2.7 c'est enfin bien passée \o/ \o/ \o/
(trois essaies pour une nase comme moi...bref)

j'ai un problème avec le mode "Pagination" (mis a jour par pep)

voici un screen avec mon ancienne version 1.2.6

-> http://img510.imageshack.us/img510/7348/20583255ar4.jpg

voici un screen version 1.2.7

- > http://img510.imageshack.us/img510/5168/32840952fn6.jpg

Pourtant et bien evidemant mon mode pagination est actif
(et le thème est le même avec les mêmes modifs puisque je l ai re-injecté)

comprend pas pourquoi rien apparait ???
((merci du coup de main pour ceux qui pourrait m'aiguillée vers une éventuelle solution))

Hors ligne

#67 2007-07-27 21:54:30

Kozlika
Modo dcTeam
Inscription : 2004-05-08
Site Web

Re : [MàJ 1.2.7] Questions et aide, c'est ici

onel a écrit :

Je suis assez nul en wiki, mais pour spamplemousse compatible 1.2.7 c'est le 0.1.7 le dernier :
(...)

Oui oui, ils sont dans le fil dédié aux plugins compatibles 1.2.7. C'est la page wiki qu'on doit mettre à jour :)


La documentation : http://doc.dotclear.net/2.0/fulltoc
Le module de recherche du forum : http://www.dotclear.net/forum/search.php ?

Hors ligne

#68 2007-07-27 21:58:53

Kozlika
Modo dcTeam
Inscription : 2004-05-08
Site Web

Re : [MàJ 1.2.7] Questions et aide, c'est ici

Message pour i_love_dc : si tu mets un mail invalide dans ton profil, tes messages à la modération ne risquent pas de recevoir de réponse ;)


La documentation : http://doc.dotclear.net/2.0/fulltoc
Le module de recherche du forum : http://www.dotclear.net/forum/search.php ?

Hors ligne

#69 2007-07-27 22:09:00

i_love_dc
Membre
Inscription : 2007-07-13

Re : [MàJ 1.2.7] Questions et aide, c'est ici

Kozlika a écrit :

Message pour i_love_dc : si tu mets un mail invalide dans ton profil, tes messages à la modération ne risquent pas de recevoir de réponse ;)

rectifié erreur de ma part

desolée

Hors ligne

#70 2007-07-27 22:52:13

Pep
Membre
Inscription : 2004-08-24
Site Web

Re : [MàJ 1.2.7] Questions et aide, c'est ici

i_love_dc a écrit :

comprend pas pourquoi rien apparait ???
((merci du coup de main pour ceux qui pourrait m'aiguillée vers une éventuelle solution))

J'ai repéré 2 boulettes dans mon code cet après-midi. Dont une qui pourrait bien être la cause de ton problème. /o\

Je finis de prendre mon bain de lune et je mettrai une 0.2.1 à disposition dans un moment.


Who Cares ?

Hors ligne

#71 2007-07-27 23:17:05

Pep
Membre
Inscription : 2004-08-24
Site Web

Re : [MàJ 1.2.7] Questions et aide, c'est ici


Who Cares ?

Hors ligne

#72 2007-07-28 00:29:50

ULB
Membre
Lieu : Saint Malo
Inscription : 2006-07-10
Site Web

Re : [MàJ 1.2.7] Questions et aide, c'est ici

J’aurais souhaité avoir quelques éclaircissements.

Après avoir lu l’annonce de la sortie de la version 1.2.7, j’ai été voir ensuite « Les auteurs de plugins trouveront des instructions les guidant en ce sens dans la documentation de Dotclear. »

Je ne suis pas auteur de plugin (pas développeur) juste un petit bidouilleur. Cependant, il y a des plugins qui ont été abandonné par leurs auteurs et je m’occupe de l’un d’entre eux. J’avais effectué quelques modifications mineures et corrections avant de le remettre à disposition sur le wiki.

Je continue donc à m’en occuper mais je souhaiterais ne pas faire de bêtises et m’assurer que tout est ok avant de mettre à disposition la version « compatible 1.2.7 » !

J’ai donc regardé les codes modifiés des plugins déjà corrigés et je crois avoir compris les modifications à effectuer.

J’ai repris le plugin, j’ai effectué la modification, testé avec un DotClear 1.2.7 fraîchement installé, il semble se comporter « normalement ».
(J’ai vérifié d’abord les blocages avec une version non modifié pour voir la différence)

Une phrase me pose problème, la première : Tout changement d'état (dans la base de données ou ailleurs) doit obligatoirement passer par une requête HTTP de type POST.

Parce que rechercher les formulaires ayant un method= »post », les fichiers d’extension .js avec un $.post et l’utilisation des fonctions ayant été définies dans ce .js, ok, j’arrive à suivre mais pas là.

Je me répète, je ne suis pas programmeur et là, cela coince, je ne comprends pas de quoi on parle. Comment puis-je savoir si l’auteur à l’origine du plugin a bien tenu compte de cette obligation ? Que dois-je rechercher dans le code ? Quel type de code, permettant un changement d’état, est proscrit ?

Hors ligne

#73 2007-07-28 02:40:42

i_love_dc
Membre
Inscription : 2007-07-13

Re : [MàJ 1.2.7] Questions et aide, c'est ici

Pep a écrit :
i_love_dc a écrit :

comprend pas pourquoi rien apparait ???
((merci du coup de main pour ceux qui pourrait m'aiguillée vers une éventuelle solution))

J'ai repéré 2 boulettes dans mon code cet après-midi. Dont une qui pourrait bien être la cause de ton problème. /o\

Je finis de prendre mon bain de lune et je mettrai une 0.2.1 à disposition dans un moment.

<br/>
<br/>
pour ma part, ça ne marche toujours pas ça me donne ça!

- > http://img510.imageshack.us/img510/5168/32840952fn6.jpg

(ca devrais me donner ca )

- > http://img510.imageshack.us/img510/7348/20583255ar4.jpg

l'ancien mode pagination je devais faire ca

Dans le fichier list.php de votre thème, ajoutez la ligne suivante avant et/ou après la boucle while :

<?php if ($mode == 'pagination') dcPagination::showNavigation(); ?>

pour ma part c'était plutôt ça:

<?php if ($mode == 'pagination') dcPagination::showNavigation('<p class="pagenav">%s</p>'); ?>
<!-- Boucle sur la liste de billets -->
<?php while ($news->fetch()) : ?>
(...)
<?php endwhile; ?>
<?php if ($mode == 'pagination') dcPagination::showNavigation('<p class="pagenav">%s</p>'); ?>

et une modif css aussi

mais tout est déjà fait...
(puisque les fichiers sont ceux du thème déjà utiliser et custom ?

Ces codes, sont ils obsolètes depuis ta mise à jour pep ?
Faut il remettre un fichier list.php d'origine (c'est le fichier modifier pour ma part) ??

Hors ligne

#74 2007-07-28 03:07:41

Pep
Membre
Inscription : 2004-08-24
Site Web

Re : [MàJ 1.2.7] Questions et aide, c'est ici

Les images ne me parlent pas, désolé. Avec l'URL de ton blog, ça irait sans doute mieux. :-)


Who Cares ?

Hors ligne

#75 2007-07-28 05:49:05

Kozlika
Modo dcTeam
Inscription : 2004-05-08
Site Web

Re : [MàJ 1.2.7] Questions et aide, c'est ici

ULB > je m'y connais encore moins que toi, mais si j'ai bien compris nos discussions, il y a deux méthodes possibles pour les interventions dans la base : POST (que tu as donc corrigés dans tes plougs) et GET. Et (toujours si j'ai bien compris), les GET doivent désormais être bannis.


La documentation : http://doc.dotclear.net/2.0/fulltoc
Le module de recherche du forum : http://www.dotclear.net/forum/search.php ?

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map