Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2008-03-01 19:26:53

fredo46
Membre
Inscription : 2008-03-01

Le Javascript disparaît dans les billets !

Bonjour à tous,

Je suis débutant en Dotclear et suis en train de mettre en ligne mon site de films persos :
http://familletruc.trioledcrush.org/pos … 2/25/first
(merci de pas diffuser pour l'instant, il n'est pas du tout au point)

Comme vous pouvez le voir, mon idée est d'avoir sur la gauche un player FLV (fait à partir d'un widget texte) toujours présent mais dont l'url du film change. Pour cela, je vois deux solutions :

- La plus simple : un lien en javascript dans le billet du film pour changer l'url, comme c'est prévu dans la doc du flv player

<a href="javascript:document.getElementById('cinematruc').SetVariable('player:jsUrl', 'http://trollfou.free.fr/Streaming/immortalite.flv');">Voir le film</a>

ce lien marche quand il est mis dans le widget texte, mais pas dans le billet (le code javascript est effacé par dotclear, je suppose pour des raisons de sécurité ?). Or dans le widget je ne sais pas quel film a été choisi, donc impossible.

- seconde solution : avoir des variables associées au billet (url du film, titre, etc.) que je fixerais dans chaque billet et que le widget récupèrerait. Mais pour cela, il faudrait que je puisse définir des variables dans le billet, or je ne sais faire ça qu'en javascript, et dotclear vire tout code javascript avant publication du billet.

Avez-vous une idée de solution technique ?

Merci d'avance pour toute aise !
Bien cordialement,
fredo46

Hors ligne

#2 2008-03-01 19:44:53

Dzana
Membre
Inscription : 2007-07-22
Site Web

Re : Le Javascript disparaît dans les billets !

Bonjour et bienvenue,

Tu peux tout à fait mettre du javascript dans tes billets.
Quand tu édites un billet, tu choisis xhtml pour le format du texte (menu à droite du billet), et sous la zone d'édition du te mets en mode "source" (au lieu de visuel).

Là tu peux écrire du html, css, javascript, etc...

Dzana

Hors ligne

#3 2008-03-01 20:02:36

fredo46
Membre
Inscription : 2008-03-01

Re : Le Javascript disparaît dans les billets !

Merci, mais j'ai déjà fait ça :)
Ca doit être une limitation de gandi, alors, l'hébergeur du blog...
Tant pis, mais merci.

Hors ligne

#4 2008-03-01 21:26:27

Moe
Responsable du mini-bar
Lieu : France
Inscription : 2004-09-19
Site Web

Re : Le Javascript disparaît dans les billets !

Dans about:config, passe enable_html_filter à non. Ou utilise la syntaxe wiki pour ton billet et colle ton code Javascript entre ///html et ///. Exemple :

Plop.

///html
<script type="text/javascript">
alert('zog');
</script>
///

Hors ligne

#5 2008-03-02 01:49:08

fredo46
Membre
Inscription : 2008-03-01

Re : Le Javascript disparaît dans les billets !

Merci mais :
- la seconde solution ne marche pas, le javascript disparaît tout pareil
- pour la première, je ne vois pas comment avoir accès à about:config (j'ai essayé familletruc.trioledcrush.org/about:config mais rien), je pense que je n'ai pas le droit (ce n'est pas mon install de dotclear mais celle de mon hébergeur gandi)

Hors ligne

#6 2008-03-02 02:07:42

Moe
Responsable du mini-bar
Lieu : France
Inscription : 2004-09-19
Site Web

Re : Le Javascript disparaît dans les billets !

about:config doit se trouver dans l'administration de ton blog, dans le menu à gauche. T'as mis quoi comme code dans ton billet quand tu as testé la solution du wiki ? Je viens de tester et mon Javascript n'a pas été effacé. Tu as un GandiBlog ?

Hors ligne

#7 2008-03-02 11:03:11

fredo46
Membre
Inscription : 2008-03-01

Re : Le Javascript disparaît dans les billets !

Moe a écrit :

about:config doit se trouver dans l'administration de ton blog, dans le menu à gauche.

http://trollfou.free.fr/image_admin.jpg
ben non, il n'y est pas. J'ai passé tous les paramètres au peigne fin, les plugins aussi, aucun about:config, aucun enable_html_filter ou qqchose s'en rapprochant, aucune option liée de près ou de loin au javascript.

T'as mis quoi comme code dans ton billet quand tu as testé la solution du wiki ?

J'ai mis ton code, puis après j'ai essayé de mettre le mien, mais dès qu'il y a une balise <script> elle disparaît.

Je viens de tester et mon Javascript n'a pas été effacé.

En fait moi non plus, le code javascript est bien stocké dans les billets, quand je les ouvre avec l'interface d'admin il est là, mais il est filtré à l'affichage (et pour la validation xhtml aussi).

Tu as un GandiBlog ?

Oui. Je leur ai posé la question sur leur forum spécifique à Gandiblog mais pour l'instant je n'ai pas de réponse.

Merci,
fredo46

Hors ligne

#8 2008-03-02 11:25:14

Kozlika
Modo dcTeam
Inscription : 2004-05-08
Site Web

Re : Le Javascript disparaît dans les billets !

fredo46 a écrit :

Oui. Je leur ai posé la question sur leur forum spécifique à Gandiblog mais pour l'instant je n'ai pas de réponse.

C'est pourtant d'eux qu'il faudra l'attendre. Les limitations d'accès et de paramétrages sont de leur ressort.


La documentation : http://doc.dotclear.net/2.0/fulltoc
Le module de recherche du forum : http://www.dotclear.net/forum/search.php ?

Hors ligne

#9 2012-09-06 11:35:41

geceo
Membre
Lieu : Cesson Sévigné
Inscription : 2008-05-10
Site Web

Re : Le Javascript disparaît dans les billets !

Quelqu'un sait si le problème du JavaScript placé dans un billet et qui disparaît quand on enregistre le billet se pose aussi en mutualisé OVH?

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map