Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2009-12-22 15:14:04

kwon
Membre
Lieu : Bordeaux
Inscription : 2006-08-05
Site Web

[Extension Newsletter] : support de l'extension

Bonjour

A l'occasion de la sortie de la version 3.7.0 de l'extension Newsletter, j'ai décidé d'ouvrir un nouveau fil pour son support. Ça évitera de se perdre dans les méandres des 19 pages de l'ancien post :)

Pour toute question, bug ou ressenti, c'est ici que ça se passe ^^

Pour les versions antérieures, vous avez toujours la possibilité de consulter l'ancien fil ici http://forum.dotclear.net/viewtopic.php?id=38703

@++

Hors ligne

#2 2009-12-23 16:08:47

marmottekidor
Membre
Inscription : 2009-11-27
Site Web

Re : [Extension Newsletter] : support de l'extension

Mince! je n'avais pas vu ce nouveau fil...
Du coup je fais une citation de ce que j'ai posté dans le précédent:

marmottekidor a écrit :

Bonjour,

Je viens d'installer la dernière version et ça me semble bien fonctionner! merci !

Voici mon retour pour le fonctionnement dont j'ai eu besoin:
Lorsque je mets le tag: LISTPOSTS
ça donne: "Si vous avez des difficultés pour visualiser ce message, accédez à la version en ligne" et le lien vers la version de la lettre en ligne...
Je croyais que LISTPOSTS allait montrer un lien vers les derniers billets ?
Mais je ne sais plus si c'est moi qui n'ai pas tout compris à ces mots clefs...
Autre chose, je ne trouve pas la liste des mots clefs dans la FAQ  ou puis-je la trouver ?

Hors ligne

#3 2009-12-23 17:10:45

marmottekidor
Membre
Inscription : 2009-11-27
Site Web

Re : [Extension Newsletter] : support de l'extension

Merci pour cette réponse rapide!

kwon a écrit :
marmottekidor a écrit :

Voici mon retour pour le fonctionnement dont j'ai eu besoin:
Lorsque je mets le tag: LISTPOSTS
ça donne: "Si vous avez des difficultés pour visualiser ce message, accédez à la version en ligne" et le lien vers la version de la lettre en ligne...
Je croyais que LISTPOSTS allait montrer un lien vers les derniers billets ?

Bonjour

LISTPOSTS retourne les billets que tu as sélectionné.

Je te conseille de suivre cette page manuel-newsletter-avance

@++

merci pour le lien vers le manuel, en fait je me perdais dans la FAQ....

J'ai refait un test et lorsque j'utilise LISTPOSTS, j'ai le lien pour voir la lettre en ligne et lorsque j'utilise le mot clef LINK_VISU_ONLINE rien n'apparait...

Hors ligne

#4 2009-12-24 08:22:04

kwon
Membre
Lieu : Bordeaux
Inscription : 2006-08-05
Site Web

Re : [Extension Newsletter] : support de l'extension

marmottekidor a écrit :

lorsque j'utilise le mot clef LINK_VISU_ONLINE rien n'apparait...

Bonjour

Merci du retour et effectivement, il semble que ce lien ne soit traité que si LISTPOSTS est activé. Je crée le ticket correspondant :)

@++

Hors ligne

#5 2010-01-02 14:12:37

Jen
Membre
Inscription : 2009-09-25
Site Web

Re : [Extension Newsletter] : support de l'extension

Salut à tous,

Je n'ai rien changé dans mes paramètres et pourtant il me semble que la newsletter ne fonctionne plus. J'ai publié 2 billets le 1er janvier, et je n'ai reçu aucune lettre. Je viens d'en republier un, aucune lettre pour l'instant.
Cela pourrait-il venir de la ligne que tu m'as conseillé de supprimer pour ne pas envoyer la lettre si le billet est "en attente" ? (cf le post du plugin)

Merci !

Hors ligne

#6 2010-01-04 08:44:59

kwon
Membre
Lieu : Bordeaux
Inscription : 2006-08-05
Site Web

Re : [Extension Newsletter] : support de l'extension

Bonjour et meilleurs vœux à tous

Jen a écrit :

Je n'ai rien changé dans mes paramètres et pourtant il me semble que la newsletter ne fonctionne plus. J'ai publié 2 billets le 1er janvier, et je n'ai reçu aucune lettre. Je viens d'en republier un, aucune lettre pour l'instant.
Cela pourrait-il venir de la ligne que tu m'as conseillé de supprimer pour ne pas envoyer la lettre si le billet est "en attente" ? (cf le post du plugin)

Est-ce que tu as essayé d'installer la dernière version de l'extension ? La correction que j'avais conseillée était temporaire le temps que je sorte la version officielle, ce qui est fait.
Si ça ne corrige pas ton problème, je regarderai plus avant ;)

@++

Hors ligne

#7 2010-01-04 12:17:34

Jen
Membre
Inscription : 2009-09-25
Site Web

Re : [Extension Newsletter] : support de l'extension

Salut kwon, meilleurs vœux à toi aussi,

Oui, voyant que ça ne marchait pas après les 2 billets publiés (ce qui est bizarre vu que ça marchait avant, avec cette même version), j'ai installé la dernière version puis j'ai publié le 3e. Je n'ai rien reçu et j'ai donc envoyé la newsletter manuellement.

Merci d'avance !

Hors ligne

#8 2010-01-06 15:06:13

Jen
Membre
Inscription : 2009-09-25
Site Web

Re : [Extension Newsletter] : support de l'extension

J'ai eu un autre problème aujourd'hui. En envoyant la lettre auto manuellement, j'ai bien reçu le mail avec 3 billets, mais le 3e n'est pas le 3e chronologiquement parlant :

Billet 1
(mercredi, 6 janvier 2010 , par Avignon à Vélo)
...

Billet 2
(mercredi, 6 janvier 2010 , par Avignon à Vélo)
....

Billet 3
(mercredi, 16 décembre 2009 , par Avignon à Vélo)
...

Il me sort un billet du 16 décembre, alors que j'en ai publié plein depuis, je sais pas pourquoi !

Merci !

Hors ligne

#9 2010-01-07 14:10:52

kwon
Membre
Lieu : Bordeaux
Inscription : 2006-08-05
Site Web

Re : [Extension Newsletter] : support de l'extension

Jen a écrit :

J'ai eu un autre problème aujourd'hui. En envoyant la lettre auto manuellement, j'ai bien reçu le mail avec 3 billets, mais le 3e n'est pas le 3e chronologiquement parlant : Il me sort un billet du 16 décembre, alors que j'en ai publié plein depuis, je sais pas pourquoi !

Bonjour

Est-ce que ça ne viendrait pas du paramètre "Choix de la date pour le tri des billets "utilisé dans l'onglet "Paramètres" ? Celui-ci peut prendre plusieurs valeurs et il faudrait le positionner à la valeur "date de publication".

@++

Hors ligne

#10 2010-01-07 19:14:16

Jen
Membre
Inscription : 2009-09-25
Site Web

Re : [Extension Newsletter] : support de l'extension

J'ai vérifié, c'est bien déjà paramétré à "date de publication".
Je viens de réessayer, je me suis envoyé la lettre auto, et pareil, le 3e billet et le dernier de décembre.

Hors ligne

#11 2010-01-11 10:07:52

Jen
Membre
Inscription : 2009-09-25
Site Web

Re : [Extension Newsletter] : support de l'extension

Pour le problème du non-envoi de la lettre, il semble que ça soit le fait d'enregistrer un billet en "en attente" qui perturbe la lettre.
- enregistrement du billet en attente -> passage en publié -> pas d'envoi auto de la lettre
- enregistrement du billet direct en publié -> envoi auto de la lettre marche bien.

Hors ligne

#12 2010-01-11 13:57:13

susana
Membre
Lieu : Dans les nuages
Inscription : 2009-03-14
Site Web

Re : [Extension Newsletter] : support de l'extension

Bonjour,

Je viens d'installer l'extension que je trouve geniale, merci !
Par contre, je viens d'aller creer une lettre d'information sans y ajouter de billet, directement en mode "publiee".
Je me choisis dans la liste des abonnes et je me l'envoie : rien ne se passe.
J'ai cree un billet sur le blog histoire de dire au plugin que le site est actif, j'ai reverifie les parametres, tout semble OK, j'ai retente l'envoi, rien recu.
J'ai juste 40 abonnes qui attendent la lettre et je ne sais pas comment y remedier :-)
Merci d'avance pour votre aide !


Firebug, indispensable pour les bidouilles :
http://getfirebug.com/
Mes bidouilles Noviny :
http://www.petitpilote.org/blog/index.p … Bidouilles

Hors ligne

#13 2010-01-11 14:14:31

susana
Membre
Lieu : Dans les nuages
Inscription : 2009-03-14
Site Web

Re : [Extension Newsletter] : support de l'extension

Precision : rien ne s'affiche sous ID, ACTION, STATUS en requete ou actions...


Firebug, indispensable pour les bidouilles :
http://getfirebug.com/
Mes bidouilles Noviny :
http://www.petitpilote.org/blog/index.p … Bidouilles

Hors ligne

#14 2010-01-11 14:42:07

susana
Membre
Lieu : Dans les nuages
Inscription : 2009-03-14
Site Web

Re : [Extension Newsletter] : support de l'extension

Deuxieme precision, la lettre automatique ne part pas non plus.
Aucun suivi de l'envoi ne s'affiche.
Merci pour vos lumieres.


Firebug, indispensable pour les bidouilles :
http://getfirebug.com/
Mes bidouilles Noviny :
http://www.petitpilote.org/blog/index.p … Bidouilles

Hors ligne

#15 2010-01-12 07:59:29

kwon
Membre
Lieu : Bordeaux
Inscription : 2006-08-05
Site Web

Re : [Extension Newsletter] : support de l'extension

susana a écrit :

Je viens d'installer l'extension que je trouve geniale, merci !

Bonjour et merci du retour :)

susana a écrit :

J'ai cree un billet sur le blog histoire de dire au plugin que le site est actif, j'ai reverifie les parametres, tout semble OK, j'ai retente l'envoi, rien recu.
J'ai juste 40 abonnes qui attendent la lettre et je ne sais pas comment y remedier :-)
Precision : rien ne s'affiche sous ID, ACTION, STATUS en requete ou actions...

C'est étonnant que tu vois ce tableau ;)
Est-ce que tu avais une version antérieure ? Si oui, il te faut peut-être forcer le rechargement du javascript en faisant un CTRL-F5 sur chaque page ou alors en vidant ton cache.

Tu me dis si ça résoud le problème.

@++

Hors ligne

#16 2010-01-12 12:10:19

susana
Membre
Lieu : Dans les nuages
Inscription : 2009-03-14
Site Web

Re : [Extension Newsletter] : support de l'extension

Bonjour Kwon,

Ça ne résout pas le problème en vidant le cache... ni en faisant CTRL F5. J'avais une version antérieure (3.6.0) qui fonctionnait très bien.
C'est au moment de mettre à jour le plugin en version 3.7.0 que les lettres ne partent plus.
Heu, au secours ?
Un grand merci d'avance !


Firebug, indispensable pour les bidouilles :
http://getfirebug.com/
Mes bidouilles Noviny :
http://www.petitpilote.org/blog/index.p … Bidouilles

Hors ligne

#17 2010-01-12 15:12:18

susana
Membre
Lieu : Dans les nuages
Inscription : 2009-03-14
Site Web

Re : [Extension Newsletter] : support de l'extension

Rebonjour à tous,

Je viens de trouver la source du problème et j'ai réparé.
J'ai relu tout le fil de discussion concernant l'ancienne version et un membre du forum, Rodolphe, avait le même souci.
J'ai donc été vérifier ce que contenait le fichier config.php (dossier inc) et le chemin vers l'admin était erroné.
Mon dossier dotclear ne s'appelle pas dotclear chez moi mais "blog".
Le chemin vers l'admin était le suivant :

// Admin URL. You need to set it for some features.
define('DC_ADMIN_URL','http://www.petitpilote.org/dotclear/admin/');

J'ai donc changé en :

define('DC_ADMIN_URL','http://www.petitpilote.org/blog/admin/');

Et ça fonctionne, la newsletter test est partie et reçue !

Merci beaucoup de t'être penché sur mon cas !

Ce plugin est superbe, merci encore. Je crois que je vais en user et abuser :-)


Firebug, indispensable pour les bidouilles :
http://getfirebug.com/
Mes bidouilles Noviny :
http://www.petitpilote.org/blog/index.p … Bidouilles

Hors ligne

#18 2010-01-12 15:35:40

Mathieu M.
Membre
Lieu : Rhône-Alpes
Inscription : 2009-09-14
Site Web

Re : [Extension Newsletter] : support de l'extension

Salut,

Hop, je signale un petit bug rencontré avec Newsletter et évoqué sur un autre sujet : http://forum.dotclear.net/viewtopic.php … 24#p275624 ;-)


++

Hors ligne

#19 2010-01-13 08:09:22

kwon
Membre
Lieu : Bordeaux
Inscription : 2006-08-05
Site Web

Re : [Extension Newsletter] : support de l'extension

Bonjour

susana a écrit :

Je viens de trouver la source du problème et j'ai réparé.

Ça c'est une bonne chose :D

susana a écrit :

Ce plugin est superbe, merci encore. Je crois que je vais en user et abuser :-)

Merci pour ton retour, j'espère qu'il comblera tes attentes ^^

Mathieu M. a écrit :

Hop, je signale un petit bug rencontré avec Newsletter et évoqué sur un autre sujet : http://forum.dotclear.net/viewtopic.php … 24#p275624 ;-)

Ok merci, je crée le billet pour supprimer cet intempestif retour à la ligne ;)

@++

Hors ligne

#20 2010-01-23 15:54:28

Jen
Membre
Inscription : 2009-09-25
Site Web

Re : [Extension Newsletter] : support de l'extension

Jen a écrit :

Pour le problème du non-envoi de la lettre, il semble que ça soit le fait d'enregistrer un billet en "en attente" qui perturbe la lettre.
- enregistrement du billet en attente -> passage en publié -> pas d'envoi auto de la lettre
- enregistrement du billet direct en publié -> envoi auto de la lettre marche bien.

Des nouvelles concernant ce problème ? C'est assez chiant car du coup je suis obligée d'envoyer manuellement la lettre, elle ne part pas toute seule.

D'autre part, j'ai voulu m'envoyer la lettre à moi-même pour tester un truc, j'ai eu le message d'erreur suivant :

ERROR: duplicate key value violates unique constraint "dc_uk_post_url"

Est-ce que ça vient du fait que j'avais déjà reçu cette lettre une fois ? On ne peut pas envoyer la même lettre automatique 2 fois ?

Merci !

Hors ligne

#21 2010-01-25 08:22:09

kwon
Membre
Lieu : Bordeaux
Inscription : 2006-08-05
Site Web

Re : [Extension Newsletter] : support de l'extension

Jen a écrit :

Pour le problème du non-envoi de la lettre, il semble que ça soit le fait d'enregistrer un billet en "en attente" qui perturbe la lettre.
- enregistrement du billet en attente -> passage en publié -> pas d'envoi auto de la lettre
- enregistrement du billet direct en publié -> envoi auto de la lettre marche bien.
Des nouvelles concernant ce problème ? C'est assez chiant car du coup je suis obligée d'envoyer manuellement la lettre, elle ne part pas toute seule.

Bonjour
Est-ce que tu as bien coché dans les paramètres du plugin l'option "Envoi automatique lors de la modification d'un billet" ? Si oui, je vais jeter un oeil au problème ;)

Jen a écrit :

ERROR: duplicate key value violates unique constraint "dc_uk_post_url"
Est-ce que ça vient du fait que j'avais déjà reçu cette lettre une fois ? On ne peut pas envoyer la même lettre automatique 2 fois ?

En fait lorsque l'envoi de la newsletter se fait, celle-ci créée un post avec l'URL définie dans le billet pour une vision online du billet ; lorsqu'on réémet le même jour, il faudrait supprimer cette lettre auto dans la liste des billets envoyés. Cette URL est spécifique au jour de l'envoi ... après, je me suis dit qu'envoyer plusieurs newsletter automatique le même jour était un peu trop, sauf pour les tests évidemment :=)

@++

Hors ligne

#22 2010-01-25 09:56:03

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : [Extension Newsletter] : support de l'extension

>kwon : juste une question : tu ne voudrais pas qu'on ferme l'autre sujet sur ce plugin, là il me semble qu'on va se mélanger les pinceaux ?

Hors ligne

#23 2010-01-25 10:42:12

Jen
Membre
Inscription : 2009-09-25
Site Web

Re : [Extension Newsletter] : support de l'extension

kwon a écrit :
Jen a écrit :

Pour le problème du non-envoi de la lettre, il semble que ça soit le fait d'enregistrer un billet en "en attente" qui perturbe la lettre.
- enregistrement du billet en attente -> passage en publié -> pas d'envoi auto de la lettre
- enregistrement du billet direct en publié -> envoi auto de la lettre marche bien.
Des nouvelles concernant ce problème ? C'est assez chiant car du coup je suis obligée d'envoyer manuellement la lettre, elle ne part pas toute seule.

Est-ce que tu as bien coché dans les paramètres du plugin l'option "Envoi automatique lors de la modification d'un billet" ? Si oui, je vais jeter un oeil au problème ;)

Non justement ! Car je ne veux pas que la lettre parte dès que, une fois publié, je fais une petite modif (style corriger une faute) dans le billet.
Je veux juste que la lettre parte une fois quand il est publié, que ce soit directement ou après un passage "en attente" et après basta, modification ou pas.
Tu vois ce que je veux dire ? Je sais pas si c'est possible...

Merci !

(et ok pour le message d'erreur !)

Hors ligne

#24 2010-01-25 12:16:48

kwon
Membre
Lieu : Bordeaux
Inscription : 2006-08-05
Site Web

Re : [Extension Newsletter] : support de l'extension

amalgame a écrit :

>kwon : juste une question : tu ne voudrais pas qu'on ferme l'autre sujet sur ce plugin, là il me semble qu'on va se mélanger les pinceaux ?

Merci d'avoir fait le nécessaire ;)

Jen a écrit :

Non justement ! Car je ne veux pas que la lettre parte dès que, une fois publié, je fais une petite modif (style corriger une faute) dans le billet.
Je veux juste que la lettre parte une fois quand il est publié, que ce soit directement ou après un passage "en attente" et après basta, modification ou pas.
Tu vois ce que je veux dire ? Je sais pas si c'est possible...

Je vois ce que tu veux dire, lors d'une modification, seul le passage de "en attente" à "publié" doit entrainer l'envoi. Par contre, ça me demande à me remettre aux propriétés metadata. Je vais essayer de voir si j'arrive à inclure ça ;)

@++

Hors ligne

#25 2010-01-25 20:55:31

Jen
Membre
Inscription : 2009-09-25
Site Web

Re : [Extension Newsletter] : support de l'extension

Super, merci beaucoup !
En attendant, je continue à envoyer la lettre manuellement pour ce cas là ;)

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map