Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2010-05-25 10:09:01

Lomalarch
Responsable du photocopieur
Lieu : Colombes (92)
Inscription : 2006-05-02
Site Web

[Dotclear 2.1.7] Attention compatibilité !

La mise à jour vers la version 2.1.7 n’apporte aucune modification quant au fonctionnement de de Dotclear MAIS certains plugins ont anticipé l’arrivée de la 2.2 et, pour parvenir à gérer les deux versions font un test sur la version utilisée.

Or, la 2.1.7, version « technique » pour la mécanique de mise à jour automatique n’a pas été, elle, prévue, et certains plugins vérifient la compatibilité jusqu’à la 2.1.6, de telle sorte que la 2.1.7 fait planter les plugins (et, accessoirement, l’ensemble du blog).

JcDenis a immédiatement réagi et propose d’ores et déjà une mise à jour de l’ensemble de ses plugins – JcDenis aka « le plugineur qui ne dort jamais ».

Nous avons également repéré, sur le Lab, les plugins suivants :

* gallery
* kturl -> mis à jour
* mymeta
* postExpired -> mis à jour
* smiliesEditor -> mis à jour
* le thème freshy2 a également été mis à jour (sur le lab et sur dotaddict).

Afin de régler le problème, si votre installation est bloquée, vous pouvez éditer les fichiers des plugins pour chercher des lignes ressemblant à

 		if (!version_compare(DC_VERSION,'2.1.6','>=')) {

et remplacer 2.1.6 par 2.1.7.

Pour les plugineurs, nous recommandons de préférer un test sur une version inférieure à 2.2-alpha – bien qu’aucune 2.1.8 ne soit dans les tuyaux.

Vous pouvez signaler dans ce fil les plugins qui nous auraient échappé, et nous éditerons ce message à mesure que les mises à jour auront été faites sur les plugins signalés.

Merci de votre attention.

Dernière modification par Lomalarch (2010-06-01 17:01:01)


RTFM attitude : https://fr.dotclear.org/documentation/2.0
Le chantier tips, tutos et astuces : http://tips.dotaddict.org/
Rien nulle part??? une petite recherche sul’ forum, alors?: https://forum.dotclear.org/search.php ?

Hors ligne

#2 2010-05-25 18:28:08

Topheur
Membre
Inscription : 2010-05-25

Re : [Dotclear 2.1.7] Attention compatibilité !

Bonjour,
L'installation auto n'a pas fonctionné a cause du fichier : /inc/clearbricks/image/class.dc.blogroll.php qui aurait été modifié.
L'installation auto semble Ok.
Vivement la 2.2

Hors ligne

#3 2010-05-25 18:33:43

Topheur
Membre
Inscription : 2010-05-25

Re : [Dotclear 2.1.7] Attention compatibilité !

Flute je me suis trompé.
Il s'agit du fichier : \inc\clearbricks\image\class.image.tools.php

Hors ligne

#4 2010-05-26 04:54:20

TulipVorlax
Membre
Lieu : Montréal
Inscription : 2010-01-01
Site Web

Re : [Dotclear 2.1.7] Attention compatibilité !

Puisque quelqu'un d'autre en parle, moi j'obtiens le message suivant :


•Comme les fichiers suivants de votre installation de Dotclear ont été modifiés, votre installation ne peut être mise à jour. Merci de mettre à jour manuellement.
?admin/style/default.css
?index.php
?plugins/akismet/_define.php
?plugins/akismet/_prepend.php
?plugins/akismet/class.dc.filter.akismet.php


Mais c'est pas grave, je mettrai la 2.2 moi-même....

Hors ligne

#5 2010-05-26 11:51:06

Narann
Membre
Inscription : 2009-02-28
Site Web

Re : [Dotclear 2.1.7] Attention compatibilité !

Idem, mais j'ai modifié dans admin/posts.php (line 145)

$nb_per_page =  30;

par

$nb_per_page =  3000;

Ras le bol d'avoir à naviguer entre les pages pour pouvoir voir la liste de ses billets.

Il n'y à pas moyen de mettre cette valeur dans le about:config? Pour la gérer manuellement? (Mieu, il n'y a pas moyen de faire un système de template pour l'admin? Je sais, j'abuse...)

J'ai remis 30 et la mise à jour n'a pas posé de problèmes.

Bonne chance pour la v2.2! :)

Hors ligne

#6 2010-05-26 12:01:47

Moe
Responsable du mini-bar
Lieu : France
Inscription : 2004-09-19
Site Web

Re : [Dotclear 2.1.7] Attention compatibilité !

Tu as raison, cette définition "en dur" dans le code nuit à la personnalisation. Je te conseille de créer un ticket à ce propos. Je verrais plutôt un paramètre pour l'utilisateur que pour le blog, ça se discute, mais ce n'est pas le sujet ici. :)

Hors ligne

#7 2010-05-28 09:52:13

JcDenis
Membre
Lieu : Lyon, France
Inscription : 2007-08-31
Site Web

Re : [Dotclear 2.1.7] Attention compatibilité !

Pour info (et pour en revenir au sujet) les plugins kUtRL et postExpired ont été mis à jour pour la 2.1.7..


Cordialement,
_JC | Intérimaire | En mode invisible

Hors ligne

#8 2010-06-01 04:35:02

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : [Dotclear 2.1.7] Attention compatibilité !

Pour info ; pour le plugin SmileEditor, "remplacer 2.1.6 par 2.1.7" supprime le message d'erreur, mais ne fonctionne pas puisque personnellement, ma barre d'émoticones n'est pas visible...

Hors ligne

#9 2010-06-01 16:35:48

Lomalarch
Responsable du photocopieur
Lieu : Colombes (92)
Inscription : 2006-05-02
Site Web

Re : [Dotclear 2.1.7] Attention compatibilité !

J’ai mis à jour ce matin SmiliesEditor, qui doit désormais être compatible (j’ai dû m’y reprendre à plusieurs fois, d’ailleurs, mais là ça marche) : essaie d’installer la dernière version http://lab.dotclear.org/wiki/plugin/smiliesEditor


RTFM attitude : https://fr.dotclear.org/documentation/2.0
Le chantier tips, tutos et astuces : http://tips.dotaddict.org/
Rien nulle part??? une petite recherche sul’ forum, alors?: https://forum.dotclear.org/search.php ?

Hors ligne

#10 2010-06-02 07:48:45

Serveur
Membre
Lieu : Champagne Ardenne
Inscription : 2008-12-08
Site Web

Re : [Dotclear 2.1.7] Attention compatibilité !

Ouille ... la version smiliesEditor sur mon blog est la v0.1.4 et je vois que ton lien pointe vers une v0.3.8 ... moi aussi faut je j'arrête la coke, ça m'endors de trop LOL


J'y connais rien mais je ne demande qu'à apprendre ... !!!
Weezo v2 : http://weezo.net/Serveur (quelques petits problèmes en ce moment)
Blog DC 2.9.1 chez 1&1 : http://www.elleluinous.fr/ (multi-Blog)
Blog DC 2.9.1 chez 1&1 de l'E.P.R.A.S. : http://www.epras.fr/

Hors ligne

#11 2010-06-04 23:16:42

BG
Membre
Lieu : 17
Inscription : 2005-05-11
Site Web

Re : [Dotclear 2.1.7] Attention compatibilité !

subscribeToComment 1.3.1 pose problème, après avoir cherché un bon moment je viens de voir que c'est lui qui m'a crée une erreur 500.


Installer votre premier blog : http://abc.dotaddict.org
Documentation Dotclear2:    http://fr.dotclear.org/documentation/2.0/
Astuces (Tips), Plugins, Thèmes: http://dotaddict.org/

Hors ligne

#12 2010-06-05 06:20:10

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : [Dotclear 2.1.7] Attention compatibilité !

??? Chez moi la version 1.3.1 à l'air de fonctionner parfaitement...

Hors ligne

#13 2010-06-11 10:45:14

Lomalarch
Responsable du photocopieur
Lieu : Colombes (92)
Inscription : 2006-05-02
Site Web

Re : [Dotclear 2.1.7] Attention compatibilité !

Sur la 2.1.7 ? Tu es sûr que tu ne fais pas référence à la beta ? Ou alors, on a un « conflit » nouveau avec un autre plugin, qui n’existait pas en 2.1.6 (mais ce serait étonnant)…


RTFM attitude : https://fr.dotclear.org/documentation/2.0
Le chantier tips, tutos et astuces : http://tips.dotaddict.org/
Rien nulle part??? une petite recherche sul’ forum, alors?: https://forum.dotclear.org/search.php ?

Hors ligne

#14 2010-06-11 11:39:53

BG
Membre
Lieu : 17
Inscription : 2005-05-11
Site Web

Re : [Dotclear 2.1.7] Attention compatibilité !

Lomalarch a écrit :

Sur la 2.1.7 ? Tu es sûr que tu ne fais pas référence à la beta ? Ou alors, on a un « conflit » nouveau avec un autre plugin, qui n’existait pas en 2.1.6 (mais ce serait étonnant)…

oui effectivement il s'agit de la beta,je me suis un peu emmêlé les pinceaux ... j'ai fais suivre le plus d'infos possible à Moe pour ce souci ! ;)


Installer votre premier blog : http://abc.dotaddict.org
Documentation Dotclear2:    http://fr.dotclear.org/documentation/2.0/
Astuces (Tips), Plugins, Thèmes: http://dotaddict.org/

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map