Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2010-06-21 06:08:02

osku
Membre
Lieu : 28
Inscription : 2005-06-15

[private (mode)] - support de l'extension

Ce plugin, compatible 2.1.6 et au delà, permet de protéger son blog par un mot de passe.

Télécharger : http://dleds.net/dl/plugin-privateMode

Fonctionnalités :
* Définition du mot de passe, du titre et d'un message pour l'accueil des visiteurs. Le titre et le message sont facultatifs.
* Connexion automatique (via un cookie) optionnelle pour les visiteurs.
* Personnalisation possible via le template private.html. (avec l'éditeur de thème)

Hors ligne

#2 2010-06-21 13:52:49

Don Quilmi
Membre
Lieu : Brest
Inscription : 2008-05-04
Site Web

Re : [private (mode)] - support de l'extension

Un petit souci avec cette version chez moi : l'option permettant de mémoriser le mot de passe n'apparait pas dans la page d'identification (et oui, l'option est bien cochée dans l'interface du plugin).

Hors ligne

#3 2010-06-21 14:25:47

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : [private (mode)] - support de l'extension

Don Quilmi a écrit :

Un petit souci avec cette version chez moi : l'option permettant de mémoriser le mot de passe n'apparait pas dans la page d'identification (et oui, l'option est bien cochée dans l'interface du plugin).

Tu as la version 1.3.1 ?

Hors ligne

#4 2010-06-21 14:33:21

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : [private (mode)] - support de l'extension

Le nom du setting a changé. Il faut de nouveau passer par l'admin' du ploug pour avoir l'option.

Hors ligne

#5 2010-06-21 15:27:03

Don Quilmi
Membre
Lieu : Brest
Inscription : 2008-05-04
Site Web

Re : [private (mode)] - support de l'extension

Oui j'ai redéfini tout ça par l'admin, mais ça ne fonctionne pas. L'option est bien cochée dans l'admin, mais le {{tpl:PrivatePassRemember}} n'est pas affiché sur la page.

Hors ligne

#6 2010-06-21 15:29:40

Don Quilmi
Membre
Lieu : Brest
Inscription : 2008-05-04
Site Web

Re : [private (mode)] - support de l'extension

Au fait, je suis en Dotclear 2.1.7 et j'ai la v1.3.1 du ploug.

Hors ligne

#7 2010-06-21 15:30:13

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : [private (mode)] - support de l'extension

Don Quilmi a écrit :

Oui j'ai redéfini tout ça par l'admin, mais ça ne fonctionne pas. L'option est bien cochée dans l'admin, mais le {{tpl:PrivatePassRemember}} n'est pas affiché sur la page.

Curieux.
Tu as quelle version de Dotclear et du plug  ?

Hors ligne

#8 2010-06-21 15:32:01

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : [private (mode)] - support de l'extension

Tu peux vider le cache des template par le plugin maintenance ?

Hors ligne

#9 2010-06-21 15:43:44

Don Quilmi
Membre
Lieu : Brest
Inscription : 2008-05-04
Site Web

Re : [private (mode)] - support de l'extension

C'est fait, et ça marche. Grompf. Chuis trop nul, je fais toujours ça d'habitude après une màj. Désolé pour le dérangement !

Et encore merci pour le plugin.

Hors ligne

#10 2010-07-01 13:02:43

Don Quilmi
Membre
Lieu : Brest
Inscription : 2008-05-04
Site Web

Re : [private (mode)] - support de l'extension

Coucou c'est encore moi ! (le chieur de service)

Après la mise à jour en 2.2, j'ai le message d'erreur suivant lorsque je tente d'accéder à mon backend :
Call to a member function addNamespace() on a non-object in /home/brestfr/public_html/site2/plugins/private/_prepend.php  on line 37

Pour la petite histoire, je me suis contenté de commenter la ligne et tout semble fonctionner parfaitement.

Hors ligne

#11 2010-07-01 13:05:28

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : [private (mode)] - support de l'extension

Don Quilmi a écrit :

Coucou c'est encore moi ! (le chieur de service)

Après la mise à jour en 2.2, j'ai le message d'erreur suivant lorsque je tente d'accéder à mon backend :
Call to a member function addNamespace() on a non-object in /home/brestfr/public_html/site2/plugins/private/_prepend.php  on line 37

Pour la petite histoire, je me suis contenté de commenter la ligne et tout semble fonctionner parfaitement.

Tu t'es bien déconnecté suite à la maj de Dotclear ?
Tu es bien en version 2.2 ?

Je vais voir..

Hors ligne

#12 2010-07-01 13:13:48

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : [private (mode)] - support de l'extension

osku a écrit :
Don Quilmi a écrit :

Coucou c'est encore moi ! (le chieur de service)

Après la mise à jour en 2.2, j'ai le message d'erreur suivant lorsque je tente d'accéder à mon backend :
Call to a member function addNamespace() on a non-object in /home/brestfr/public_html/site2/plugins/private/_prepend.php  on line 37

Pour la petite histoire, je me suis contenté de commenter la ligne et tout semble fonctionner parfaitement.

Tu t'es bien déconnecté suite à la maj de Dotclear ?
Tu es bien en version 2.2 ?

Je vais voir..

Comment as-tu fait ta mise à jour de Dotclear ?
Chez moi ça marche :)

Hors ligne

#13 2010-07-01 13:37:49

Don Quilmi
Membre
Lieu : Brest
Inscription : 2008-05-04
Site Web

Re : [private (mode)] - support de l'extension

Hello

Alors, ça remarche, mais ce coup ci ça n'était pas (complètement) ma faute :

Après la mise à jour ("vous n'êtes plus qu'à un clic..."), je suis tombé sur la page d'erreur. Impossible donc de me déconnecter.

Il a fallu que je bidouille le _prepend.php pour retrouver ma page d'admin. De là j'ai pu me déconnecter, remettre en place le prepend.php puis me reconnecter.

Bref ça remarche.

J'avais loupé une étape ou quoi ?

Hors ligne

#14 2010-07-01 14:24:37

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : [private (mode)] - support de l'extension

Don Quilmi a écrit :

Hello

Alors, ça remarche, mais ce coup ci ça n'était pas (complètement) ma faute :

Après la mise à jour ("vous n'êtes plus qu'à un clic..."), je suis tombé sur la page d'erreur. Impossible donc de me déconnecter.

Il a fallu que je bidouille le _prepend.php pour retrouver ma page d'admin. De là j'ai pu me déconnecter, remettre en place le prepend.php puis me reconnecter.

Bref ça remarche.

J'avais loupé une étape ou quoi ?

L'idéal aurait été de désactiver le plugin pendant la mise à jour. (à défaut créer un fichier _disabled dans le répertoire du plugin).

Heureux que ça remarche.

Hors ligne

#15 2010-07-26 06:26:30

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : [private (mode)] - support de l'extension

Version 1.4
Ajout de la barre d'édition côté admin pour la rédaction du message d'accueil.

Hors ligne

#16 2010-09-11 06:28:36

Don Quilmi
Membre
Lieu : Brest
Inscription : 2008-05-04
Site Web

Re : [private (mode)] - support de l'extension

Hello

Chez moi, depuis la v1.5, la connexion automatique ne fonctionne plus.

J'ai tout tenté, effacé à la main le répertoire du ploug et les entrées dans mySQL, effacé aussi le cache des templates, mais sans résultat. La case "activer la connexion automatque" est bien proposée, mais elle reste sans effet.

Merci de ton aide.

Hors ligne

#17 2010-12-16 19:44:16

malib
Membre
Inscription : 2009-02-10

Re : [private (mode)] - support de l'extension

Bonjour,

Je teste actuellement ce plugin  sur une version 2.2 de Dotclear et j'ai ne n'arrive pas à le faire fonctionner...
Plugin Activé (en rouge dans le menu), j'accède au blog sans demande de mot de passe...
Le Widget est installé. Le bouton Se déconnecter recharge la page, mais toujours sans afficher la demande de mot de passe...

Sur une autre installation, toujours en 2.2 et en multiblog problème identique. Avec une légère différence.
Seul un des deux blogs est en mode privé et j'atterris sur la page de demande de mot de passe à la première ouverture. Ensuite il suffit que je recharge celle-ci pour voir l'accueil du blog...

Hors ligne

#18 2010-12-17 09:05:30

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : [private (mode)] - support de l'extension

malib a écrit :

Bonjour,

Je teste actuellement ce plugin  sur une version 2.2 de Dotclear et j'ai ne n'arrive pas à le faire fonctionner...
Plugin Activé (en rouge dans le menu), j'accède au blog sans demande de mot de passe...
Le Widget est installé. Le bouton Se déconnecter recharge la page, mais toujours sans afficher la demande de mot de passe...

Sur une autre installation, toujours en 2.2 et en multiblog problème identique. Avec une légère différence.
Seul un des deux blogs est en mode privé et j'atterris sur la page de demande de mot de passe à la première ouverture. Ensuite il suffit que je recharge celle-ci pour voir l'accueil du blog...

C'est très curieux. Peux-tu me faire parvenir des URLs pour que je constate par moi même ?

Quels sont les caractéristiques de ton hébergement ?
As-tu constaté d'autres curiosités dans l'utilisation de dotclear par ailleurs ?
Quels sont les autres plugins fraichement installés ?

Hors ligne

#19 2010-12-19 19:33:45

malib
Membre
Inscription : 2009-02-10

Re : [private (mode)] - support de l'extension

osku a écrit :

C'est très curieux. Peux-tu me faire parvenir des URLs pour que je constate par moi même ?
Quels sont les caractéristiques de ton hébergement ?
As-tu constaté d'autres curiosités dans l'utilisation de dotclear par ailleurs ?
Quels sont les autres plugins fraichement installés ?

Impossible de te montrer ça pour le moment, je teste en local.
J'utilise un serveur LAMP à base d'Ubuntu Lucid (10.04) avec un PHP 5.3 et la dernière version de dotclear.
J'ai dû patcher rapidement certains plugins, pour le support du 5.3, en enlevant les passages d'arguments par référence.
Hors plugins standards, voilà la liste :
- atReply
- commentsWikibar
- contactMe
- daInstaller
- editComment
- emailNotification
- emailOptionnel
- googleTools
- highlightVisitor
- lightbox
- miniseo
- private
- prvcat
- related
- sitemaps
- subscribeToComments
- tinyMce
- writers

Je teste actuellement sur un dotclear tout frais et sans multi-blog et ça passe....

Hors ligne

#20 2010-12-30 22:21:24

malib
Membre
Inscription : 2009-02-10

Re : [private (mode)] - support de l'extension

Je confirme le bug.

Je viens de finir mes tests avec :
- une nouvelle installation dotclear from scratch
- un multi-blog avec une installation propre
- private-mode en tant que seul plugin ajouté
- le widget présent sur le blog en mode privé.
- on vide le cache, on met à jour les bandeaux.

mêmes effets :
- la page de demande de mot de passe s'affiche une première fois
- on recharge la page et on atterris sur le blog sans protection
- le cookie dc_privateblog_sess_blog2 n'est pas positionné

Je suis toujours sur un PHP 5.3.2...
J'ai malgré tout décidé de tenter de reporter mon changement sur l'hébergment de production (OVH) du blog et là ça fonctionne.
La différence majeure par rapport à mes tests est le PHP 5.2 de cet hébergement.

Hors ligne

#21 2010-12-31 09:28:02

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : [private (mode)] - support de l'extension

Le plugin fonctionne très bien chez moi avec du PHP >= 5.3 (en local sous Ubuntu 10.10) ou en hébergement distant (OVH, alwaysdata)

Tu essaies de fermer ton navigateur entre tes tests de connexion ? (afin de détruire la session)

Hors ligne

#22 2011-03-10 10:23:49

Dessa
Membre
Inscription : 2006-07-10

Re : [private (mode)] - support de l'extension

Bonjour, j'ai un petit problème avec le plugin Private. J'ai installé un multiblog (j'ai procédé à l'upgrade dernière version 2.2.2) et j'ai la dernière mise à jour du plugin Private.
Sur 2 de mes blogs, l'option cochée "Proposer la connexion automatique aux visiteurs" fonctionne très bien.
Sur le 3ème, la case étant cochée, la possibilité de conserver la connexion n'apparaît pas.

Après avoir regardé un peu tous les sujets sur ce forum, j'ai fait plusieurs tentatives (vidage de cache de template, suppression de cookies...).
Mes 3 blogs sont configurés de la même façon. Ils sont configurés selon le guide du multiblog, soit avec des répertoires séparés pour les plugins et les fichiers publics.

Ils sont hébergés sur serveur dédié chez OVH.

Et j'ai un second multiblog sur un autre domaine et le blog que j'ai mis en "privé" propose bien l'option de connexion automatique.

La dernière tentative que je n'ai pas faite, c'est de désinstaller et de réinstaller le plugin car je crains de perdre les adresses des flux rss et qu'elles soient réinitialisées.
Est-ce que quelqu'un peut me dire si ce serait le cas ?

Ces blogs étant privé, je ne souhaite pas mettre l'adresse ici mais juste savoir si une réinstallation du plugin réinitialiserait mes flux rss.
Merci d'avance pour vos réponses.

Hors ligne

#23 2011-03-10 13:22:38

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : [private (mode)] - support de l'extension

Bonjour,

C'est très curieux. Quelles sont les différences entre le blog où ça ne marche pas et les autres ?

Quel est le thème utilisé sur le blog concerné ? As-tu essayé avec le thème Blowup (par défaut) ?

Hors ligne

#24 2011-03-10 13:43:41

Dessa
Membre
Inscription : 2006-07-10

Re : [private (mode)] - support de l'extension

BINGO ! Merci osku ! Le thème que j'utilise est Welsh 2.0 de Kozlika. Sauf que j'ai la version 0.7 (adaptée à mes besoins) et non la 0.8 qui est la dernière.
En appliquant la 0.8 (de base) je vois la case à cocher !

Ce qui reste bizarre, c'est que sur l'un de mes autres blogs où ça marche, c'est également le thème Welsh 2.0 en version 0.7 qui est utilisé. Et les modifications (de couleurs ou d'images) sont sensiblement les mêmes.

Je creuse par là. Et de toute façon mieux vaut avoir la dernière version des thèmes... je vais donc appliquer mes modifications sur cette dernière version.

Merci bien !!

(Je suis toujours preneuse de l'information sur la désinstallation et la réinstallation du plugin... si cela réinitialise les flux rss car j'ai déjà constaté une réinitialisation lors d'une mise à jour du plugin il y a quelques temps...).

Hors ligne

#25 2011-03-10 13:52:25

Dessa
Membre
Inscription : 2006-07-10

Re : [private (mode)] - support de l'extension

Problème résolu en copiant la page private.html du thème qui marchait à la place de celle qui ne marchait pas.

C'est pas forcément très propre de le faire à la main et je ne comprends pas bien pourquoi ça ne s'était pas actualisé... mais c'est réglé de ce côté-là.

Merci. :)

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map