Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2010-07-02 08:18:41

Kozlika
Modo dcTeam
Inscription : 2004-05-08
Site Web

Dotclear 2.2, vérifiez la compatibilité de vos plugins

Si vous n'utilisez pas de plugin supplémentaire sur votre installation de Dotclear, la mise à jour se passera en deux clics sans difficulté aucune. Mais attention : cette version apportant des modifications dans le codage des plugins, il se peut que vous rencontriez des difficultés de ce côté. Quelques conseils pour que ça se passe en douceur.

Pour les plugins que vous avez ajoutés à votre installation de base, quatre cas peuvent se présenter :
1. ils sont directement compatibles avec la version 2.2 de Dotclear
2. ils ne sont pas bloquants mais nécessitent une mise à jour
3. ils sont incompatibles mais leurs auteurs les ont mis à jour
4. ils sont incompatibles et leurs auteurs ne les ont pas mis à jour


Le premier cas est le plus peinard, vous n'avez rien à faire de spécial. Le deuxième cas ne présente pas de difficulté non plus, après la mise à jour de Dotclear, puis vous mettez à jour daInstaller (attention, la mise à jour manuelle est recommandée pour ce plugin) et ensuite vous lancez la mise à jour des plugins signalés.

Dans les deux derniers cas, si vous lancez la mise à jour de Dotclear directement, un vilain message s'affichera (et parfois même plusieurs selon le nombre de vos plugins incompatibles) et vous empêchera d'accéder à votre interface d'administration.

Le mieux est d'anticiper en suivant le conseil en fin de ce billet. Si cependant vous avez lancé la mise à jour sans précautions et vous êtes retrouvés nez à nez avec ces messages :

1. Relevez leur nom et supprimez chacun des plugins en question : on reconnaît leur nom dans tout le charabia des messages d'erreur. (Si une suppression pure et simple vous angoisse, vous pouvez tout d'abord les sauvegarder sur votre ordinateur à l'aide de votre client FTP pour pouvoir revenir en arrière si besoin.) Vous pourrez de nouveau accéder à votre installation.

2. Depuis votre tableau de bord, rendez-vous sur le module daInstalleur et utilisez l'onglet "Recherche" pour installer la version mise à jour de chacun des plugins que vous avez supprimé.

3. Si le plugin n'a pas été mis à jour, il vous faut attendre qu'il le soit en surveillant le fil RSS du site de dépôt des plugins ou en regardant si une bonne âme a pris provisoirement le plugin sous son aile en consultant ce lien dédié sur le forum.

Cette procédure présente un seul inconvénient : si vous avez absolument besoin d'un plugin qui n'a pas été mis à jour, vous ne pourrez pas vous en servir sans revenir en arrière à la version 2.1.7 de Dotclear.

Nous vous suggérons donc de vérifier au préalable pour les plugins qui vous sont indispensables qu'il existe bien une version compatible avec Dotclear 2.2 et d'attendre qu'ils le soient si ça n'est pas le cas. N'hésitez pas à en contacter l'auteur ou à demander sur le fil cité plus haut si un codeur peut s'en occuper en attendant que l'auteur s'en charge.


La documentation : http://doc.dotclear.net/2.0/fulltoc
Le module de recherche du forum : http://www.dotclear.net/forum/search.php ?

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map