Dotclear

Vous n'êtes pas identifié(e).

Annonce

#26 2010-09-19 16:49:57

nairolf54
Membre
Inscription : 2010-07-26

Re : Gallery 0.4 : support du plugin

Toujours des problèmes sur le plugin suite a la mise a jour de DC
voir ce post :
http://forum.dotclear.net/viewtopic.php?id=43052

je suis passé en version 0.4 et toujours le même problème
je suis chez free
pgsql 8.3.1
php 5.1.3.rc4dev
Voici quelques copies d'écran :
about:config
message d'erreur
action impossible

Merci a tous
en esperant résoudre le problème sans tout réinstaller :(

Hors ligne

#27 2010-09-21 17:32:17

nairolf54
Membre
Inscription : 2010-07-26

Re : Gallery 0.4 : support du plugin

Bonjour à tous,
J'ai enfin reussi a faire reaparaitre le gallery_themes_path en utilisant le plugin "clean:config" + le plugin "Gestionnaire de versions"
ouf

maintenant un nouveau problème est apparu :( :
impossible de soumettre de nouvelles images.
Il aparait en rouge des #ERR# a chaque lignes !
voir cette copie d'écran

Si vous avez une solution
Merci d'avance

Hors ligne

#28 2010-09-21 17:45:05

nairolf54
Membre
Inscription : 2010-07-26

Re : Gallery 0.4 : support du plugin

Re bonjour,
parfois, le message est :
#ERR#Function does not exist

Merci

Hors ligne

#29 2010-09-21 18:00:28

Dsls
Modérateur couteau-suisse
Inscription : 2004-11-18
Site Web

Re : Gallery 0.4 : support du plugin

C'est un problème lié à free. Il faut passer le paramètre gallery_max_ajax_requests à 2, voire 1 dans about:config


Dyslexics have more fnu!

Hors ligne

#30 2010-09-22 07:59:24

nairolf54
Membre
Inscription : 2010-07-26

Re : Gallery 0.4 : support du plugin

OK, merci free

J'ai passé le paramètre a 1, mais j'ai fait la mise a jour vers ie9beta et le bouton soumettre n'a plus aucun effet :(

Quelle galère...

Hors ligne

#31 2010-09-22 08:11:16

Dsls
Modérateur couteau-suisse
Inscription : 2004-11-18
Site Web

Re : Gallery 0.4 : support du plugin

Et avec un navigateur non-beta, type firefox ou chrome, ça marche ?


Dyslexics have more fnu!

Hors ligne

#32 2010-09-22 08:13:16

Dsls
Modérateur couteau-suisse
Inscription : 2004-11-18
Site Web

Re : Gallery 0.4 : support du plugin

Peux-tu en parallèle installer le plugin integrityCheck et vérifier que ton install est cohérente ?


Dyslexics have more fnu!

Hors ligne

#33 2010-09-24 05:23:32

nairolf54
Membre
Inscription : 2010-07-26

Re : Gallery 0.4 : support du plugin

L'erreur #ERR# apparait toujours sous chrome meme avec le parametre mis a 1
le plugin integritycheck ne dit que tout est ok
A suivre

Hors ligne

#34 2010-09-24 05:25:46

nairolf54
Membre
Inscription : 2010-07-26

Re : Gallery 0.4 : support du plugin

voici le dernier resultat

Nombre de médias orphelins (ie. les médias présents en base de données mais dont le fichier n'existe plus) : #ERR#   Supprimer les médias orphelins
Nombre d'images orphelines (ie. billets-images associés à un média inexistant en base) : #ERR#Function does not exist   Supprimer les images orphelines
Nombre de nouveaux médias détectés : #ERR#Function does not exist   Créer les médias en base
Nombre de médias sans billet associé : #ERR# Function does not exist   Créer les billets-images pour les médias dans le dossier
Nombre de médias dans le répertoire : #ERR#Function does not exist   Forcer la régénération des miniatures

Hors ligne

#35 2010-09-24 06:15:01

Dsls
Modérateur couteau-suisse
Inscription : 2004-11-18
Site Web

Re : Gallery 0.4 : support du plugin

Peux-tu tester avec firebug, et me dire les paramètres transmis aux requêtes Ajax ? J'ai écrit un tuto à ce sujet : http://www.morefnu.org/post/2010/08/30/ … ec-firebug


Dyslexics have more fnu!

Hors ligne

#36 2010-09-29 06:11:48

nairolf54
Membre
Inscription : 2010-07-26

Re : Gallery 0.4 : support du plugin

tout fonctionne avec firefox, rien avec IE8
dommage
Merci

Hors ligne

#37 2010-09-29 06:41:22

Dsls
Modérateur couteau-suisse
Inscription : 2004-11-18
Site Web

Re : Gallery 0.4 : support du plugin

Dommage surtout que IE8 soit si mal foutu et respecte si peu les standards... pour ma part, je n'ai pas de IE8 à disposition pour tester quoi que ce soit.


Dyslexics have more fnu!

Hors ligne

#38 2010-09-29 13:58:58

patidou
Membre
Inscription : 2004-11-14
Site Web

Re : Gallery 0.4 : support du plugin

Tiens une petite question : où dois-je placer les gabarits dans un thème? Dans un sous-dossier "tpl/gal_simple"? Les galeries n'affichent plus sur mon site…


«Quand j'étais petit, je voulais être maître du monde. Maintenant que je suis grand, j'arrive à peine à être maître de moi-même.» Le Chat/Philippe Geluk.
Dotclear a besoin de vous

Hors ligne

#39 2010-09-29 17:37:24

Black Angel
Membre
Inscription : 2008-05-11

Re : Gallery 0.4 : support du plugin

Bonjour patidou,

Dsls m'avait proposé deux solutions pour placer un nouveau thème de galerie au message #16 de ce fil.  J'ai opté pour la première pour ma part. ;-)

Hors ligne

#40 2010-09-29 18:33:21

patidou
Membre
Inscription : 2004-11-14
Site Web

Re : Gallery 0.4 : support du plugin

Merci ;-)


«Quand j'étais petit, je voulais être maître du monde. Maintenant que je suis grand, j'arrive à peine à être maître de moi-même.» Le Chat/Philippe Geluk.
Dotclear a besoin de vous

Hors ligne

#41 2010-10-04 21:37:00

vinzoo
Membre
Inscription : 2006-06-22

Re : Gallery 0.4 : support du plugin

Bonjour, suite à une mise à jour de DC 2.1.5 vers 2.2 j'ai eu plusieurs difficultés, mais surtout que Gallery ne répond plus. Les liens vers les galleries me renvoient
Unable to find template
Something went wrong while loading template file for your blog.
et dans l'interface DC, dans Galeries, seul l'onglet Options est accessible, les autres sont morts.
Plus d'infos sur le scénario ici http://forum.dotclear.net/viewtopic.php … 05#p293405  (post #6)
Merci de votre aide.

Hors ligne

#42 2010-10-25 22:03:57

vinzoo
Membre
Inscription : 2006-06-22

Re : Gallery 0.4 : support du plugin

Pas de réponse? Plizzz

Hors ligne

#43 2010-10-25 22:20:29

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Gallery 0.4 : support du plugin

Et tu as bien la version de Gallery pour Dotclear 2.2 ?

Hors ligne

#44 2010-10-30 10:15:32

vinzoo
Membre
Inscription : 2006-06-22

Re : Gallery 0.4 : support du plugin

Oui j'ai mis la dernière version.

Hors ligne

#45 2010-11-07 16:36:04

spooky
Membre
Inscription : 2010-10-03
Site Web

Re : Gallery 0.4 : support du plugin

Bonjour
j'ai installé et essayé galerie pour dotclear 2.2 et j'ai fait une bêtise, j'ai généré des billets pour chaque image après leur détection alors que je ne voulais pas... Mais au moment de cliquer sur galeries ou images dans le module galeries j'ai ce message d'erreur:
Fatal error: Cannot redeclare class adminPostList in /home/ericlope/public_html/ecotones/inc/admin/lib.pager.php on line 143

du coup impossible de supprimer ces maudits billets avec une seule image !!
Je suis débutant en dotclear et ne connais rien en programmation ! Merci pour votre aide pour faire marcher galeries !

Hors ligne

#46 2010-11-07 16:38:15

spooky
Membre
Inscription : 2010-10-03
Site Web

Re : Gallery 0.4 : support du plugin

oups désolé me suis trompé de page ! je copie sur le fil pour dc2.2

Hors ligne

#47 2010-11-07 21:40:42

vinzoo
Membre
Inscription : 2006-06-22

Re : Gallery 0.4 : support du plugin

OK, il semble que personne n'ait d'élément de réponse. Dsls est attendu désespérement ! :(
Une méthode pourrait être dfe désinstaller puis réinstaller Gallery, mais est-ce que ça va effacer les bases de données de Gallery (tous les albums) aussi?

Hors ligne

#48 2010-11-10 22:14:56

vinzoo
Membre
Inscription : 2006-06-22

Re : Gallery 0.4 : support du plugin

Bonjour, l'installation de 2.2 n'était pas effective et je tournais encore sous 2.1.5 sans le savoir, c'est pourquoi le dernier Gallery 0.4 ne fonctionnait pas.

Hors ligne

#49 2010-11-12 00:48:51

karpediem
Membre
Lieu : Saint-Denis
Inscription : 2007-12-30
Site Web

Re : Gallery 0.4 : support du plugin

Bonsoir,

Je me suis inspirée de ce que Dsls expliquait sur ce même fil en #18 et j'ai choisi la 2eme option, à savoir :

Dsls a écrit :

2/ Créer un répertoire à part, du même type que /public, et y copier tous les thèmes gallery, et y mettre le tien. Il te suffira alors de modifier le chemin vers les thèmes gallery via about:config et le paramètre gallery_themes_path

Je précise que je suis en multiblog et que mon objectif n'est pas de créer un nouveau theme mais juste d'adapter ceux existants.

J'ai effectué les opérations suivantes :
- j'ai créé un répertoire /gallery/ au même niveau que /public/ dans mon répertoire de blog /blog2/
- dans le répertoire /blog2/gallery/ j'ai copié le contenu au complet, du dossier "default-templates" du plugin
- dans about:config pour gallery_themes_path j'ai spécifié ../blog2/gallery
- dans l'admin du plugin dans l'onglet "option", "Thème par défaut" j'ai choisi dans la liste : simple

Je pensais qu'en modifiant les fichiers gallery.css et gallery.html qui se trouvent maintenant dans mon répertoire /blog2/gallery/gal_simple/, l'affichage côté public de mes galeries serait modifié en conséquence, mais en fait non...
En bidouillant et en essayant plusieurs choses, j'ai réussit à ce que mes modifs de gallery.css et gallery.html soient prises en compte à l'affichage de mes galeries en copiant les fichiers du répertoire /blog2/gallery/gal_simple/ au niveau du /tpl/gal_simple/ de mon theme (sans modifier mon about:config)...

Du coup, je me dis que je n'ai pô dû tout comprendre ou alors j'ai (encore) zappé un truc...
A quoi ça sert de spécifier un gallery_themes_path s'il n'en tient pas compte puisqu'il va charger les fichiers qui se trouvent dans /tpl/ ?

Merci de vos réponses et bonne soirée !

Hors ligne

#50 2010-12-21 12:59:09

DMA
Membre
Inscription : 2010-12-21

Re : Gallery 0.4 : support du plugin

Même après réinstallation proprement j'ai l'erreur suivante :

Fatal error: Cannot redeclare class adminpostlist in Xxx/inc/admin/lib.pager.php on line Xxx

j'ai supprimé les class à priorir inutile mais ce sont les billets que ne fonctionne plus après.... une idée à ce "bug" ?

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map