Dotclear

Vous n'êtes pas identifié(e).

Annonce

#426 2016-08-18 12:41:33

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : [nouveau thème] Chestnut

C'est le comportement voulu par Azork.
Je ne vais pas modifier cela.

En ligne

#427 2016-08-18 12:56:13

scotlandyard
Membre
Lieu : Sainte-Croix (Suisse)
Inscription : 2005-06-25
Site Web

Re : [nouveau thème] Chestnut

Ok, je n'avais pas compris ça.
Il me semblait que sur les premières versions, l'exerpt apparaissait en dc-post.


------<scotlandyard>------
Fan des thèmes d'Azork
DC1: tamaki.li - soripro.ch / DC2: pomey.com - jardinsdivers.ch - chasseron.net
Site qui m'occupe pour le moment: webpratique.ch

Hors ligne

#428 2016-08-18 12:58:29

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : [nouveau thème] Chestnut

Quand je regarde sur le site d'Azork (v1.0), l'extrait n'est pas dans post.html.

En ligne

#429 2016-08-18 17:26:28

scotlandyard
Membre
Lieu : Sainte-Croix (Suisse)
Inscription : 2005-06-25
Site Web

Re : [nouveau thème] Chestnut

Mes excuses alors, j'ai mal souviendu.


------<scotlandyard>------
Fan des thèmes d'Azork
DC1: tamaki.li - soripro.ch / DC2: pomey.com - jardinsdivers.ch - chasseron.net
Site qui m'occupe pour le moment: webpratique.ch

Hors ligne

#430 2017-01-26 14:17:32

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : [nouveau thème] Chestnut

Bonjour. J'utilise un thème personnalisé basé sur Chesnut sur ce blog http://sophiatt.com ; et je viens de me rendre compte d'un petit bug au niveau de la page publique des commentaires.

En effet lorsqu'un visiteur rédige une note et qu'il souhaite la "prévisualiser", la page qui se recharge alors n'est plus celle des commentaires, mais celle de l'article. Il faut retourner manuellement sur l'onglet "commentaire" pour prévisualiser" sa note et pouvoir l'"envoyer".
Et même quand le commentaire est envoyé et publié, la page qui se recharge alors est celle de l'article à nouveau ! Encore un clic sur l'onglet "commentaire" pour constater que le message "votre commentaire a été publié" est bien présent avec la note.
Idem quand on pointe sa souris dans le widget "derniers commentaires" , on arrive sur l'article, mais pas sur le commentaire...

Aurais-je trop personnalisé ce thème , ;)

Merci pour votre aide.

Hors ligne

#431 2017-02-01 18:58:08

Nadia_
Membre
Inscription : 2008-08-04

Re : [nouveau thème] Chestnut

Bonsoir,

Je suis allé tester par curiosité les commentaires sur ton blog, en mode prévisu et effectivement il y a bien un bug. J'utilise moi-même le thème Chesnut (en local pour l'instant) et ton message m'a interpellé, car j'ai également beaucoup retravaillé les templates.

Malgré cela, aucun bug de ce genre pour ma part. J'ai testé aussi le widget et il n'y a aucun bug non plus, les liens renvoient correctement au dernier commentaire de chaque billet.

Je sais que c'est une maigre aide que j'apporte là, mais tu es sans doute sur la bonne piste en pensant l'avoir un peu trop tripatouillé ?
Je pense que ton problème doit venir des fichiers .js du thème, ou à leur insertion dans les templates.

Dernière modification par Nadia_ (2017-02-01 19:02:22)

Hors ligne

#432 2017-02-02 07:55:12

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : [nouveau thème] Chestnut

Merci pour ta réponse Nadia_
Tu peux me dire quelle est la version JQuery que tu utilises ?

Hors ligne

#433 2017-02-03 07:58:59

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : [nouveau thème] Chestnut

J'y reviens.

J'ai testé toutes les versions de JQuery disponibles nativement via l'interface d'administration de Doctlear.

- Avec la version par défaut 1.4.2, tout fonctionne bien au niveau du retour à la page de visualisation des commentaires (prévisualisation et affichage après validation) ; MAIS LA BARRE DE PRESENTATION "article | Commentaire(s) | Annexe(s)" N'APPARAIT PAS CORRECTEMENT !
- Avec les versions 1.11.3 et 2.2.0, c'est l'inverse : retour du bug signalé auparavant au niveau de la prévisualisation des commentaires etc... mais la barre de présentation  "article | Commentaire(s) | Annexe(s)" apparait correctement.

Des idées ?
Merci.

Hors ligne

#434 2017-02-03 08:32:21

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : [nouveau thème] Chestnut

Petite info de plus ; dans la version de demo de dotaddict.org du thème Chestnut http://themes.dotaddict.org/demo-dc2/?theme=chestnut le retour automatique à "l'onglet commentaire(s)" n'est pas fonctionnel non plus en mode "prévisualisation" et "affichage après validation"... (j'en déduis que la version JQuery utilisée sur dotaddict est 1.11.3 ou 2.2.0)
Merci pour votre attention.

Dernière modification par bebr (2017-02-03 08:32:40)

Hors ligne

#435 2017-02-03 11:42:54

i_love_dc
Membre
Inscription : 2007-07-13

Re : [nouveau thème] Chestnut

Ca n'a sans doute aucuns rapport mais...voici ce que dit la page sur dotaddict

"query 1.4.2 n'est plus compatible avec le thème, merci de choisir la version 1.11.3 ou postérieure depuis les paramètres du blog afin de faire fonctionner le slide et les autres effets visuels du thème. La version minimale de php est 5.4."

Mais ce n'est peut être pas mis à jour ?


Sinon, dans ton "user-head.htm"vire le

<script type="text/javascript" src="{{tpl:BlogThemeURL}}/js/jquery-ui-1.11.4.js"></script>

essaye de le remplacer par

<script src="{{tpl:BlogQmarkURL}}pf={{tpl:BlogJsJQuery}}/jquery.js"></script>
<script type="text/javascript" src="{{tpl:BlogQmarkURL}}pf={{tpl:BlogJsJQuery}}/jquery.cookie.js"></script>

vide le cache etc..et re tente avec des versions plus "récentes" que propose dotclear (en prenant soin de bien vider le cache a chaques nouvelles opérations.)

Autres chose qui n'a "peut-etre pas de rapport direct" mais le plugin  "jQuery Cycle Plugin" embarqué dans ta version est actuellement la "Version: 2.94 (20-DEC-2010)" hors sur le site la dernière est la "Version: 3.0.3 (11-JUL-2013)"

Tout en sachant que jQuery Cycle Plugin est maintenant disponible en jQuery Cycle2 Plugin..

Mais je doute que la version 2 soit compatible (au point de vue insertion dans le code html des templates...mais cela reste à tester)

Voila, désolé de ne pas trouver de solution plus "ciblée"

Hors ligne

#436 2017-02-04 06:04:45

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : [nouveau thème] Chestnut

Merci pour tes quelques aiguillages, I_Love_DC.

i_love_dc a écrit :

Ca n'a sans doute aucuns rapport mais...voici ce que dit la page sur dotaddict

"query 1.4.2 n'est plus compatible avec le thème, merci de choisir la version 1.11.3 ou postérieure depuis les paramètres du blog afin de faire fonctionner le slide et les autres effets visuels du thème. La version minimale de php est 5.4."

Mais ce n'est peut être pas mis à jour ?

Vu. J'étais en déjà en 1.11.3, j'ai tenté 2.2.0, rien ne change niveau du bug : toujours un retour à "l'onglet article" après "prévisualisation" ou "validation" d'un commentaire au lieu de revenir à "l'onglet commentaires".

i_love_dc a écrit :

Sinon, dans ton "user-head.htm"vire le

<script type="text/javascript" src="{{tpl:BlogThemeURL}}/js/jquery-ui-1.11.4.js"></script>

essaye de le remplacer par

<script src="{{tpl:BlogQmarkURL}}pf={{tpl:BlogJsJQuery}}/jquery.js"></script>
<script type="text/javascript" src="{{tpl:BlogQmarkURL}}pf={{tpl:BlogJsJQuery}}/jquery.cookie.js"></script>

vide le cache etc..et re tente avec des versions plus "récentes" que propose dotclear (en prenant soin de bien vider le cache a chaques nouvelles opérations.)

Fait. Aucun changement. Note que les deux lignes de code :

<script src="{{tpl:BlogQmarkURL}}pf={{tpl:BlogJsJQuery}}/jquery.js"></script>
<script type="text/javascript" src="{{tpl:BlogQmarkURL}}pf={{tpl:BlogJsJQuery}}/jquery.cookie.js"></script>

sont déjà présente dans le template "_head.html", donc pas besoin de faire un doublon sachant qu'on y trouve aussi le code

{{tpl:include src="user_head.html"}}

D'autre part j'ai importé la version "JQuery-ui-1.8.10.custom.min.js" dans mon thème et l'ai appelé via le code

<script type="text/javascript" src="{{tpl:BlogThemeURL}}/js/jquery-ui-1.8.10.custom.min.js"></script>

en lieu et place de celui que tu me proposais de supprimer (version ui 1.11.4) car c'est une version qui fonctionne sur mon autre site internet avec Chestnut (avec JQuery 1.11.3 dans les paramètres du blog) http://omarlatuee.free.fr, mais malheureusement, caches vidés ça n'a rein changé ; toujours le bug...
J'ai d'ailleurs tout remis ce matin  à la normal comme le thème Chestnut de DotAddict. Viré la version ui 1.8.10 et remis la ui 1.11.4.

i_love_dc a écrit :

Autres chose qui n'a "peut-etre pas de rapport direct" mais le plugin  "jQuery Cycle Plugin" embarqué dans ta version est actuellement la "Version: 2.94 (20-DEC-2010)" hors sur le site la dernière est la "Version: 3.0.3 (11-JUL-2013)"
Tout en sachant que jQuery Cycle Plugin est maintenant disponible en jQuery Cycle2 Plugin..
Mais je doute que la version 2 soit compatible (au point de vue insertion dans le code html des templates...mais cela reste à tester)

Là c'est du lourd pour moi ! Mais je vais voir ça durant le Week-end et je te dirai ce qu'il en est...

i_love_dc a écrit :

Voila, désolé de ne pas trouver de solution plus "ciblée"

Merci beaucoup. Tes infos m'ont déjà aidé à étudier quelques solutions ; c'est déjà énorme !

Hors ligne

#437 2017-02-04 07:19:12

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : [nouveau thème] Chestnut

i_love_dc a écrit :

(...) le plugin  "jQuery Cycle Plugin" embarqué dans ta version est actuellement la "Version: 2.94 (20-DEC-2010)" hors sur le site la dernière est la "Version: 3.0.3 (11-JUL-2013)"
Tout en sachant que jQuery Cycle Plugin est maintenant disponible en jQuery Cycle2 Plugin..

C'est aussi la version 2.94 qui est embarquée sur mon autre site http://omarlatuee.free.fr où tout fonctionne bien... Donc j'en déduis que ça ne vient pas de là non plus (ou je me trompe ?)

J'ai testé aussi avec ma version de JS "post.js" sur mon site qui fonctionne en l'embarquant sur "SophiaTT", mais ça ne change rien non plus.

Je sèche désormais. Et on ne pourra pas me reprocher de ne pas avoir cherché !
Puisse la pluie prévue pour ce nouveau week-end, m'apporter d'autres idées... ;)

Hors ligne

#438 2017-10-30 23:02:11

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : [nouveau thème] Chestnut

màj chez moi qui fonctionne impec avec dc2.12 et jquery par défaut de cette version.

En ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map