Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2013-08-18 03:33:36

cubytus
Membre
Inscription : 2013-08-13
Site Web

Aspect incorrect du thème Design Pile

Bonsoir à tous,

Pour agrémenter l'aspect de mon blog (en construction, donc invisible pour le moment), j'ai choisi le thème designPile, mais hélas il n'apparaît pas comme sur la démo.

À quoi est-ce dû? Je me doute que ça se corrige probablement aisément pour qui connaît quoi changer, mais ce n'est pas mon cas..

[img=Pb d'affichage]http://image.bayimg.com/5f9c0c7771af6b2e5adaf8f7ab00827a56904873.jpg[/img]

Hors ligne

#2 2013-08-18 06:44:01

Jean-Michel
Modérateur à ailes d'ange
Lieu : Paris
Inscription : 2006-08-22
Site Web

Re : Aspect incorrect du thème Design Pile

Bonsoir,

Le mieux serait quand même d'avoir une URL afin de le passer au Firebug. Là, avec une simple capture d'ecran, c'est un peu compliqué.

On peut simplement te conseiller de vérifier que le code de tes billets soient valide (balise fermé par exemple) et/ou de voir avec un thème comme BlowUp si le même soucis se présente.

Hors ligne

#3 2013-08-18 09:09:02

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : Aspect incorrect du thème Design Pile

Bonjour,

Apparemment, il y a des bugs si tu utilises conjointement le plugin PictureShow.

Hors ligne

#4 2013-08-20 22:54:05

cubytus
Membre
Inscription : 2013-08-13
Site Web

Re : Aspect incorrect du thème Design Pile

Bonjour à vous deux,

le plugin PictureShow ne semble pas activé, ni même installé. Avec le thème par défaut Blowup, il n'y a aucun problème d'arrière-plan. J'hésite tout de même à montrer le blog dans son état non fini, tout de même...

Hors ligne

#5 2013-08-21 05:38:52

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Aspect incorrect du thème Design Pile

cubytus a écrit :

J'hésite tout de même à montrer le blog dans son état non fini, tout de même...

C'est pourtant le moyen le plus simple pour obtenir de l'aide. Une image ne permet pas de comprendre les causes d'un dysfonctionnement car on ne peut voir le code source de la page

Nous ne sommes pas là pour juger ton site, mais simplement pour t'aider à le faire marcher. Tu peux poster ici un lien vers la page en ligne, puis le retirer quand le problème sera résolu ;)

Hors ligne

#6 2013-08-21 08:15:22

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : Aspect incorrect du thème Design Pile

cubytus a écrit :

J'hésite tout de même à montrer le blog dans son état non fini, tout de même...

Tu postes sur un forum technique... C'est un peu comme si tu décrivais le pb de ta voiture sans amener le véhicule à ton garagiste : l'aide ne peut être efficace.

Hors ligne

#7 2013-08-21 16:25:30

cubytus
Membre
Inscription : 2013-08-13
Site Web

Re : Aspect incorrect du thème Design Pile

Bon, j'ai vérifié la conformité des feuilles CSS du thème, par acquis de conscience, et c'est valide. Firefox passe aussi le ACID3 test à 99% (je ne me souviens pas d'un aussi bon score avec les versions précédentes). Le blog est protégé par un simple mdp, destiné aux rédacteurs, qui est ZeSuperBlog à l'adresse https://websrv3.q-x.ch/~ftp83plu/dc/dotclear/index.php?. Je viens de me rendre compte aussi que les titres des têtes d'articles, vers le bas du thème, sont tout emmêlés.

Hors ligne

#8 2013-08-21 17:24:46

Jean-Michel
Modérateur à ailes d'ange
Lieu : Paris
Inscription : 2006-08-22
Site Web

Re : Aspect incorrect du thème Design Pile

Vérifier la conformité de ton contenu serait le bienvenue aussi ;)

Hors ligne

#9 2013-08-21 17:52:37

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : Aspect incorrect du thème Design Pile

C'est quoi cette url en https qui fait couiner firefox (pb de certificat) ?

Hors ligne

#10 2013-08-21 19:20:10

cubytus
Membre
Inscription : 2013-08-13
Site Web

Re : Aspect incorrect du thème Design Pile

Juste "accepter", et tout se passe bien. Quasiment tous les certificats d'hébergeurs mutualisés font ça.

Hors ligne

#11 2013-08-21 19:36:55

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : Aspect incorrect du thème Design Pile

Pourquoi ne pas utiliser une url normale sans zigouigoui ?

Hors ligne

#12 2013-08-21 20:22:51

cubytus
Membre
Inscription : 2013-08-13
Site Web

Re : Aspect incorrect du thème Design Pile

Ça ne répond pas tellement à la question de l'aspect, ça :(
Ni à comprendre pourquoi ça ne s'affiche pas bien.

Dernière modification par cubytus (2013-08-21 20:25:33)

Hors ligne

#13 2013-08-21 20:53:59

Jean-Michel
Modérateur à ailes d'ange
Lieu : Paris
Inscription : 2006-08-22
Site Web

Re : Aspect incorrect du thème Design Pile

Si je rajoute float:left; à #content dans style.css du thème ça fonctionne.

Hors ligne

#14 2013-08-21 22:10:50

cubytus
Membre
Inscription : 2013-08-13
Site Web

Re : Aspect incorrect du thème Design Pile

Parle-t-on bien de la section 5? J'ai:

#content {
	width:632px;
	min-height:500px;
	padding:25px 24px 35px;
	background:#fff;
  	float:left;/*edit*/
}

Et ça ne fonctionne toujours pas, la page d'entrée est tout emmêlée vers le bas.

Hors ligne

#15 2013-08-21 22:26:13

Jean-Michel
Modérateur à ailes d'ange
Lieu : Paris
Inscription : 2006-08-22
Site Web

Re : Aspect incorrect du thème Design Pile

C'est quoi section #5?

J'ai étais le testeur de ce thème avant sa publication donc normalement on devrait pas avoir ce genre de chose.

Peux-tu vérifier que le contenu de tous les billets de la home soient valide ?

Hors ligne

#16 2013-08-22 01:20:55

cubytus
Membre
Inscription : 2013-08-13
Site Web

Re : Aspect incorrect du thème Design Pile

Je ne suis pas certain de comprendre le but de la question. Quand je tape un billet, je le fais au format XHTML, que je trouve plus commode que le wiki (d'ailleurs j'aimerais que XHTML soit le format par défaut), et j'assume que DC fait le travail de mise en forme valide en arrière-plan, ce qui était d'ailleurs un des critères du choix d'un moteur de blog. Les rédacteurs rédigent, la machine vérifie que tout est techniquement conforme.

D'ailleurs, je viens de temporairement débloquer l'accès, et chose curieuse, la bande blanche d'arrière-plan de la page d'entrée descend bien jusqu'au dernier article. Par contre, les titres des articles en fin de page sont toujours emmêlés. On dirait qu'il ne faut pas dépasser trois lignes.

La section 5 du fichier style.css du thème, comme indiqué dedans.

Hors ligne

#17 2013-08-22 05:07:40

Jean-Michel
Modérateur à ailes d'ange
Lieu : Paris
Inscription : 2006-08-22
Site Web

Re : Aspect incorrect du thème Design Pile

Pour choisir ce format par defaut, tu vas dans Systeme > Utilisateurs > (utilisateur) > liste deroulante "format d'edition préféré".

Ce thème a été éprouvé sur mon blog de test (http://www.atelierdethemes.com/demo/blog/ - choisir "design pile").

Si je te demande de vérifier ce qui a été rajouter, c'est sans doute qu'une balise est mal fermée (contenu, widget) ou qu'un script n'est pas lu ou stoppé.

Hors ligne

#18 2013-08-22 06:36:45

cubytus
Membre
Inscription : 2013-08-13
Site Web

Re : Aspect incorrect du thème Design Pile

Réglé le problème du format de message.

Je n'ai pas touché au fichier style.css à part la balise que tu sembles ajouter dans la section 5, et ça s'affiche toujours mal. Rien n'a été rajouté à part ce petit bout de code, qui n'a rien changé sur l'affichage final. Il n'y a aucun widget à part celui de blog privé, le contenu est fait en XHTML ou wiki, je n'ai pas touché à la source, et il n'y a pas de script, á part ce qui est inclus d'origine dans DC.

En essayant de désactiver tous les billets, l'affichage est correct. En les réactivant un par un, l'affichage est toujours décalé pour ceux dont le titre est plus long, comme si les aperçus bloquaient à 3 lignes, au lieu de mettre, par exemple, des points de suspension.

Quoi d'autre?

Dernière modification par cubytus (2013-08-22 06:38:10)

Hors ligne

#19 2013-08-28 01:39:05

cubytus
Membre
Inscription : 2013-08-13
Site Web

Re : Aspect incorrect du thème Design Pile

On ne peut pas dire que ça croule sous les suggestions de dépannage. Suis-je le seul à utiliser ce thème?

Hors ligne

#20 2013-08-28 08:32:01

annso
Responsable de la machine à Twix
Lieu : Lyon
Inscription : 2006-03-05
Site Web

Re : Aspect incorrect du thème Design Pile

Hello,

C'est moi qui avait porté ce thème de WP à Dotclear il y a un certain nombre d'années; je viens en renfort.

As-tu résolu ton problème ? Chez moi, ton blog s'affiche correctement.

Hors ligne

#21 2013-08-28 08:35:00

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : Aspect incorrect du thème Design Pile

annso : les titres de plus de 3 lignes ne s'affichent pas bien et débordent sur le texte en page de liste.

Hors ligne

#22 2013-08-28 09:17:23

annso
Responsable de la machine à Twix
Lieu : Lyon
Inscription : 2006-03-05
Site Web

Re : Aspect incorrect du thème Design Pile

Ce problème n'est pas facilement corrigeable sans grandement modifier la structure du thème (ça doit être pour ça qu'il n'était pas géré sur le thème original).

En rajoutant la règle suivante, on corrige le décalage à droite, mais il reste toujours le problème de la hauteur des blocs...

.home-post h2 {
   padding-left: 63px;
}

Une solution (pas très satisfaisante) serait donc de limiter la taille des titres :

.home-post h2 {
   height: 42px;
   overflow: hidden;
   text-overflow: ellipsis;
   -o-text-overflow: ellipsis;
   -moz-binding: url('assets/xml/ellipsis.xml#ellipsis');
}

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map