Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2015-08-30 20:59:50

AtomicShrimp
Membre
Inscription : 2015-01-02

XHTML Editor not working after 2.8 upgrade

I've just upgraded to 2.8 on my blog - most things seem to be OK, except that the XHTML format option doesn't seem to work in the editor

It's been a while since I set up Dotclear, so I don't remember whether the XHTML option was a feature of the main editor or a plugin (I see I have dcACEEditor, dcCKEditor and dcLegacEditor installed).

When I try to edit or create an XHTML entry, I get blank spaces below the Excerpt and Content headings - no box displaying the entered content.
If I use Wiki format, it seems to work OK (but none of my entries were created in wiki markup and I don't know it well enough)

Hors ligne

#2 2015-08-30 21:17:43

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : XHTML Editor not working after 2.8 upgrade

J'aurai mieux fait d'être attentif au lycée...

Dernière modification par pierrevg (2015-08-31 10:18:56)

Hors ligne

#3 2015-08-30 21:30:40

AtomicShrimp
Membre
Inscription : 2015-01-02

Re : XHTML Editor not working after 2.8 upgrade

OK... my browser (Chrome) supports HTML5...  I don't really understand what you mean - What do I have to do?

Dernière modification par AtomicShrimp (2015-08-30 21:31:29)

Hors ligne

#4 2015-08-30 22:19:03

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : XHTML Editor not working after 2.8 upgrade

Voire de ne pas écrire sur cette partie du forum...

Dernière modification par pierrevg (2015-08-31 10:19:19)

Hors ligne

#5 2015-08-31 07:13:09

Dsls
Modérateur couteau-suisse
Inscription : 2004-11-18
Site Web

Re : XHTML Editor not working after 2.8 upgrade

Hello,

You may select which editor you want to use through "my preferences" in your admin. Then go to the "my options" tab. You can then select which editor you want for "xhtml". If none has been selected, you may then have no editor at all by default.

Also, make sure that your "DC_ADMIN_URL" option is correctly set in your inc/config.php file. otherwise, you may have trouble getting the CKEditor work properly.


Dyslexics have more fnu!

Hors ligne

#6 2015-08-31 10:20:34

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : XHTML Editor not working after 2.8 upgrade

In inc/config.php :

// Admin URL. You need to set it for some features.
define('DC_ADMIN_URL','http://exemple.com/dotclear/admin/');

Hors ligne

#7 2015-08-31 10:21:33

AtomicShrimp
Membre
Inscription : 2015-01-02

Re : XHTML Editor not working after 2.8 upgrade

Thanks Dsis and pierrevg - it was the config.php setting - I have three domain names pointing at the same resource - the main one is atomicshrimp.com, but the config.php setting still referenced one of the other domain names (which I was using during migration of my content to Dotclear).

Dernière modification par AtomicShrimp (2015-08-31 10:22:12)

Hors ligne

#8 2015-11-04 21:32:47

AtomicShrimp
Membre
Inscription : 2015-01-02

Re : XHTML Editor not working after 2.8 upgrade

I just noticed that since the changes discussed above, one of the things that has changed is that the XHTML source of my pages is not preserving its formatting/whitespace.

I create an article, save it, and when I go back to view source, it's all compressed into a single continuous block of source.  It still works, obviously, but it's very hard to amend in the code.

Is there a setting somewhere for this?

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map