Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2016-08-14 06:18:55

ben_griffith
Membre
Lieu : Wiltshire
Inscription : 2009-09-28

DC2.10 issues

After updating my testblog, I noticed an issue with Breadcrumb (smashed home and post.html, everything else was fine). Believing it's my new theme what I'm doing, I copied the same theme into my existing blog DC2.9.1., however it works fine there. Then I created a new admin install, like a new user who wants to test DC2.10, but the frontend looks like HTML without any css.

What I did:
- checked the blog news by Franck about changes. No changes to folder permissions as far as I can see.
- created new database
- uploaded DC2.10
- Gave permissions for Cache/Public (777) and admin/install (755).
- called domain/admin/install -> worked fine
- I can see the the blog with default theme, works fine
- I log in into admin and get a page without any css (Firefox/Seamonkey).

Do you have similar issues?

Many thanks in advance.

Dernière modification par ben_griffith (2016-08-14 06:28:15)


I Dotclear.

Hors ligne

#2 2016-08-14 06:27:50

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : DC2.10 issues

May be a browser cache issue. Try to empty it and test again


Dotclear addicted since 2004

Hors ligne

#3 2016-08-14 07:28:50

ben_griffith
Membre
Lieu : Wiltshire
Inscription : 2009-09-28

Re : DC2.10 issues

Hi Franck
No, my Firefox never sees any other webpage then my testblog. The new installation has never been there before. And to make it worse, I can't deny the bad feeling that the issues with my server has to do with the new DC version.
Everything was working fine this morning. Then I updated my testblog, I closed the browser, restarted the browser and logged into the testblog. Immediately after, my server went down.
My provider is marvellous guy who works 24/7. He turned on the server twice in between.
I installed DC2.10 as a new installation, but as soon as I'm in the new installation frontend, the server goes down again.
Maybe coincidence, but I don't feel comfortable at the moment. I will take off the new and the test blog as soon as the server works again. I will ask Ricky, so his name, if I'm the culprit.


I Dotclear.

Hors ligne

#4 2016-08-14 08:06:02

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : DC2.10 issues

Hi Ben,

I did the same test and you're right, there is a problem, on new installation, about the new Content-Security-Policy system.

To disable it, as you should have only text (not css), you can go to the about:config page, then look for the first "csp_admin_on" and switch it to "no", then save.

You should have full CSS'ed admin after that.


Dotclear addicted since 2004

Hors ligne

#5 2016-08-14 08:20:34

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : DC2.10 issues

You can also download a 2.9.1, here https://download.dotclear.org/attic/ and then upgrade it, it will work (I just test it).


Dotclear addicted since 2004

Hors ligne

#6 2016-08-14 10:45:18

ben_griffith
Membre
Lieu : Wiltshire
Inscription : 2009-09-28

Re : DC2.10 issues

Hi Franck, thanks for the link, but I have to sort out why the server down issue came.

My provider wrote back:
It looks like your site or something you were doing was causing you to have hundreds of connections open to the server, so our firewall was blocking you.
It hasn't caused issues for anyone else on the server. I've made a tweak so this shouldn't happen as easily.

I'm not a expert for things that, but let me say that we had 2 weeks ago a hardware failure and my provider had to change the server hardware. He rolled back the backup, but I have to use a different FTP connection now. Before, I had in FileZilla "Explicit FTP over TLS if available" and since the hardware change I have to use "Plain FTP (unsecure)".

[UPDATE]: The FTP connection change is solved and I'm back to the old setting. I'm now going to install DC2.9.1 until further.

Dernière modification par ben_griffith (2016-08-14 13:55:46)


I Dotclear.

Hors ligne

#7 2016-08-15 08:17:51

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : DC2.10 issues

The 2.10.1 has been released and should fix your problem (with a new installation).

Have you any detail about your server issue ?


Dotclear addicted since 2004

Hors ligne

#8 2016-08-16 04:42:20

ben_griffith
Membre
Lieu : Wiltshire
Inscription : 2009-09-28

Re : DC2.10 issues

I'm currently building up again my testblog. I will give it a try until Friday morning, Franck.


I Dotclear.

Hors ligne

#9 2016-08-17 04:44:34

ben_griffith
Membre
Lieu : Wiltshire
Inscription : 2009-09-28

Re : DC2.10 issues

Hi Franck, 2.10.1 fixed all issues. Can't complain works fine now :-)


I Dotclear.

Hors ligne

#10 2016-08-17 05:37:32

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : DC2.10 issues

ben_griffith a écrit :

Hi Franck, 2.10.1 fixed all issues. Can't complain works fine now :-)

\o/ Nice to read that !


Dotclear addicted since 2004

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map