Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2016-10-21 15:56:37

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

dcCKEditor not running with https

Hi

I changed the setup of my webhosting - the dotClear blog is running now under HTTPS.

But after now the internal dcCKEditor doesn't work. The editor window is empty  - no buttons are shown and no input is possible.

Any help?

Thanks.


Salutations / best regards
Tin

Hors ligne

#2 2016-10-21 17:15:15

Jean-Michel
Modérateur à ailes d'ange
Lieu : Paris
Inscription : 2006-08-22
Site Web

Re : dcCKEditor not running with https

Hi',

I think is that : https://fr.dotclear.org/blog/post/2015/ … r-en-panne. Could you check that these lines are there?

Hors ligne

#3 2016-10-21 17:16:33

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : dcCKEditor not running with https

Hi,

Have you update your DC_ADMIN_URL (in inc/config.php) according to your switch, as I suppose that your admin is now also under HTTPS ?


Dotclear addicted since 2004

Hors ligne

#4 2016-10-21 17:52:44

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : dcCKEditor not running with https

Hi

Yes! You are right- I missed to change DC_ADMIN_URL to https - now editor is displayed.

The only issue: The editor tries to load the "editor.css" from the theme folder - this link isn't changed to https - it is still "http://domain.tld/themes/berlin/editor.css"

So where to change this?

Thanks.


Salutations / best regards
Tin

Hors ligne

#5 2016-10-21 19:43:07

Jean-Michel
Modérateur à ailes d'ange
Lieu : Paris
Inscription : 2006-08-22
Site Web

Re : dcCKEditor not running with https

Must be checked these values themes_path et themes_url in the page about:config. It's in French but Franck's post explained very well.

Hors ligne

#6 2016-10-23 07:48:22

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : dcCKEditor not running with https

Jean-Michel a écrit :

Must be checked these values themes_path et themes_url in the page about:config.

Ok, checked an changed these values to https. But CKEditor calls editor.css still with http instead of https - like "http://domain.tld/themes/berlin/editor.css" . Seems I missed a config option for CKEditor?


Salutations / best regards
Tin

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map