Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2017-01-07 09:54:05

grix
Membre
Inscription : 2017-01-07

Problems with references after changing the Blog URL

Hi all

I am using Dotclear for over a year now and I like it pretty much.

Now I have changed my base URL
from
http://domain1.tld/blog/index.php
to
http://blog.domain2.tld/index.php


Doing so I have come across two problems:

1. Within the blog all of the references still include the former /blog subdirectory. I.e. the references within the blog are now reading
http://blog.domain2.tld/blog/index.php/....

One can work around this by defining an Alias for /blog in the Apache site configuration. But of course it would be nice to get this corrected.

2. The bigger problem are all the picture galleries I have inserted with the plugin GalleryInsert. All of its' references are still pointing to the former URL http://domain1.tld/blog/... with an absolute path including the old host name. So these references will fail.

Is there a way to correct all these references within the blog?

Regards,

grix

Dernière modification par grix (2017-01-07 09:55:21)

Hors ligne

#2 2017-01-08 03:33:10

ben_griffith
Membre
Lieu : Wiltshire
Inscription : 2009-09-28

Re : Problems with references after changing the Blog URL

Hello grix

Can you see a general pattern in your case?

I recently changed the path for all of my images from "http://domain.com/photos/year/date/jpg" to "/photos/year/date/jpg".

1. I saved the backup file
2. I opened my txt file in Scite
3. changed the path using Replace (took me a couple of times as I had used different methods over the last 8 years)
4. Imported my new file into a test blog (worked fine)
5. Created a new main blog with same name and imported my changed file.

Dernière modification par ben_griffith (2017-01-08 03:34:26)


I Dotclear.

Hors ligne

#3 2017-01-08 13:49:42

grix
Membre
Inscription : 2017-01-07

Re : Problems with references after changing the Blog URL

Hello Ben

Cool, I wasn't aware of the possibility to export the whole blog as a single flat text file. It looks like I can work with this. I just need to set up a second blog first to try it.

I'll keep you posted.

Thanks and regards,
grix

Hors ligne

#4 2017-01-09 04:10:00

ben_griffith
Membre
Lieu : Wiltshire
Inscription : 2009-09-28

Re : Problems with references after changing the Blog URL

Hello grix

I also save my blog at least once a week or months. That little txt file allows you to restore your blog at any time in case your provider goes suddenly offline and you need a new provider.


I Dotclear.

Hors ligne

#5 2017-01-15 15:32:49

grix
Membre
Inscription : 2017-01-07

Re : Problems with references after changing the Blog URL

Well, finally I had some time to fix this. I have successfully moved my blog completely and even new posts and galleries get correct URLs. So far so good.

I have not found a way to make a blog completely appear under http://blog.domain.tld/index.php/ instead of http://blog.domain.tld/blog/index.php/ though. Dotclear really seem to rely on this additional subdirectory. At least if we are dealing with more than blog within one Dotclear installation. I tried different solutions and even manually edited themes_path and public_path accordingly. But then the plugin GalleryInsert will still insert the additional subdirectory into the picture URLs. So I think I am going to live with it.

Thanks Ben for pointing me into the right direction.

grix

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map