Dotclear

Vous n'êtes pas identifié(e).

Annonce

#26 2018-08-21 11:40:53

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Test Mrvb Derniers billets: erreur  trouvée ? (php 5 et 7)

--
Billets sélectionnés uniquement: coché
Filtre: post, page, related
catégories à exclure 1
ou
catégories à exclure test
ou
catégories à exclure 1, test
Liste des billets OK

    page related 2
    page related php
    page connexe test sans mdp
    page test 2 non affichée widget position 2 sans mdp
    Welcome cat welcome
    test avec catégorie créée catégorie nouvelle

mais....
si dans catégories à exclure je termine par une virgule ou met une virgule suivie d'un espace

1, test,
OU
1, , test

la liste est limitée

    Welcome cat welcome
    test avec catégorie créée catégorie nouvelle

En fait :
un print_r($exclude) révèle une valeur vide
Cas virgule à la fin

    [0] => 1
    [1] =>

cas virgule espace au milieu

    [0] => 1
    [1] => 
    [2] => test

confirmée par test dans une fonction à moi

		foreach($vars as $key => $value) {
			echo '$value: "' .$value .'"  is empty?';
			echo empty($value) ?'YES' :'NO';
			echo '<br>';
		}

qui donne

$value: "1" is empty?NO
$value: "" is empty?YES
$value: "test" is empty?NO

Le problème étant que la méthode mrvb_ListToArray ne traite pas pas les valeurs vide d'un array, mais seulement les array vides
Il faudrait donc, amaha, trouver une solution pour ne pas stocker dans $tab une ligne avec une valeur vide.
En gros, le résultat de cette méthode devrait être :

    [0] => 1
    [1] => test

vais creuser car il faudrait pouvoir supprimer toute valeur vide...
EDIT
Ton widget mots clés ne semble pas poser ce type de problème: c'est donc dans la partie qui traite les billets(post) qu'il faudrait regarder ?
Par ailleurs,
La génération de mots clés dans un billet dotclear ne présente pas ce problème.

Dernière modification par nanart (2018-08-21 12:11:54)


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#27 2018-08-21 13:14:36

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Premier essai :
méthode mrvb_ListToArray
remplacement ligne 24

	if (strip_tags(trim($tab[$i])) != false) { $tab[$i] = strip_tags(trim($tab[$i])); }

La liste des billets (et des mots clés) semble ok.

note: on peut aussi passer par une variable intermédiaire (plus clair), par ex:

	$tag = strip_tags(trim($tab[$i]));
	if ($tag != false) { $tab[$i] = $tag; }

Référence php

Lors d'une conversion en booléen, les valeurs suivantes sont considérées comme FALSE :
    le booléen FALSE, lui-même
    l'entier 0 (zéro)
    le nombre à virgule flottante 0.0 (zéro)
    la chaîne vide, et la chaîne "0"
    un tableau avec aucun élément
    le type spécial NULL (incluant les variables non définies)
    les objets SimpleXML créés depuis des balises vides


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#28 2018-08-21 18:44:01

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Anecdotes --> comme sous le widget derniers billets de Dotclear:
- un billet avec mdp n'est pas affiché
- le filtre mot clé = XXX, élimine les autres types de post auxquels on ne peut associer un mot clé, ce même si  type= post, page, related
le widget DC n'affichant que les billets -(post)

Dernière modification par nanart (2018-08-21 18:47:05)


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#29 2018-08-22 04:51:53

Mirovinben
M comme Mathusalem
Lieu : Dole (Jura)
Inscription : 2007-02-06
Site Web

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Heu... J'avoue que je commence à être largué. Je vais devoir regarder ça posément.

Hors ligne

#30 2018-08-22 14:07:52

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

A propos du rendu du widget liste des billets, quand on entre un mot clé, alors la liste des pages et related n'est plus affichée.
Je m'attendais cependant à avoir la liste des pages et related.
Après réflexion, il me semble que c'est un comportement "normal" puisque page et related ne peuvent avoir de mots clés.
Il en va de même pour ce qui concerne les catégories.

Plusieurs solutions apparaissent :
- soit tu laisses comme ça, mais amha il faudrait que l'utilisateur puisse comprendre que même s'il désire avoir la liste, par exemple, des pages, s'il entre un mot clé, les pages n'apparaitront pas dans la liste.
- soit tu traites les autres types de post, après la recherche AVEC mot clé; par un else if, par exemple.
Ce qui donnerait une liste des billets avec le mot clé recherché + la liste des pages
+ même traitement pour ce qui concerne une recherche avec catégorie

Mon avis serait de laisser tel que, sachant qu'il y a aussi un widget pages
mais pour la compréhension par l'utilisateur, le widget devrait s'organiser avec un chapeau de type :
Rechercher uniquement les billets
ayant cette catégorie
ayant ce mot clé
Catégorie à exclure ne posant pas ce type de pb.

Pour rappel et ex: analyse sommaire de ton code / mot clé : fonction public static function mrvb_LastPosts($w) ligne: 228

		#SI tag
		if ($w->tag){
			$params['meta_id'] = $w->tag;
			#liste les posts ayant ce mot clé (donc NI page NI related
			$rs = $core->meta->getPostsByMeta($params);
		#PAS de TAG
		} else {
			#liste les posts avec catégorie ET type
			$rs = $core->blog->getPosts($params);
		}
		#si rien dans la liste QUITTE
		if ($rs->isEmpty()) {
			return;
		}

Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#31 2018-08-23 05:06:08

Mirovinben
M comme Mathusalem
Lieu : Dole (Jura)
Inscription : 2007-02-06
Site Web

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Je pense qu'il serait préférable de revenir à ma demande du début : tester mes plugins sous PHP7 (et de ne proposer d'éventuelles évolutions de leurs fonctionnalités que plus tard ou dans un fil de discussion dédié).

Pour la petite histoire, je n'ai pas souhaité étendre aux pages et pages statiques la liste obtenue en utilisant mrvbLastPosts, pour rester en harmonie avec ce que propose le widget "équivalent" fourni par Dotclear. D'autant que mrvbPages fait le job et que le plugin related propose un widget équivalent ("pages connexes").

D'autre part il me paraît difficile de vérifier toutes les erreurs de saisie possibles dans une liste traitée par mrvb_ListToArray et je préfère laisser aux administrateurs la responsabilité de construire un filtre efficace et de demander de l'aide sur le forum s'ils rencontrent un pb. Jusqu'à présent cela a plutôt bien fonctionné.

Quoiqu'il en soit, je te remercie dès à présent du boulot accompli.
- détection d'un bug dans mrvbToC,
- validation de bon fonctionnement de mrvbToC sous PHP7,
- meilleure prise en compte dans les widgets de mrvbCustomWidgets de la présence d'un éditeur "externe" pour les champs de type "textarea".
Ce n'est pas rien.

Hors ligne

#32 2018-08-23 12:20:47

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Ok, je continue dans le test de ces widgets sous php 7.
Cependant, si je me heurte à un problème du type erreur de saisie
(ex: une virgule finale dans 'catégories à exclure' du widget Mrvb Derniers billets),
je te la signalerais pour info  si je trouve une solution simple.
(ex: modif de la méthode mrvb_ListToArray),


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#33 2018-08-24 06:44:24

Mirovinben
M comme Mathusalem
Lieu : Dole (Jura)
Inscription : 2007-02-06
Site Web

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Ok...

Je n'arrive pas à reproduire le défaut signalé en #26. sans doute à cause de ma configuration locale. Ce qui explique mon peu d'envie de trop toucher à la fonction "mrvb_ListToArray".

Peux-tu refaire des tests notamment avec mrvbLastPosts en remplaçant mrvb_ListToArray par cette nouvelle version ?

function mrvb_ListToArray($list)
{
	$tmp = str_replace("\n",',',$list);
	$tmp = str_replace("\r",',',$tmp);
	while (strpos($tmp,',,') !== false) {
		$tmp = str_replace(',,',',',$tmp);
	}
	if (!empty($tmp)) {
		$t = explode(',',$tmp);
		$tab = array();
		$j = 0;
		for ($i = 0 ; $i < count($t) ; $i++) {
			$t[$i] = strip_tags(trim($t[$i]));
			if (strlen($t[$i]) > 0){
				$tab[$j] = $t[$i];
				++$j;
			}
		}
	} else {
		$tab = array();
	}
	return $tab;
}

Attention : dans la liste des catégories à exclure, il ne doit y avoir que des nombres (les ID des catégories).

Si tu utilises un éditeur pour les textarea, il serait bien de vérifier le code source. Je pense notamment à &nbsp; (espace insécable) pouvant remplacer un espace "normal".

Merci d'avance.

Dernière modification par Mirovinben (2018-08-24 07:15:40)

Hors ligne

#34 2018-08-25 12:20:49

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Essai avec ton code, éditeur sur textarea
1) ok avec des virgules
entré: "1, ,2,"
résultat: les cat 1 et 2 sont bien exclues; pas de problème avec les virgules "parasites"

Notes:
[EDIT]
En effet, si on met deux espaces, une des 2 est traduite par &nbsp;

  0 => string '1' (length=1)
  1 => string '&nbsp;' (length=6)
  2 => string '2' (length=1)

Mébon, le résultat semble être le même qu'entrer du texte dans catégorie à exclure -> ne semble pas poser problème (l'ID 'xxx' ou '&nbsp;' n'existant pas)
[/EDIT]

2) j'ai testé avec des retours de ligne dans les textarea avec les deux éditeurs Dc
Je rame un peu avec DcLegacyEditor, car, de temps en temps, je me retrouve avec des balise <br /> que la fonction php str_replace ne semble pas gérer correctement.


Pour résumer:
Le problème des virgules "parasites" me semble traité.
Par contre avec un textarea + éditeur il faut que je teste plus en avant la séparation des mots par sauts de ligne...
(à la main avec un retour chariot et par clic sur 'retour à la ligne')

Dernière modification par nanart (2018-08-25 18:40:03)


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#35 2018-08-26 05:38:00

Mirovinben
M comme Mathusalem
Lieu : Dole (Jura)
Inscription : 2007-02-06
Site Web

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Merci pour ces infos.

Je note que les pb rencontrés sont liés à l'utilisation d'éditeurs pour les textarea. Je conseille donc, soit de passer par le mode source si l'éditeur le propose, soit de décocher la case kivabien dans les paramètres utilisateur

"Admin" - "Mes préférences" - "Mes options" - "Utiliser l'éditeur xhtml pour :" - décocher "Les zones de texte multilignes des widgets".

Je peux donc valider pour l'instant la nouvelle version de la fonction "mrvb_ListToArray" (cf message #33)...

Hors ligne

#36 2018-08-26 08:20:51

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Ok, je continue les vérifications.

Pour ce qui concerne l'éditeur xhtml, il faudrait peut être contacter Franck Paul pour savoir si ce qui est fait dans préférences (désactiver éditeur xhtml pour les widgets) ne peut ou pourrait pas être réalisé dans le code d'un plugin (ou widget).


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#37 2018-08-26 09:46:29

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Question :

Si, pour tes textarea qui posent problème, tu pouvais demander à ce qu'aucun éditeur ne soit actif sur ceux-ci, ça irait ?

En gros, au lieu de définir le setting en question du widget, pour l'instant ressemblant à :

$__widgets->text->setting('text', __('Text:'), '', 'textarea');

Il suffirait de mettre :

$__widgets->text->setting('text', __('Text:'), '', 'textarea', array('class' => 'noeditor'));

Si oui je valide les modifs que je viens de tester et ça sera dans la prochaine 2.15

Ça permettra pour chaque textarea de widget, de définir s'il est souhaitable d'avoir un éditeur HTML (si l'option est active dans les préférences), ou pas.


Dotclear addicted since 2004

Hors ligne

#38 2018-08-26 15:07:25

Mirovinben
M comme Mathusalem
Lieu : Dole (Jura)
Inscription : 2007-02-06
Site Web

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Perso, ça m'irait très bien... À condition que cette modification du setting ne rende pas un widget qui l'utilise incompatible avec les versions antérieures à Dotclear 2.15.

En d'autres termes que la présence de

array('class' => 'noeditor')

ne génère pas d'erreur avec un dotclear 2.14, 2.13, etc...

Hors ligne

#39 2018-08-26 15:22:26

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

EDIT/suppression premières lignes
---
J'ai remarqué, que lorsqu'on pose un widget dans le volet de navigation un champ textarea est (par défaut?) sans éditeur.
Par contre, dès que l'on met à jour les volets, l'éditeur (activé dans préférences) entre en action.

J'ai testé cela avec le widget texte.
J'ai donc modifié _default_widgets.php, line 36 en

$__widgets->text->setting('text', __('Text:'), '', 'textarea', array('class' => 'noeditor') );

Pas vu de modif (tjrs éditeur, même après déconnexion) ni erreurs manifeste

EDIT/MODIF:
Sinon, cette modif (attendue sous Dc 2.15 ?) me parait intéressante.
L'ajout de  array('class' => 'noeditor') ne génère apparemment aucune erreur dans les codes testés (Dc 2.14)

Dernière modification par nanart (2018-08-26 15:42:43)


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#40 2018-08-26 16:16:57

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Mirovinben a écrit :

Perso, ça m'irait très bien... À condition que cette modification du setting ne rende pas un widget qui l'utilise incompatible avec les versions antérieures à Dotclear 2.15.

En d'autres termes que la présence de

array('class' => 'noeditor')

ne génère pas d'erreur avec un dotclear 2.14, 2.13, etc...

Bah tu peux aussi définir que ton plugin nécessite a minima la 2.15, je fais ça souvent quand j'utilise des nouvelles fonctionnalités qui n'existent pas dans les versions précédentes.

Cela dit, vu le code, ça ne devrait pas poser problème.

Au delà de ça, je vois mal comment un setting enregistré avec une 2.15 pourrait poser problème avec une version précédente !


Dotclear addicted since 2004

Hors ligne

#41 2018-08-26 16:35:30

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Test avec DC 2.8 :
pas totalement compatible php 7 -> test sous php 5.6
Pas de possibilité d'activer éditeur pour widgets, etc.

ajout , array('class' => 'noeditor') line 346 widget mrvbText : Aucune erreur apparente décelée
ajout , array('class' => 'noeditor') line 128 widget mrvbLastPosts : Aucune erreur apparente décelée


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#42 2018-08-26 17:12:45

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

nanart a écrit :

J'ai remarqué, que lorsqu'on pose un widget dans le volet de navigation un champ textarea est (par défaut?) sans éditeur.
Par contre, dès que l'on met à jour les volets, l'éditeur (activé dans préférences) entre en action.

J'ai corrigé ça (pour la 2.15 à venir), si dcLegacyEditor est l'éditeur HTML utilisé, si c'est CKEditor c'est largement plus complexe (on verra si c'est absolument nécessaire)


Dotclear addicted since 2004

Hors ligne

#43 2018-08-26 17:32:28

Mirovinben
M comme Mathusalem
Lieu : Dole (Jura)
Inscription : 2007-02-06
Site Web

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Franck a écrit :

Bah tu peux aussi définir que ton plugin nécessite a minima la 2.15, je fais ça souvent quand j'utilise des nouvelles fonctionnalités qui n'existent pas dans les versions précédentes.

Ok. j'avais oublié ça.

Franck a écrit :

Cela dit, vu le code, ça ne devrait pas poser problème.

C'est ce que j'ai cru comprendre suite aux essais de nanart.

Franck a écrit :

Au delà de ça, je vois mal comment un setting enregistré avec une 2.15 pourrait poser problème avec une version précédente !

Je ne comprends pas ta remarque.

Hors ligne

#44 2018-08-26 17:37:53

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Test avec 2.10.4
pas totalement compatible php 7.2.9 -> test sous php 7.1.9
Pas de possibilité d'activer éditeur pour widgets, etc. => apparemment activé d'office
ajout, array('class' => 'noeditor') à toute ligne 'textarea'
widget mrvbText & widget mrvbLastPosts : Aucune erreur apparente décelée


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#45 2018-08-26 17:49:03

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

EDIT, réponse supprimée car non exacte ;-)

Dernière modification par nanart (2018-08-26 18:02:08)


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#46 2018-08-27 06:00:54

Mirovinben
M comme Mathusalem
Lieu : Dole (Jura)
Inscription : 2007-02-06
Site Web

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Je viens de modifier en local les setting concernant les textarea de certains widgets. Je confirme l'absence de warning avec Dotclear 2.13 sous PHP 5.5 alors que cette version de Dotclear n'a pas la capacité de prendre en compte l'ajout proposé par Franck dans la future 2.15.

Remarque : selon moi, deux widgets ne sont pas concerné par l'ajout de "array('class' => 'noeditor')" dans

$__widgets->text->setting('text', __('Text:'), '', 'textarea', array('class' => 'noeditor'));

Au contraire, ils ont tout intérêt à bénéficier de la présence d'un éditeur html.

il s'agit de
- mrvbLastPosts
- mrvbText

Ce sont les seuls à proposer un textarea qui ne soit pas utilisé pour établir une liste de catégories ou de mots-clés à exclure mais pour insérer du code html.

[Edit 2018-08-27 12:47:48]
Erreur : il s'agit de mrvbFeed et non de mrvbLastPosts

Dernière modification par Mirovinben (2018-08-27 10:47:48)

Hors ligne

#47 2018-08-27 07:52:16

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Mirovinben a écrit :

Remarque : selon moi, deux widgets ne sont pas concerné par l'ajout de "array('class' => 'noeditor')" dans

$__widgets->text->setting('text', __('Text:'), '', 'textarea', array('class' => 'noeditor'));

Au contraire, ils ont tout intérêt à bénéficier de la présence d'un éditeur html.

il s'agit de
- mrvbLastPosts
- mrvbText

Ce sont les seuls à proposer un textarea qui ne soit pas utilisé pour établir une liste de catégories ou de mots-clés à exclure mais pour insérer du code html.

Pour ce qui concerne mrvbText, ok. J'ai fait des tests sur ce widget uniquement parce qu'il est le plus "simple" et afin de vérifier si un ajout de classe pour un textarea pouvait générer une erreur.

Quant à mrvbLastPosts que j'ai testé avec la modif class=..., sauf erreur de ma part "derniers billets",  je ne vois pas en quoi le textarea 'catégories à exclure (ID séparés par virgules ou sauts de ligne)' sert à "insérer du code html'.
Bien au contraire, je viens de tester avec le bouton d'insertion de saut de ligne - DcLegacyEditor, il semble que l'éditeur envoie un/des <br /> qui génère une erreur d'interprétation:

1<br />2<br />
ou
<p>1<br />2</p>
donne :

array (size=1)
  0 => string '12' (length=2)

Dernière modification par nanart (2018-08-27 08:36:00)


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#48 2018-08-27 07:59:55

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Merci Franck pour tes tickets :

  • * Allows textarea settings in widget without HTML editor, even if activated in user prefs.

  • * Activate dcLegacyEditor (if it is the HTML editor set in user pref) for new instances of widgets having textarea in settings. Doing same for CKEditor seems to be a little bit harder than that, may be completed in future…
    et

  • * Extends opts to each type of widget setting (only 'class' is taken into account up to now)

:cool:

Dernière modification par nanart (2018-08-27 08:08:29)


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#49 2018-08-27 08:25:51

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Proposition:
à ce stade des tests, je propose de faire un point.
Ce qui me permettra d'indiquer ce que j'ai testé - dont non encore indiqué ici, ce qu'on a vérifié et noté ou corrigé.
note: pause travaux persos en cours; Je reprends dans quelques heures...


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#50 2018-08-27 09:22:35

Mirovinben
M comme Mathusalem
Lieu : Dole (Jura)
Inscription : 2007-02-06
Site Web

Re : Cherche volontaires pour tester certains de mes plugins sous PHP7.x

Oups, je vérifie cet après-midi mais il semble en effet que je me sois trompé dans mon précédent message.

Ce n'est pas mrvbLastPosts mais mrvbFeed qui accepte volontiers du html dans le textarea "format des items".

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map