Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2020-04-01 05:54:54

hyperion66
Membre
Inscription : 2008-12-01
Site Web

Problème lightbox et Gallleryinsert

Bonjour,

Depuis la mise à jour lightbox, j'ai un souci sur www.matosvelo.fr.
D'une, je n'ai plus l'effet lightbox sur mes images, elles s'affichent sans aucun effet, obligeant à un retour arrière pour revenir sur l'article, mais en plus, ça empêche les galeries faites avec GalleryInsert v0.412 de s'afficher correctement. Une idée de comment régler le problème ?

Je suis revenu à lightbox 1.3.1, plus de souci.

Merci

Dernière modification par hyperion66 (2020-04-01 05:57:04)

Hors ligne

#2 2020-04-01 06:45:45

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Problème lightbox et Gallleryinsert

C'est difficile à diagnostiquer si ce n'est pas visible en ligne... Lorsque la nouvelle version de Lightbox est activée, quels sont les messages d'erreur dans la console du navigateur ?

Une piste probable serait l'incompatibilité du nouveau Lightbox avec ta version assez ancienne de jQuery (1.11.2)

Accessoirement, sur la version actuelle, je vois aussi une erreur javascript sur le widget de la newsletter. Pas sûr que ce soit le problème toutefois

Hors ligne

#3 2020-04-01 07:11:34

hyperion66
Membre
Inscription : 2008-12-01
Site Web

Re : Problème lightbox et Gallleryinsert

Bizarre, je charge pourtant dans les paramètres du blog la dernière version de jQuery.

Edit : Dans mon _head, j’appelle <script type="text/javascript" src="{{tpl:BlogThemeURL}}/js/jquery-1.11.2.min.js"></script> et si je le vire, ça casse tout le thème :-(

Dernière modification par hyperion66 (2020-04-01 07:15:50)

Hors ligne

#4 2020-04-01 07:35:53

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Problème lightbox et Gallleryinsert

hyperion66 a écrit :

Bizarre, je charge pourtant dans les paramètres du blog la dernière version de jQuery.

Cela ne marchera que si tu utilises cette version côté public. Or ton thème contient dans _head.html le code

<script type="text/javascript" src="{{tpl:BlogThemeURL}}/js/jquery-1.11.2.min.js"></script>

Ce qui signifie que ta version de jQuery est celle qui a été livrée avec le thème (voir BlogThemeURL).

Pour charger le jQuery fourni par dotclear il te faudrait avoir dans le head le code suivant (jusqu'à la version 2.15.x de dotclear)

<script type="text/javascript" src="{{tpl:BlogQmarkURL}}pf={{tpl:BlogJsJQuery}}/jquery.js"></script>

En revanche, tu ne pourras pas utiliser la dernière version, en effet ton thème est basé sur Bootstrap 3, dont le fichier bootstrap.min.js n'est pas compatible avec jQuery 3.x

Tu pourrais peut-être essayer avec une version 2.x ?

Dans tous les cas, il te faudra demander au concepteur de ton thème de le rendre compatible avec dotclear 2.16, qui embarque par défaut la version 3.4.1

Hors ligne

#5 2020-04-01 07:38:05

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : Problème lightbox et Gallleryinsert

Voilà à quoi devrait ressembler la partie du head qui s'occupe de charger les scripts, depuis la 2.16 :

<tpl:SysIf jquery_needed="1">
  <script src="{{tpl:BlogQmarkURL}}pf={{tpl:BlogJsJQuery}}/jquery.js"></script>
</tpl:SysIf>
<script src="{{tpl:BlogQmarkURL}}pf=util.js"></script>

Dotclear addicted since 2004

Hors ligne

#6 2020-04-01 07:40:50

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Problème lightbox et Gallleryinsert

Oui mais non, il est je crois en 2.15 et il faudra d'abord mettre le thème à jour

Hors ligne

#7 2020-04-01 07:45:37

Mathieu M.
Membre
Lieu : Rhône-Alpes
Inscription : 2009-09-14
Site Web

Re : Problème lightbox et Gallleryinsert

Hors ligne

#8 2020-04-01 07:58:50

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Problème lightbox et Gallleryinsert

@Mathieu M. : j'ai pour ma part modifié mes thèmes Bootstrap3 (grayscale par exemple) en n'intégrant que le fichier bootstrap.min.js de Bootstrap 4, mais j'ai conservé les CSS de Bootstrap 3 ;)

Hors ligne

#9 2020-04-01 08:05:35

hyperion66
Membre
Inscription : 2008-12-01
Site Web

Re : Problème lightbox et Gallleryinsert

Oui, Mathieu bosse dessus, je vais donc attendre !

Hors ligne

#10 2020-04-21 12:44:00

stvercez
Membre
Inscription : 2012-07-25

Re : Problème lightbox et Gallleryinsert

hyperion66 a écrit :

Bonjour,

Depuis la mise à jour lightbox, j'ai un souci sur www.matosvelo.fr.
D'une, je n'ai plus l'effet lightbox sur mes images, elles s'affichent sans aucun effet, obligeant à un retour arrière pour revenir sur l'article, mais en plus, ça empêche les galeries faites avec GalleryInsert v0.412 de s'afficher correctement. Une idée de comment régler le problème ?

Je suis revenu à lightbox 1.3.1, plus de souci.

Merci

Bonjour,
J'ai le même problème mais seulement sur une partie de mes blogs.
J'ai entre autre un multi-blog où ligthbox fonctionne toujours sur deux blogs, et pas sur le troisième.
Je n'y connais rien en javascript.
Même en repassant à la bibliothèque javascript précédente, ça ne marche plus du tout !
Help !

Dernière modification par stvercez (2020-04-21 12:44:39)

Hors ligne

#11 2020-04-21 12:58:22

stvercez
Membre
Inscription : 2012-07-25

Re : Problème lightbox et Gallleryinsert

stvercez a écrit :
hyperion66 a écrit :

Bonjour,

Depuis la mise à jour lightbox, j'ai un souci sur www.matosvelo.fr.
D'une, je n'ai plus l'effet lightbox sur mes images, elles s'affichent sans aucun effet, obligeant à un retour arrière pour revenir sur l'article, mais en plus, ça empêche les galeries faites avec GalleryInsert v0.412 de s'afficher correctement. Une idée de comment régler le problème ?

Je suis revenu à lightbox 1.3.1, plus de souci.

Merci

Bonjour,
J'ai le même problème mais seulement sur une partie de mes blogs.
J'ai entre autre un multi-blog où ligthbox fonctionne toujours sur deux blogs, et pas sur le troisième.
Je n'y connais rien en javascript.
Même en repassant à la bibliothèque javascript précédente, ça ne marche plus du tout !
Help !

J'ai suivi vos conseils : c'est en effet dans une version modifiée du _head.html de certains blogs seulement qu'il fallait modifier le code pour jquery.
Merci aux Geeks pour leur aide !

Hors ligne

#12 2020-04-21 13:27:12

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Problème lightbox et Gallleryinsert

Il faudrait nous donner un lien pour voir le blog où ça ne marche pas, nous ne pouvons pas deviner autrement. Notamment il nous faut connaître la version de dotclear, le thème et les plugins utilisés, ainsi que les messages d'erreur dans la console du navigateur

Edit : ça c'est autoréparé entre temps, félicitations

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map