Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2020-06-01 20:05:21

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

[résolu]Mise à jour Dotclear 2.16.8

Bonjour,
Cette mise à jour génère une modification de 

/inc/.htaccess 

Or depuis au moins la version dotclear-2.13 - j'ai pas vérifié plus en arrière , /inc/.htaccess est le même que celui proposé.
Mais, apparemment, pas le même que dans des versions plus anciennes, même mise à jour, puisque les mises à jour proposées n'intégraient pas de modification de ce fichier.

Ainsi, si vous avez installé une version récente de Dotclear, la mise à jour peut indiquer une erreur qui empêche la mise à jour automatique

Solution: utiliser le plugin Fake Me Up
qui va afficher le (ou) les fichiers qui pose(nt) problème, parce que modifié(s)..

Si c'est seulement /inc/.htaccess vous pouvez confirmer et installer la nouvelle mise à jour sans problème

EDIT: je me suis un peu mélangé les pinceaux ;-( Cf mon post suivant

Dernière modification par nanart (2020-06-02 11:23:18)


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#2 2020-06-02 06:09:08

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : [résolu]Mise à jour Dotclear 2.16.8

Bonjour. Je viens de mettre à jour une installation sur le canal "testing" et je n'ai pas eu besoin d'utiliser Fake Me Up. À surveiller pour la prochaine version...

Hors ligne

#3 2020-06-02 11:22:27

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : [résolu]Mise à jour Dotclear 2.16.8

Bonjour,

Oups, je me suis mélangé les pinceaux en lisant ce post  Modification du fichier .htaccess à savoir:

Require all denied
Deny from all

devrait être remplacé par

# Apache 2.2
<IfModule !authz_core_module>
  Deny from all
</IfModule>

# Apache 2.4+
<IfModule authz_core_module>
  Require all denied
</IfModule>

et non l'inverse :rolleyes:


Bref, pas de panique,
sauf que - erreur de ma part ... Fake Me Up ne modifie pas ce fichier???
Du coup, il faut donc que je le modifie à la main pour éviter que les prochaines mises à jour me signalent encore une erreur ?

Quant à l'erreur initiale, il est possible que j'ai modifié moi-même ce fichier. Et -je m'en suis déjà aperçu, un simple retour de ligne en plus ou en moins -> boum !

D'où:
A suivre...

Dernière modification par nanart (2020-06-02 11:36:10)


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map