Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2021-02-04 09:39:19

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Passer de PHP 5.6 à PHP 7.x => MSQL MSQLI

La prochaine version de Dotclear nécessitera une version de php minimum 7

Si vous utilisez une version inférieure (php 5.6.x, par ex) et désirez utiliser php 7 dès maintenant, une opération est nécessaire pour permettre un passage "en douceur".

--> dans le fichier /votredossierdotclear/inc/config.php

Il s'agit de modifier, dans le fichier config.php la ligne suivante tout en haut du fichier:

define('DC_DBDRIVER','mysql');

en ajoutant un i (lettre i) à mysql
ce qui donne

define('DC_DBDRIVER','mysqli');

Si vous craignez de faire une erreur vous pouvez copier la ligne et mettre l'original en commentaire, comme ceci

// define('DC_DBDRIVER','mysql');
define('DC_DBDRIVER','mysqli');

en cas de problème il vous suffira de décommenter la 1er ligne en enlevant les // et commenter la seconde en ajoutant // et poser la question sur ce forum....

bonne nouvelle Vous pouvez dès maintenant procéder à cette modification car elle ne génère aucun problème si vous continuez à utiliser une version php <7 (5.6.x, par ex). C'est même recommandé

Pour information: On n’utilise plus l’API mysql qui est devenu obsolète. Il n’est plus mis à jour, ne gère pas les dernières fonctionnalités de MySQL et pourrait présenter des failles de sécurité.

Note @Franck la prochaine 2.19 s’en fichera puisque dans ce cas il fera comme si c’était mysqli, donc rien à modifier.

Dernière modification par nanart (2021-02-04 09:56:01)


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#2 2021-02-05 08:24:15

adjaya
Membre
Lieu : Provence - Luberon
Inscription : 2006-09-05
Site Web

Re : Passer de PHP 5.6 à PHP 7.x => MSQL MSQLI

nanart a écrit :

Si vous utilisez une version inférieure (php 5.6.x, par ex) et désirez utiliser php 7 dès maintenant, une opération est nécessaire pour permettre un passage "en douceur".

peut être à préciser que cette opération n'est nécessaire que si l'on utilise une base de données Mysql.
Cette modification ne concernant évidement pas les utilisateurs des bases
PostgreSQL ou Sqlite.


Photo, Art et Création Numérique : http://benoit-grelier.photo7.fr/

Hors ligne

#3 2021-02-28 18:41:08

NenadX
Membre
Lieu : Amsterdam
Inscription : 2020-12-21
Site Web

Re : Passer de PHP 5.6 à PHP 7.x => MSQL MSQLI

Unfortunately, this is not helped in my case.

Here is the part of my config.php

<?php
/**
* @package Dotclear
*
* @copyright Olivier Meunier & Association Dotclear
* @copyright GPL-2.0-only
*/

if (!defined('DC_RC_PATH')) {return;}

// Database driver (mysql (deprecated, disabled in PHP7), mysqli, mysqlimb4 (full UTF-8), pgsql, sqlite)
define('DC_DBDRIVER','mysqli');

// Database hostname (usually "localhost")
define('DC_DBHOST','localhost');

// Database user
define('DC_DBUSER','routpyue_dotc257');

// Database password
define('DC_DBPASSWORD','xxxxxxxxxxx');

// Database name
define('DC_DBNAME','routpyue_dotc257');

// Tables' prefix
define('DC_DBPREFIX','dcx9_');

// Persistent database connection
define('DC_DBPERSIST', false);

Hors ligne

#4 2021-02-28 19:10:11

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : Passer de PHP 5.6 à PHP 7.x => MSQL MSQLI

Si ça concerne le blog en profil, je ne vois aucun soucis de connexion à la bdd.

Hors ligne

#5 2021-02-28 19:14:19

NenadX
Membre
Lieu : Amsterdam
Inscription : 2020-12-21
Site Web

Re : Passer de PHP 5.6 à PHP 7.x => MSQL MSQLI

After checking error.log file

[28-Feb-2021 18:58:47 UTC] PHP Fatal error:  'break' not in the 'loop' or 'switch' context in /home/routpyue/public_html/plugins/postNotification/behaviors.php on line 132

I change "break" to "loop" in line 132 and now blog is working again. :)

if(count($ulist)==0) break;

to

if(count($ulist)==0) loop;

Hors ligne

#6 2021-03-01 14:38:47

Lomalarch
Responsable du photocopieur
Lieu : Colombes (92)
Inscription : 2006-05-02
Site Web

Re : Passer de PHP 5.6 à PHP 7.x => MSQL MSQLI

Thanks for your feedback and resolution. Your problem was caused by the postNotification plugin, which is an old plugin, which explains that it is up to date with latest PHP versions.


RTFM attitude : https://fr.dotclear.org/documentation/2.0
Le chantier tips, tutos et astuces : http://tips.dotaddict.org/
Rien nulle part??? une petite recherche sul’ forum, alors?: https://forum.dotclear.org/search.php ?

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map