Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2010-02-28 14:01:16

Mathieu M.
Membre
Lieu : Rhône-Alpes
Inscription : 2009-09-14
Site Web

La branche 2.1.x et php 5.3

Bonjour à tous,

Je suis sous DC 2.1.6 pour un projet, et je ne pourrais pas me tourner vers DC 2.2 (lors de sa sortie) pour tout un tas de raisons. Je me permet du coup d'ouvrir ce sujet pour savoir si la branche 2.1.x, et donc une éventuelle release 2.1.7, allait subir quelques modifs "officielles" pour être compatible avec php 5.3 et dans un avenir plus lointain php 6 ?


Merci ;-)

Hors ligne

#2 2010-02-28 14:21:25

Moe
Responsable du mini-bar
Lieu : France
Inscription : 2004-09-19
Site Web

Re : La branche 2.1.x et php 5.3

Bonjour,
j'ai posé la même question à xave, sa réponse est "non".

Hors ligne

#3 2010-02-28 14:57:59

Mathieu M.
Membre
Lieu : Rhône-Alpes
Inscription : 2009-09-14
Site Web

Re : La branche 2.1.x et php 5.3

Décidément c'est à la mode l'abandon des "vieilles" branches (cf. phpBB, entre autre...).

:/

Hors ligne

#4 2010-02-28 15:02:08

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : La branche 2.1.x et php 5.3

La future 2.2 n'est essentiellement qu'une mise en compatibilité avec PHP 5.3. Certes la prochaine version ne s'appellera donc pas 2.1.7, mais en pratique il n'y aura, à part cette compatibilité, qu'une modification de la gestion des préférences des plugins.


Dotclear addicted since 2004

Hors ligne

#5 2010-02-28 15:05:22

Mathieu M.
Membre
Lieu : Rhône-Alpes
Inscription : 2009-09-14
Site Web

Re : La branche 2.1.x et php 5.3

Le hic, si on peut dire, c'est que la plupart des plugins et thèmes vont mettre un certain temps avant d'être mis à jour. Avec l'avancement de la branche 2.2, ça risque d'être assez long, et certains projets ne peuvent pas vraiment attendre 1 an... :(

Hors ligne

#6 2010-02-28 15:21:54

Kozlika
Modo dcTeam
Inscription : 2004-05-08
Site Web

Re : La branche 2.1.x et php 5.3

Uh ? Oh mais la version compatible PHP 5.3 va sortir avant un an hein ! (ou je n'ai pas compris la remarque)


La documentation : http://doc.dotclear.net/2.0/fulltoc
Le module de recherche du forum : http://www.dotclear.net/forum/search.php ?

Hors ligne

#7 2010-02-28 16:19:16

Moe
Responsable du mini-bar
Lieu : France
Inscription : 2004-09-19
Site Web

Re : La branche 2.1.x et php 5.3

Mathieu M. a écrit :

je ne pourrais pas me tourner vers DC 2.2 (lors de sa sortie) pour tout un tas de raisons

Peux-tu préciser ces raisons ? Ce sont des choses à améliorer dans Dotclear peut-être ? Ou des problèmes que des lecteurs de ce forum pourraient régler ?

Hors ligne

#8 2010-02-28 19:56:28

Mathieu M.
Membre
Lieu : Rhône-Alpes
Inscription : 2009-09-14
Site Web

Re : La branche 2.1.x et php 5.3

Kozlika a écrit :

Uh ? Oh mais la version compatible PHP 5.3 va sortir avant un an hein ! (ou je n'ai pas compris la remarque)

Je disais simplement qu'il faut encore pas mal de temps avant la sortie de DC 2.2 + du temps pour mettre à jour les plugins (sans compter ceux que j'utilise et qui ne seront peut-être pas mis à jour) + du temps pour mettre à jour le thème employé. Bref, ça fait beaucoup de temps mine de rien, et pour le projet que je monte, le temps c'est de l'argent (oui, c'est pas bien beau à écrire comme ça...) ;-)

Moe a écrit :

Peux-tu préciser ces raisons ? Ce sont des choses à améliorer dans Dotclear peut-être ? Ou des problèmes que des lecteurs de ce forum pourraient régler ?

Non, principalement le manque de temps et certaines applications qui tournent avec / grâce à DC 2.1.6 (et bon, c'est quitte ou double avec une mise à jour, et tout renvoi au manque de temps ensuite...).

Je trouve vraiment dommage que certains développements poussent les utilisateurs à toujours "suivre le mouvement". Bien sûr, parfois c'est essentiel, comme la mise à jour phpBB2 vers phpBB3 par exemple (sécurité, sérénité à long terme, ...), mais le reste du temps, je trouve vraiment dommage et dommageable que les "vieilles branches" ne soient pas soutenues...

Hors ligne

#9 2010-02-28 20:05:00

Moe
Responsable du mini-bar
Lieu : France
Inscription : 2004-09-19
Site Web

Re : La branche 2.1.x et php 5.3

Mathieu M. a écrit :

Je disais simplement qu'il faut encore pas mal de temps avant la sortie de DC 2.2 + du temps pour mettre à jour les plugins (sans compter ceux que j'utilise et qui ne seront peut-être pas mis à jour)

Sais-tu que les plguins actuels fonctionneront toujours sur Dotclear 2.2 ? Ça affichera une erreur mais on pourra la cacher en modifiant le fichier de configuration.

Mathieu M. a écrit :

Je trouve vraiment dommage que certains développements poussent les utilisateurs à toujours "suivre le mouvement". Bien sûr, parfois c'est essentiel, comme la mise à jour phpBB2 vers phpBB3 par exemple (sécurité, sérénité à long terme, ...), mais le reste du temps, je trouve vraiment dommage et dommageable que les "vieilles branches" ne soient pas soutenues...

Dotclear ne fait que suivre l'évolution de PHP. Libre à toi d'utiliser Dotclear 2.1.6 sur PHP 5.2 pendant 10 ans, personne ne t'oblige à faire les mises à jour. Si tu le souhaites, tu peux essayer de te bricoler une version 2.1.6 de Dotclear en ajoutant les modifications de Dsls pour ajouter la compatibilité avec PHP 5.3.

Hors ligne

#10 2010-02-28 23:03:10

Mathieu M.
Membre
Lieu : Rhône-Alpes
Inscription : 2009-09-14
Site Web

Re : La branche 2.1.x et php 5.3

Moe, le problème n'est pas de suivre php, mais surtout, du côté utilisateur, de suivre le support d'un logiciel. Inutile d'être dupe, à la sortie de DC 2.2, DC 2.1.x va prendre un coup de vieux et il n'y aura plus vraiment d'engouement pour cette branche.

C'est un fait, comme pour beaucoup d'autres logiciels. Dans la pratique, ça contraint toujours l'utilisateur à : 1- rester sur la "vieille branche" et se débrouiller seul, 2- se casser les dents pour migrer vers la nouvelle branche.

Je suis un peu rabat-joie :-) mais je serais ravi de passer sur DC 2.2 pour tous mes autres projets, mais sur l'un, ça risque d'être fort compliqué hélas :/


Mathieu.

Hors ligne

#11 2010-02-28 23:50:49

Moe
Responsable du mini-bar
Lieu : France
Inscription : 2004-09-19
Site Web

Re : La branche 2.1.x et php 5.3

Mathieu M. a écrit :

Inutile d'être dupe, à la sortie de DC 2.2, DC 2.1.x va prendre un coup de vieux et il n'y aura plus vraiment d'engouement pour cette branche.

Peut-être que tu n'es pas le seul à avoir besoin d'un backport ? Tu devras probablement te débrouiller seul.

Mathieu M. a écrit :

je serais ravi de passer sur DC 2.2 pour tous mes autres projets, mais sur l'un, ça risque d'être fort compliqué hélas :/

À qui la faute ? Peut-être que tu aurais dû choisir une base plus pérenne qu'un logiciel de blog si tu cherchais la stabilité.

Hors ligne

#12 2010-03-01 06:06:31

Dsls
Modérateur couteau-suisse
Inscription : 2004-11-18
Site Web

Re : La branche 2.1.x et php 5.3

Le seul changement majeur de la version 2.2 sera le support de php 5.3, du moins pour les uilisateurs.
Sortir une 2.1.7 ne changerait rien, les thèmes et plugins auront quoi qu'il arrive à être adaptés, vu qu'une partie des évolutions tient plus de php 5.3 que de dc2.2 ...


Dyslexics have more fnu!

Hors ligne

#13 2010-03-01 10:00:53

Serveur
Membre
Lieu : Champagne Ardenne
Inscription : 2008-12-08
Site Web

Re : La branche 2.1.x et php 5.3

Salut ...

Personnellement cette discussion m'inquiète quand même ... quand je vois les soucis que j'ai eu avec l'évolution de Weezo de version en version (et encore, dans ce cas la, je suis en local) ... lors du passage il y a un moment déjà du PHP3 vers le PHP4 (sur Chez.com) ... mais il est vrai que la futur migration vers un DC 2.2 me hante ... c'est toujours un soucis de voir qu'une mise à jour peut "plomber" des heures de travail, tant au niveau du thème que des extensions !!!

@+


J'y connais rien mais je ne demande qu'à apprendre ... !!!
Weezo v2 : http://weezo.net/Serveur (quelques petits problèmes en ce moment)
Blog DC 2.9.1 chez 1&1 : http://www.elleluinous.fr/ (multi-Blog)
Blog DC 2.9.1 chez 1&1 de l'E.P.R.A.S. : http://www.epras.fr/

Hors ligne

#14 2010-03-01 10:05:16

Dsls
Modérateur couteau-suisse
Inscription : 2004-11-18
Site Web

Re : La branche 2.1.x et php 5.3

L'update vers la 2.2 sera dans la même trempée qu'un update depuis la 2.1.5 vers la 2.1.6, c'est-à-dire quasi transparent.
Si vous restez sur du php < 5.3, même les plugins qui n'auront pas été adaptés fonctionneront.


Dyslexics have more fnu!

Hors ligne

#15 2010-03-01 10:36:08

Mathieu M.
Membre
Lieu : Rhône-Alpes
Inscription : 2009-09-14
Site Web

Re : La branche 2.1.x et php 5.3

Bonjour,

Moe a écrit :
Mathieu M. a écrit :

je serais ravi de passer sur DC 2.2 pour tous mes autres projets, mais sur l'un, ça risque d'être fort compliqué hélas :/

À qui la faute ? Peut-être que tu aurais dû choisir une base plus pérenne qu'un logiciel de blog si tu cherchais la stabilité.

Moe, je ne tiens pas à m'étendre sur le sujet, mais je trouve cette remarque un tantinet déplacée ;-) Je ne reproche rien à Dotclear, qui est à mon sens un superbe outil bien plus complet qu'une simple "machine à faire des blogs".

Dsls a écrit :

Le seul changement majeur de la version 2.2 sera le support de php 5.3, du moins pour les uilisateurs.
Sortir une 2.1.7 ne changerait rien, les thèmes et plugins auront quoi qu'il arrive à être adaptés, vu qu'une partie des évolutions tient plus de php 5.3 que de dc2.2 ...

Pas faux :-)
Dans mon cas, le hic vient comme je l'ai dit précédemment, plus du temps et de certaines applications qui tournent autour de DC 2.1.6 (et je suis incapable de dire si elles tourneront avec DC 2.2, ce qui m'inquiète justement).

Serveur a écrit :

mais il est vrai que la futur migration vers un DC 2.2 me hante ... c'est toujours un soucis de voir qu'une mise à jour peut "plomber" des heures de travail, tant au niveau du thème que des extensions !!!

Ce n'est pas le sujet, mais c'est exactement ce qu'il se passe avec phpBB depuis plusieurs mois... et c'est frustrant de voir son travail réduit à néant par une mise à jour, tout comme il est agaçant la politique du phpBB Group à forcer ses utilisateurs à migrer à chaque nouveauté (plus aucun support pour les "vieilles branches", comme phpBB 2.0 et prochainement phpBB 3.0).


++

Hors ligne

#16 2010-03-01 10:45:26

Dsls
Modérateur couteau-suisse
Inscription : 2004-11-18
Site Web

Re : La branche 2.1.x et php 5.3

Mathieu M. a écrit :

Dans mon cas, le hic vient comme je l'ai dit précédemment, plus du temps et de certaines applications qui tournent autour de DC 2.1.6 (et je suis incapable de dire si elles tourneront avec DC 2.2, ce qui m'inquiète justement).

Il est fort probable que les changements passeront inaperçus pour la majorité des plugins.

Et au vu des adaptations qu'il faudra éventuellement faire, je pense qu'on pourra mettre en place des correctifs des plugins problématiques rapidement, quitte à notifier les auteurs desdits plugins en parallèle...


Dyslexics have more fnu!

Hors ligne

#17 2010-03-01 10:59:26

Tomtom33
Responsable des travaux finis
Lieu : Barcelone
Inscription : 2006-06-13

Re : La branche 2.1.x et php 5.3

Et puis je rappelle quand même que cette mise à jour (ie dc2.2) est faite pour suivre les changements induits par php 5.3. On ne fait que suivre le mouvement de php et des utilisateurs qui viennent "râler" ici parce que la version actuelle n'est pas compatible (à juste titre).

Et franchement, tout ce que tu risques en migrant, c'est d'avoir des notices qui s'affichent à cause des plugins et thèmes qui passent leurs arguments en référence ce qui est déprécié avec php5.3. Or sur un serveur en prod, l'affichage de ses notices est désactivé donc c'est pas la mort. A part ça, tout fonctionnera normalement.


Le lab => http://lab.dotclear.org
Besoin d'un plugin? => http://plugins.dotaddict.org
Besoin d'un thème? => http://themes.dotaddict.org
Besoin d'une astuce? => http://tips.dotaddict.org

Hors ligne

#18 2010-05-25 11:16:46

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : La branche 2.1.x et php 5.3

Pour tester PHP 5.3 (et la 2.2-alpha de Dotclear) sur un hébergement mutualisé chez OVH, il faut remplacer, dans le fichier .htaccess :

SetEnv PHP_VER 5

par

SetEnv PHP_VER 5_TEST

Hors ligne

#19 2010-05-25 11:21:02

Moe
Responsable du mini-bar
Lieu : France
Inscription : 2004-09-19
Site Web

Re : La branche 2.1.x et php 5.3

Si je ne me trompe pas, on peut aussi tester la version 2.2-alpha sur PHP 5.2.

Hors ligne

#20 2010-05-25 11:22:51

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : La branche 2.1.x et php 5.3

Oui, tu as raison, le message n'était pas très clair sur ce point ^^

Hors ligne

#21 2010-05-25 11:44:59

xave
Président
Lieu : commun
Inscription : 2004-05-06
Site Web

Re : La branche 2.1.x et php 5.3

Si je peux me permettre d'être désagréable (ah, ça fait longtemps, tiens) : je ne comprends pas bien la logique du "je voudrais qu'on mette à jour pour PHP5.3 mais je ne veux pas installer la version qui est une mise à jour pour PHP5.3."

Question identique pour : "je voudrais que la version N soit mise à jour, mais je ne veux pas de la version N+1".


xave, asocial assez atypique (©Koz) , en 15ème année de http://xave.org/
RTFM. / Je ne lis pas la LOL-langue. / Je suis un gars désagréable, ne me parlez pas.

Hors ligne

#22 2010-05-25 21:09:03

JcDenis
Membre
Lieu : Lyon, France
Inscription : 2007-08-31
Site Web

Re : La branche 2.1.x et php 5.3

Tiens j'vais rajouter mon grin de sel à propos des passages aux versions supérieurs.

Etant developpeur de plugins, je serais le premier à ne plus developper mes plugins sous 2.1.7 à la sortie de la 2.2. Car même si il n'y aura pas de révolution, l'évolution de Dotclear vaut la peine de passer à la version suivante, j'ai un tas de plugins qui ne demande que ça et ceux existant profiteront des avancés de DC. Par manque de temps (pour reprendre un expression de ce sujet) et grace à ces avancés, je ne peux faire évoluer deux branches en parallèle de mes 532000 plugins.
Effectivement il y aura un temps de latence entre la mise à jour de Dotclear et celle des plugins mais comme dit plus haut cela ne devrait en rien gèner le fonctionnement d'un blog. Et l'equipe de DC est la pour vous aider.

Voila c'était mon point de vue sur la chose.

Hé, au fait, comment rester jouer à Pacman quand Call of Duty 25 existe...


Cordialement,
_JC | Intérimaire | En mode invisible

Hors ligne

#23 2010-05-26 02:26:18

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : La branche 2.1.x et php 5.3

Pacman c'est vachtement bien quand call of duty fout la nausée ;-)

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map