Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2010-06-07 17:14:00

Kompozitor
Membre
Inscription : 2008-06-09
Site Web

Installation locale de la 2.2alpha

Bonjour, j'ai installé la 2.2alpha en locale sur wampserver avec la config suivante :

OS : windows 7 64bits
Browser : firefox 3.6.3
Apache : 2.2.11
PHP : 5.2.11
MySql : 5.1.36

Partie install et admin tout fonctionne bien : j'afiche l'admin, j'ai installé des plufgins des themes et tout...

Et puis partie publique : rien. Je veux dire, mais même une erreur DC ou un affichage partiel. Connexion reinitialisée

"La connexion a été réinitialisée

La connexion avec le serveur a été réinitialisée pendant le chargement de la page.

    *   Le site est peut-être temporairement indisponible ou surchargé. Réessayez plus
          tard ;

    *   Si vous n'arrivez à naviguer sur aucun site, vérifiez la connexion
          au réseau de votre ordinateur ;

    *   Si votre ordinateur ou votre réseau est protégé par un pare-feu ou un proxy,
          assurez-vous que Firefox est autorisé à accéder au Web."

J'ai retourné le pb dans tous les sens, je ne sais plus où regarder...
Help ! :'(

Hors ligne

#2 2010-06-07 17:17:50

Dsls
Modérateur couteau-suisse
Inscription : 2004-11-18
Site Web

Re : Installation locale de la 2.2alpha


Dyslexics have more fnu!

Hors ligne

#3 2010-06-07 18:04:28

Kompozitor
Membre
Inscription : 2008-06-09
Site Web

Re : Installation locale de la 2.2alpha

Merci ! t'es un chef !

Hors ligne

#4 2010-06-07 18:49:22

Kompozitor
Membre
Inscription : 2008-06-09
Site Web

Re : Installation locale de la 2.2alpha

Bon, j'ai encore un soucis !

Warning: Parameter 1 to menuWidgets::initWidgets() expected to be a reference, value given in C:\wamp\www\dotclear\inc\core\class.dc.core.php  on line 304

Warning: Parameter 1 to templateWidgetBehaviors::loadVisitorCookie() expected to be a reference, value given in C:\wamp\www\dotclear\inc\core\class.dc.core.php on line 304

Warning: Parameter 1 to templateWidgetBehaviors::loadVisitorCookie() expected to be a reference, value given in C:\wamp\www\dotclear\inc\core\class.dc.core.php on line 304

Warning: Parameter 1 to templateWidgetBehaviors::loadVisitorCookie() expected to be a reference, value given in C:\wamp\www\dotclear\inc\core\class.dc.core.php on line 304

Warning: Parameter 1 to templateWidgetBehaviors::loadVisitorCookie() expected to be a reference, value given in C:\wamp\www\dotclear\inc\core\class.dc.core.php on line 304

dans le header

J'ai la même erreur plus loin dans le blog...

Hors ligne

#5 2010-06-07 20:58:31

Dsls
Modérateur couteau-suisse
Inscription : 2004-11-18
Site Web

Re : Installation locale de la 2.2alpha

Il faut faire quelques adaptations au plugin templateWidget pour qu'il soit compatible avec PHP 5.3. Tu utilises quelle version de templateWidget ?


Dyslexics have more fnu!

Hors ligne

#6 2010-06-07 21:00:47

Kompozitor
Membre
Inscription : 2008-06-09
Site Web

Re : Installation locale de la 2.2alpha

1.4 m'sieur :)

Hors ligne

#7 2010-06-07 21:05:55

Dsls
Modérateur couteau-suisse
Inscription : 2004-11-18
Site Web

Re : Installation locale de la 2.2alpha

Dans WidgetAdmin.php, remplacer &$widgets par $widgets (2x). Idem dans _public.php (2x)


Dyslexics have more fnu!

Hors ligne

#8 2010-06-07 21:17:00

Kompozitor
Membre
Inscription : 2008-06-09
Site Web

Re : Installation locale de la 2.2alpha

mmm j'ai pas &$widgets  dans _public.php

Hors ligne

#9 2010-06-07 21:31:08

Dsls
Modérateur couteau-suisse
Inscription : 2004-11-18
Site Web

Re : Installation locale de la 2.2alpha

Au temps pour moi, il s'agit de &$widget et &$core dont il faut enlever les &


Dyslexics have more fnu!

Hors ligne

#10 2010-06-07 21:42:10

Kompozitor
Membre
Inscription : 2008-06-09
Site Web

Re : Installation locale de la 2.2alpha

glop, c'est ce dont je me suis douté !

J'avais le même message d'erreur dans le plugin menu, j'ai donc remplacé tous les "&$" par des "$" (je suis d'un pouvoir déductif qui m'épate moi-même),
ça avance...

J'ai aussi copié les deux fichier .widget de mystique dans defaut_template (je sais pas si'il fallait faire ça, mais du coup les widgets sont apparus dans l'admin)

il me reste un message d'erreur :

Notice: Undefined variable: _actv_sm in C:\wamp\www\dotclear\plugins\menu\_public.php  on line 285
Un pas après l'autre lol

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map