Dotclear

Vous n'êtes pas identifié(e).

Annonce

#26 2012-02-09 06:51:55

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : Pb messagerie ?

Waouh ! ça semble alléchant !
J'ai demandé les renseignements requis à mon hébergeur. Dès que j'ai ça, je teste cette solution et la partagerais ici.
Mais pourquoi n'ai-je pas trouvé cette solution tous seul en fouillant dans le forum et en utilisant "mon ami G"......... ;o) ???

Merci Osku.

Hors ligne

#27 2012-02-10 04:20:06

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : Pb messagerie ?

Salut ;

Cette solution ne fonctionne pas non plus.
Mon hébergeur m'a signifié de mettre 'localhost' dans les lignes de code - qui étaient déjà à la fin de mon fichier "config.php" d'ailleurs (est-ce déjà une intervention de l'assistance de mon hébergeur ou est-ce d'origine dans DC 2.4.1.2 ?) - et ça ne change rien...

J'ai désactivé tous mes antispams ; vider via FTP tous les caches, vider le cache de mon navigateur...... IDEM.
Je commence à désespérer...

HELP !

Hors ligne

#28 2012-02-10 10:59:40

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Pb messagerie ?

Pour résumer, la boîte mail fonctionne mais c'est le site qui ne sait pas envoyer les mails ?

PS : je t'ai envoyé un mail directement sur l'adresse fournie dans le premier message de ce sujet ;)

Dernière modification par Philippe (2012-02-10 11:02:17)

Hors ligne

#29 2012-02-10 15:14:31

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : Pb messagerie ?

amalgame a écrit :

je t'ai envoyé un mail directement sur l'adresse fournie dans le premier message de ce sujet ;)

Reçu ! Mais ça je savais puisque je me suis fait moi-même des test avec des envois par mes différentes adresses de courriel.
Mais là je suis perdu... Je fais quoi ? Je vous ai fourni toutes mes infos je pense et je vois pas de solution poindre le bout du nez...
Je suis prêt à tout reprendre du début.
Merci amalgame ;)

Hors ligne

#30 2012-02-10 15:16:43

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : Pb messagerie ?

...t'ai répondu par courriel via la même adresse aussi, je pense que tu as reçu...

Hors ligne

#31 2012-02-10 15:28:58

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Pb messagerie ?

Oui, donc la messagerie fonctionne ;)

Essayons d'aller plus loin : on a regardé dans dotclear, mais ce n'est peut-être pas le seul endroit. En effet, il est possible que les messages envoyés par ton site internet soient capturés par un antispam du côté de ton FAI. As-tu vérifié ce point ?

Cela pourrait arriver si par exemple tu as envoyé beaucoup de mails de manière automatisée avec le site...

Hors ligne

#32 2012-02-10 17:24:40

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : Pb messagerie ?

Je suis chez le trublion  ;o) Mais j'ai aussi tenté avec une connexion secondaire en Wi-fi sur mon lieu de travail, donc avec un autre FAI vu que c'est à l'étranger et ça n'a pas fonctionné non plus. Donc ça ne viendrait pas de mon FAI, non ?

Hors ligne

#33 2012-02-13 07:17:55

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : Pb messagerie ?

Pour info, mise à jour de Dotclear en 2.4.2 ; le pb persiste.
Je sais pas pourquoi, mais je m'en doutais ;o)

Hors ligne

#34 2012-02-14 08:54:48

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : Pb messagerie ?

Bonjour,

Je cherche toujours une solution (côté antispam) à mon problème et en essayant de désactivé "akismet", j'ai eu ce message côté admin ET public :

Fatal error: Call to a member function register() on a non-object in /home/bebrfr/public_html/blog/plugins/pages/_prepend.php on line 14

Cela vous en dit-il un peu plus ?
Merci.

Hors ligne

#35 2012-02-14 09:02:07

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : Pb messagerie ?

Arrête de tourner en rond et grater Dotclear.

Le problème est du côté de ton hébergeur. Demande leur comment envoyer un mail depuis leur serveur. Tu peux aussi leur demander la "Changelog" de la mise à jour de leur serveur. (si j'ai bien compris, avant leur mise à jour, ça marchait)

S'ils ne te donnent pas d'élément, tu devras te résigner à changer d'hébergeur. Beaucoup de magiciens contribuent à dotclear mais pour ton problème, il faudrait des voyants extra-lucides. :)

Hors ligne

#36 2012-02-14 10:31:07

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : Pb messagerie ?

Slt Osku et merci pour ta réponse d'une franchise que j'apprécie.

J'ai donc posé les questions que tu me soumets à mon hébergeur. Je posterais la réponse ici car je suis pas sûr d'y comprendre quelque chose. :'-(

A+

Hors ligne

#37 2012-02-14 15:40:32

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : Pb messagerie ?

J'ai la réponse aux question par mon hébergeur :
Pour l'envoie du courriel, que voulez-vous dire exactement? Normalement, vous pouvez envoyer des courriels à partir de votre compte courriel ou à partir de la fonction mail de php pour les différents scripts.
Pour le changement de serveur, il n'y a pas de changelog précis, la seule différence est la version de php qui est 5.2.17 au lieu de 5.3.8 sur ce serveur.

Alors ?

Hors ligne

#38 2012-02-21 06:11:48

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : Pb messagerie ?

y'a t'il un bon samaritain DC - physiquement - près de  moi (Nice) ?

Hors ligne

#39 2012-02-21 12:43:26

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : Pb messagerie ?

Est-ce que, à tout hasard, tu aurais installé le plugin "fakeMail" ?

Hors ligne

#40 2012-02-21 17:08:44

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : Pb messagerie ?

Sinon, tu peux faire des essais d'envoi d'email depuis ton tableau de bord Dotclear via l'extension 'Mail testor' disponible ici : http://dleds.net/labs/pub/6DwvL2

Hors ligne

#41 2012-02-22 08:09:45

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : Pb messagerie ?

Slt Osku ;

Comme tu vois, je galère toujours.
J'ai supprimé tous mes plugins faisant appel à la fonction d'envoi de courriel en attendant de trouver une solution.
Le ticket d'assistance de mon hébergeur sur ce problème est maintenant fermé. Ce qui me parait tout à fait normal sachant que j'ai deux blogs hébergés sur la même plateforme et que l'un fonctionne tout à fait normalement  - au niveau d'envoi de courriel(s) automatique(s) - et pas l'autre.

J'ai suivi ton ultime conseil : installer "Mail testor" (Pour info je n'ai pas installé "FakeMail", c'est la première fois que j'en entends parler).

Résultat des courses :
1/ adresse du destinataire : j'ai essayé avec plusieurs de mes adresses de courriel en faisant attention de ne pas faire de faute
2/ sujet : "test"
3/ contenu : "test"
MAIS...
4/ Deux possibilités :
- sans cocher "Active mail headers" : ERREUR

No valid from e-mail address

(alors que mon adresse est bien correcte, j'ai vérifié)
-en cochant  "Active mail headers" : ERREUR

220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail.

Alors Docteur ?
;o)

Merci.

Hors ligne

#42 2012-02-22 08:45:41

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Pb messagerie ?

Peux-tu faire un test afin de savoir si c'est l'envoi de mails par dotclear ou l'envoi de mails tout court qui est en panne ?

Si oui, crée une page connexe avec le plugin du même nom, qui appelle un fichier que tu crées nommé contact.php.

Le fichier contact.php contiendra ce code. N'oublie pas de changer l'adresse dans le haut du script ;)

Teste ensuite l'envoi à partir de la page connexe, et reviens nous dire.

Hors ligne

#43 2012-02-22 10:34:54

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : Pb messagerie ?

bebr a écrit :

Slt Osku ;

Comme tu vois, je galère toujours.
J'ai supprimé tous mes plugins faisant appel à la fonction d'envoi de courriel en attendant de trouver une solution.
Le ticket d'assistance de mon hébergeur sur ce problème est maintenant fermé. Ce qui me parait tout à fait normal sachant que j'ai deux blogs hébergés sur la même plateforme et que l'un fonctionne tout à fait normalement  - au niveau d'envoi de courriel(s) automatique(s) - et pas l'autre.

J'ai suivi ton ultime conseil : installer "Mail testor" (Pour info je n'ai pas installé "FakeMail", c'est la première fois que j'en entends parler).

Résultat des courses :
1/ adresse du destinataire : j'ai essayé avec plusieurs de mes adresses de courriel en faisant attention de ne pas faire de faute
2/ sujet : "test"
3/ contenu : "test"
MAIS...
4/ Deux possibilités :
- sans cocher "Active mail headers" : ERREUR

No valid from e-mail address

(alors que mon adresse est bien correcte, j'ai vérifié)
-en cochant  "Active mail headers" : ERREUR

220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail.

Alors Docteur ?
;o)

Merci.

Le nom de domaine du site concerné est-il bien configuré ? Tu peux accéder au site ?

D'après ce qu'on a comme erreur, c'est lié à ton hébergeur. Tu peux lui faire passer ta seconde erreur "220- truc ...".

Hors ligne

#44 2012-02-22 10:52:02

osku
Membre
Lieu : 28
Inscription : 2005-06-15

Re : Pb messagerie ?

Tu peux aussi refaire ces essais avec le fichier de config.php de dotclear sans les lignes _mail() de l'astuce ci-dessus. ?

Hors ligne

#45 2012-02-22 11:28:44

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : Pb messagerie ?

EUREKA!? Je n'ose y croire...

Les 2 tests (avec option "header" coché ou pas) fonctionnent parfaitement sur n'importe quelle adresse e-mail.

Je vais donc réinstaller (demain matin car là je suis trop occupé) en premier lieu le plugin "email notification" et reviens vers toi si besoin.

Merci BEAUCOUP Osku, vraiment...

Hors ligne

#46 2012-02-23 04:42:08

bebr
Membre
Lieu : Roquefort-Les-Pins
Inscription : 2007-06-18
Site Web

Re : Pb messagerie ?

Comme promis, je donne des nouvelles.

Tout est rentré dans l'ordre.
J'ai réinstallé les plugins "SubscribeToComment", EmailNotification" et "ContactMe", je les ai testé : RAS !

Merci Osku.

(PS : pour la petite anecdote, et parce que j'aime bien comprendre et apprendre de mes erreurs ; je ne sais toujours pas ce qui s'est passé sur mon blog puisque du jour au lendemain cette fonction de courriel n'a plus fonctionné sans que je n'opère la moindre modif dans ce fichier "config.php". Le rajout des lignes "function_mail" n'a été faite qu'en réponse à l'aide sollicitée ici...)

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map