Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2012-07-15 20:01:49

SebastienP
Membre
Inscription : 2012-07-15

Dotclear incompatible PHP 5.4.5 (last versions)

Bonjour à tous,

Je crois avoir le même problème que cet utilisateur-là, qui a posté une discussion à cet endroit, dans le forum (partie Multilingual) :

http://forum.dotclear.org/viewtopic.php?id=46189

Je me permets d'activer cette discussion dans la partie francophone, dans l'espoir d'obtenir une réponse.

Avez-vous une solution ? Comment expliquer que la solution de l'utilisateur en question n'est pas fonctionnelle chez moi ?

Cet autre post me semble aussi intéressant, et relève peut-être de la même erreur, non ?
http://forum.dotclear.org/viewtopic.php?id=45935

Dans tous les cas, je pense qu'il serait bon de modifier la documentation d'installation. En effet, la mention PHP 5 ou supérieur est erronée. Est-il possible de connaitre la dernière version supportée ?

Merci d'avance pour votre aide !

PS : Dotclear en dernière verison à ce jour.

Dernière modification par SebastienP (2012-08-03 13:39:17)

Hors ligne

#2 2012-07-16 11:37:59

geceo
Membre
Lieu : Cesson Sévigné
Inscription : 2008-05-10
Site Web

Re : Dotclear incompatible PHP 5.4.5 (last versions)

Bonjour,

Je pense que c'est lié à un changement dans le comportement de PHP depuis la version 5.3 :

http://www.php.net/manual/fr/language.r … s.pass.php

A partir de PHP 5.3.0, vous devriez recevoir une alerte disant que "Call-time pass-by-reference" est obsolète, lorsque vous utilisez un & dans foo(&$a);.

Donc il faudrait corriger tous les appels qui ont un "&" devant le nom de la variable passée en paramètre, afin de ne pas avoir cette alerte. Si ça provient d'une extension, il faudrait prévenir l'auteur pour qu'il mette à jour son code.

Grégoire

Hors ligne

#3 2012-07-21 07:59:29

SebastienP
Membre
Inscription : 2012-07-15

Re : Dotclear incompatible PHP 5.4.5 (last versions)

Merci pour la réponse geceo !

Cela ne provient pas d'une extension.
Voici la page incriminée :   /plugins/widgets/index.php (ligne 327).

Dès lors, dois-je :

* adapter le code de dotclear, pour supporter les dernières version de PHP (au risque que l'automatic update de dotclear rende mes corrections éphémères) ?
* utiliser une version antérieure de PHP et du coup, rendre mon serveur vulnérable ? D'autant que les vulnérabilités PHP sont particulièrement utilisées...

Et dernière question : qui d'autre a remarqué ce problème ? S'agit-il d'un autre problème, lié à mon installation ?

Qu'en pensez-vous ?

Hors ligne

#4 2012-08-03 13:40:05

SebastienP
Membre
Inscription : 2012-07-15

Re : Dotclear incompatible PHP 5.4.5 (last versions)

Quelle est la dernière version de PHP supportée par dotclear ?
Est-il possible de le préciser clairement dans la documentation ?

Hors ligne

#5 2012-08-06 08:25:28

SebastienP
Membre
Inscription : 2012-07-15

Re : Dotclear incompatible PHP 5.4.5 (last versions)

J'ai trouvé un lien (FAQ DotClear) qui indique la version PHP 5.3 maximum...

http://fr.dotclear.org/documentation/2.0/faq

Quelle est la roadmap ? Est-ce qu'une modification du code est prévue, de façon à supporter les dernières versions ?

Hors ligne

#6 2012-08-06 08:47:41

Dsls
Modérateur couteau-suisse
Inscription : 2004-11-18
Site Web

Re : Dotclear incompatible PHP 5.4.5 (last versions)

Bonjour,

Il s'agit d'un petit oubli dans le support de PHP>=5.3. Le fait que ça n'ait pas râlé déjà en PHP 5.3 est mystérieux.

En tout état de cause, une release mineure qui sortira sous peu rectifiera ce problème.


Dyslexics have more fnu!

Hors ligne

#7 2012-11-29 11:52:12

gary73
Membre
Lieu : Savoie,Maurienne
Inscription : 2007-02-26
Site Web

Re : Dotclear incompatible PHP 5.4.5 (last versions)

essai de passage sous php 5.4 ce jour chez 1&1,ça ne marche pas...donc retour sous 5.2 ok,mais tous les serveurs vont passer sous 5.4 au mois de mars...un correctif en vue ?
bonne journée à tous

Hors ligne

#8 2012-11-29 12:00:13

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : Dotclear incompatible PHP 5.4.5 (last versions)

Bonjour,

C'est un peu court ce que tu dis, gary73...
Qu'est-ce qui ne marche pas ? Précisément.
Quelle version de dotclear ?
La totalité des plugins additionnels sont à jour ?
Le thème par défaut est-il lui aussi à jour ?

Merci d'étayer un peu.

Hors ligne

#9 2012-11-29 13:28:45

gary73
Membre
Lieu : Savoie,Maurienne
Inscription : 2007-02-26
Site Web

Re : Dotclear incompatible PHP 5.4.5 (last versions)

bonjour,
version 2.4.4
plugins à jour,thème par défaut utilisé blowup
si l'on passe à php 5.4 sur l'interface de 1&1,on n'a plus accès ni au blog,ni à l'espace d'admin !

Dernière modification par gary73 (2012-11-29 13:33:30)

Hors ligne

#10 2012-11-29 14:08:55

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : Dotclear incompatible PHP 5.4.5 (last versions)

Bonjour,

Sans message d'erreur ? Tu obtiens une page blanche ? Autre ?
Bref, des détails car c'est toujours un peu léger...

Merci.

Hors ligne

#11 2012-11-29 14:21:22

gary73
Membre
Lieu : Savoie,Maurienne
Inscription : 2007-02-26
Site Web

Re : Dotclear incompatible PHP 5.4.5 (last versions)

ben zut,j'ai refait l'essai de mettre sous 5.4,et maintenant...ça fonctionne !
je reviens vers vous dès que le message d'erreur se reproduit...ou non ;-)
peut-être un petit couac chez l'hebergeur...
merci quand même
(en gros c'était une page de dc qui me disait ne pas trouver le jenesaisplusquoi )

Hors ligne

#12 2012-11-29 14:32:45

gary73
Membre
Lieu : Savoie,Maurienne
Inscription : 2007-02-26
Site Web

Re : Dotclear incompatible PHP 5.4.5 (last versions)

ayet


Dotclear
Connexion à la base de données impossible

Cela signifie soit que les informations d'identifiant ou de mot de passe de votre fichier config.php sont incorrects, soit que nous ne pouvons pas contacter le serveur de base de données à l'adresse "db1572.1and1.fr". Cela peut vouloir dire que le serveur en question est éteint.

    Êtes-vous sûr que l'identifiant et le mot de passe sont corrects ?
    Êtes-vous sûr d'avoir entré le bon nom de serveur ?
    Êtes-vous sûr que le serveur fonctionne ?

S vous n'êtes pas sûr de la signification de ces termes, vous devriez probablement contacter votre hébergeur. Si vous avez besoin d'une aide supplémentaire, vous pouvez vous rendre sur le forum d'entraide Dotclear.

Hors ligne

#13 2012-11-29 16:39:44

Lomalarch
Responsable du photocopieur
Lieu : Colombes (92)
Inscription : 2006-05-02
Site Web

Re : Dotclear incompatible PHP 5.4.5 (last versions)

Donc ÇA, ça n’est pas directement un problème avec Dotclear, mais avec le serveur de base de données de 1and1 qui, lui, a peut-être un souci avec le « branchement » en mode php 5.4.

Que dit le support 1and1 à ce sujet ?


RTFM attitude : https://fr.dotclear.org/documentation/2.0
Le chantier tips, tutos et astuces : http://tips.dotaddict.org/
Rien nulle part??? une petite recherche sul’ forum, alors?: https://forum.dotclear.org/search.php ?

Hors ligne

#14 2012-11-29 17:03:54

gary73
Membre
Lieu : Savoie,Maurienne
Inscription : 2007-02-26
Site Web

Re : Dotclear incompatible PHP 5.4.5 (last versions)

j'ai envoyé un mail à l'assistance,je vous transmet la réponse quand je l'aurai
bonne soirée à tous

Hors ligne

#15 2012-11-29 20:48:30

Welsh
Membre
Inscription : 2011-12-28

Re : Dotclear incompatible PHP 5.4.5 (last versions)

Je confirme :
- accès aux bases via l'admin 1&1
- message d'erreur sur MultiTags
- autres messages d'erreurs sur un autre produit que DC (PhpMySport pour ceux que cela intéresse).

Hors ligne

#16 2012-11-29 20:55:58

Welsh
Membre
Inscription : 2011-12-28

Re : Dotclear incompatible PHP 5.4.5 (last versions)

En complément le message sur MultiTags :
Warning: Parameter 1 to behaviorsMultiTag::templateBeforeBlock() expected to be a reference, value given in /(...)/dotclear/inc/core/class.dc.core.php on line 317

Hors ligne

#17 2012-11-29 21:12:29

Welsh
Membre
Inscription : 2011-12-28

Re : Dotclear incompatible PHP 5.4.5 (last versions)

Méthode utilisée :
- suppression de l'utilisation du cache pour les templates (DC)
- activation de la version 5.4 chez 1&1
- validation de cette version par le non fonctionnement de PhpMySports (vous m'avez suivi ?)
- changement de thème du blog pour vider les caches
- affichage de page

-> Tout semble bon sauf MultiTag uniquement sur un thème dérivé de Ductile. Sur un thème BlowUp par exemple pas de message d'erreurs.

Hors ligne

#18 2012-11-30 10:54:10

Lomalarch
Responsable du photocopieur
Lieu : Colombes (92)
Inscription : 2006-05-02
Site Web

Re : Dotclear incompatible PHP 5.4.5 (last versions)

MultiTags, effectivement, n’est pas compatible avec PHP >= 5.3…


RTFM attitude : https://fr.dotclear.org/documentation/2.0
Le chantier tips, tutos et astuces : http://tips.dotaddict.org/
Rien nulle part??? une petite recherche sul’ forum, alors?: https://forum.dotclear.org/search.php ?

Hors ligne

#19 2012-11-30 11:12:28

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : Dotclear incompatible PHP 5.4.5 (last versions)

Bonjour,

Testé la méthode de Welsh en passant par une activation de php5.4.9 via le .htaccess et c'est niet : impossible de contacter la bdd...

Hors ligne

#20 2012-11-30 11:30:45

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : Dotclear incompatible PHP 5.4.5 (last versions)

Bonjour,

Si vous avez une bdd chez 1&1 qui a un espace de stockage de 100Mo, le php5.4 déconne, si par contre c'est de 1Go que vous disposez, ça marche sans pb...
Me demandez pas pourquoi, je me borne à constater.
Reste maintenant à les faire bouger...

Hors ligne

#21 2012-11-30 12:48:36

Welsh
Membre
Inscription : 2011-12-28

Re : Dotclear incompatible PHP 5.4.5 (last versions)

Hello

Un petit complément. J'avais un souci similaire sur PhpMySport.
Dans la mesure où il m'indiquait la ligne de code en erreur, j'ai regardé de plus près. Cela touchait une ligne avec @mysql_connect().
En enlevant @ devant la fonction (pour avoir les messages d'erreurs), j'ai eu alors le message qui m'indiquait qu'il fallait renouveler le mot de passe de connexion à la base. Ok le message faisait référence à une base MySql4 alors qu'elle est en 5.
Ca ne coûte pas cher. J'ai essayé et ça fonctionne. Pour mon installation de PhpMySport...

Mais mon petit doigt me souffle que cela pourrait fonctionner pour vous...

Le renouvellement de mot de passe : par l'interface d'administration 1&1. Quelques minutes d'attente et hop !

Bon courage.

Hors ligne

#22 2012-11-30 12:49:44

Welsh
Membre
Inscription : 2011-12-28

Re : Dotclear incompatible PHP 5.4.5 (last versions)

Lomalarch a écrit :

MultiTags, effectivement, n’est pas compatible avec PHP >= 5.3…

Tant pis. Je m'en passerais pour le moment et j'essaierais de voir (si j'ai un peu de temps) si c'est compliqué à rendre Php v5.4 compliant.

Hors ligne

#23 2012-11-30 19:13:18

gary73
Membre
Lieu : Savoie,Maurienne
Inscription : 2007-02-26
Site Web

Re : Dotclear incompatible PHP 5.4.5 (last versions)

la réponse de 1&1

"Nous faisons suite à votre demande d'informations concernant votre site internet et sa compatibilité suite à la migration vers PHP 5.4.9.

Nous vous informons qu'il existe effectivement un incident au niveau de PHP concernant la connexion à une base de données MySQL5.

Un ticket est ouvert auprès de nos développeurs qui vont faire le nécessaire pour le résoudre très vite.

La solution actuelle consiste en redéfinir le mot de passe relatif à votre base de données, avec celui déjà existant.
   
Nous restons disponibles pour de plus amples informations.

Nous vous remercions de l'intérêt porté envers les produits 1&1 Internet.

Cordialement,
Fabien  "

bon,il est urgent....d'attendre !
bonne soirée à tous

Hors ligne

#24 2012-11-30 21:44:03

Welsh
Membre
Inscription : 2011-12-28

Re : Dotclear incompatible PHP 5.4.5 (last versions)

D'où l'explication du commentaire #21.

Hors ligne

#25 2012-12-14 17:03:10

pacha35
Membre
Inscription : 2011-04-06

Re : Dotclear incompatible PHP 5.4.5 (last versions)

Bonjour,

je relance ce sujet car je vient d'installer dotclear 2.4.4 dans wamp dernière version (avec une version PHP 5.4.3).
Quand je veux lancer dans le tableau de bord le module "widget presentation" , j'ai un retour d'erreur :
"Fatal error: Call-time pass-by-reference has been removed in C:\wamp\www\dotclear\plugins\widgets\index.php on line 327" indiqué plus haut dans ce sujet.
Je n'ai donc pas accès au paramétrage du sidebar

Je n'ai chargé aucun widget supplémentaire.

J'ai également un message d'erreur quand je crée un nouveau billet, (Notice: Array to string conversion in C:\wamp\www\dotclear\plugins\tags\_admin.php on line 106) mais le formulaire reste actif et fonctionne.

Quelqu'un a-t-il une idée sur une éventuelle correction?

Merci d'avance

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map