Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2015-11-10 13:17:43

pepere
Membre
Inscription : 2015-11-10

Problème d'intégraton de font-awesome

Bonjour à tous,


après avoir fait une recherche sur le forum, je ne trouve pas de réponse à mon problème.
Ce sujet s'y rapporte mais ne correspond pas tout à fait: http://forum.dotclear.org/viewtopic.php?id=47550
Aussi, j'ai fait de nombreuses recherches sur le net pour trouver une solution... en vain.


Alors, voilà, je cherche à intégrer "font-awesome" à mon design mais je n'y parviens pas.
A la place, j'ai de jolis petits carrés (très moche, en fait) avec le code de l’icône inscrit en-dedans.


Comme vous pourrez le voir, coté html du site, pas de problème pour les intégrer.
Par contre, coté blog, installé dans un sous-dossier, les icônes sont remplacées par le carré.


J'ai testé toutes les possibilités à propos des url des fonts (absolues, relatives,...).
J'ai tenté de les intégrer au départ du cdn du développeur, même problème.
J'ai aussi essayé de rajouter un htaccess avec quelques lignes dénichées sur la toile, sans succès.


Ne parvenant pas à trouver de solution, j'en appelle donc à vos bons soins afin de m'aider à régler ce problème.


Voici l'adresse du site (encore en phase de remplissage): http://xpert-web.be/blog/


Pour info, le serveur est un Kimsufi de chez OVH et le problème semble se produire quel que soit le navigateur.


D'avance merci pour l'aide apportée ;)

Dernière modification par pepere (2015-11-13 13:32:49)

Hors ligne

#2 2015-11-10 14:01:14

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : Problème d'intégraton de font-awesome

Bonjour

Pour commencer et en fait ce n'est pas négociable, corriger les erreurs de code. Par exemple, tu fermes deux fois le <head> et non, ça ne peut pas aller bien ensuite. Idem pour <body> et <html>.

Un exemple de billet avec des carrés ?

Hors ligne

#3 2015-11-10 15:20:34

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Problème d'intégraton de font-awesome

Les polices de caractères doivent être servies depuis strictement le même domaine que la feuille de style qui les appelle, est-ce bien le cas chez toi ?

De mon côté, travaillant avec plusieurs sous-domaines et blogs servis par une seule installation de Dotclear et le même thème, j'avais ce problème et même l'instruction ajoutée dans le .htaccess ne fonctionnait pas. J'ai donc résolu le problème en liant directement depuis le thème la CSS de Font Awesome sur un CDN ;)

<link href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.4.0/css/font-awesome.min.css" rel="stylesheet" type="text/css">

Là, la CSS appelle des polices qui sont dans le même domaine, et les petits carrés ont disparu :D

Hors ligne

#4 2015-11-10 15:37:09

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Problème d'intégraton de font-awesome

PS : sinon chez toi font-awesome.min.css est dans le répertoire /blog/themes/XpertWeb/ et elle appelle les polices de caractère ainsi :

src:url('fonts/fontawesome-webfont.eot?#iefix&v=4.4.0') par exemple

Y a -t-il donc un répertoire fonts dans /blog/themes/XpertWeb/ avec les polices à l'intérieur ?

Hors ligne

#5 2015-11-10 18:29:36

Dsls
Modérateur couteau-suisse
Inscription : 2004-11-18
Site Web

Re : Problème d'intégraton de font-awesome

De ce que je vois, c'est la ligne 203 de ton style.css qui pose problème, notamment le font Genericons qui n'est pas ignoré chez moi.

:after, :before {vertical-align:middle;/* font: normal 100%/1 'Genericons'; */display: inline-block;-webkit-font-smoothing: antialiased;-moz-osx-font-smoothing: grayscale;}

Dyslexics have more fnu!

Hors ligne

#6 2015-11-13 13:32:11

pepere
Membre
Inscription : 2015-11-10

Re : Problème d'intégraton de font-awesome

Merci Pierrevg, j'ai corrigé ces erreurs flagrantes ;)

Merci Philipe, j'avais déjà exploré toutes ces pistes... en vain ;)

Merci Dsls, t'es une bête !
Je n'aurais jamais été penser qu'il y aurait pu avoir un "conflit" de ce genre dans le css.
En effet, le genericons était posé par défaut sur tous les :before et :after.
En stipulant uniquement les endroits où il était nécessaire, le problème s'est réglé rapidement.
Il faut dire que je suis parti d'un thème existant qui les utilisait.

Un grand merci à tous pour votre aide !!

Bon week-end ;)

Hors ligne

#7 2015-11-13 13:59:37

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : Problème d'intégraton de font-awesome

Il reste plein d'erreurs et une notice qui ne doivent pas être normale.
Tant que tu es dans la dynamique de corriger tes erreurs, n'abandonne pas en si bon chemin ;)

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map