Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2016-05-10 15:38:40

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Theme Berlin - turn off "read more"

Hi

How can I turn off the function "read more" in main view of the blog. Only the first post has the whole text, older have only some lines with the "read more" at the end.


Salutations / best regards
Tin

Hors ligne

#2 2016-05-10 15:44:15

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Theme Berlin - turn off "read more"

Hello

The "read more" link appears in posts lists (such as categories) when the excerpt field is not empty.

Hors ligne

#3 2016-05-10 15:55:45

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : Theme Berlin - turn off "read more"

Hmm - I didn't edit something in the excerpt window in the post - it is empty. But it the main view older posts have the "read more" button after some text lines.


Salutations / best regards
Tin

Hors ligne

#4 2016-05-10 16:09:52

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Theme Berlin - turn off "read more"

OK. Sorry I do not know Berlin that well ;)

I checked and saw that it relies on currywurst template and that layout.html (which Berlin inherits) has a LoopPosition template tag for posts after the very first one. In that loop, second and following posts are treated differently from first.

If you want to modify this behaviour, you will have to make your own copy of Berlin (as a child theme or as an independant one) to be able to add your tweaked version of layout.html (or home.html only). Do not hesitate to ask if you have doubts about how to do it.

Hors ligne

#5 2016-05-10 16:15:29

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : Theme Berlin - turn off "read more"

Ok. But I don't see any layout.html or home.html file in the template folder "berlin".


Salutations / best regards
Tin

Hors ligne

#6 2016-05-10 16:25:59

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Theme Berlin - turn off "read more"

Berlin herits from currywurst template set, which means that any template file it does not have in its tpl folder is taken in the currywurst template set.

If you want a different home.html, just copy it from currywurst set into Berlins's tpl folder, and make your changes there. When home.html is called (ie when you visit your home page), the new file will be used instead of the one in the template set.

Hors ligne

#7 2016-05-10 16:31:51

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : Theme Berlin - turn off "read more"

Ok. But where is "currywurst template"? Sorry.


Salutations / best regards
Tin

Hors ligne

#8 2016-05-10 16:40:34

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Theme Berlin - turn off "read more"

No need to apologise, it is a bit confusing if you are new to dotclear and template inheritance, but you will discover that it is a very powerful system ;)

The default template sets are located in /dotclear/inc/public/default-templates/

Hors ligne

#9 2016-05-10 17:07:32

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : Theme Berlin - turn off "read more"

Ok thanks - and found! So I changed _layout.html and stored it and home.html in  Berlin template folder - and it works now as I wished.

Great!


Salutations / best regards
Tin

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map