Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2016-05-17 11:12:24

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Problem with pictures

Hi

Found two problems with uploaded pictures. The upload is ok - the picture is in the folder.

But
1. The thumbnail and small or square pictures are not really pictures - so picture is destroyed - a "picture" file is written in the folder, but unusable.

2. The editor can't insert such a picture in a post - error 403 - only the original picture can be inserted.

Problem with both editors.

Dernière modification par Tin (2016-05-17 11:26:14)


Salutations / best regards
Tin

Hors ligne

#2 2016-05-18 05:55:32

ben_griffith
Membre
Lieu : Wiltshire
Inscription : 2009-09-28

Re : Problem with pictures

Hi Tin
I was able to reproduce the same issue in the past when I tested the Media Manager. Explanation and solution can be found here.
https://forum.dotclear.org/viewtopic.php?id=46035


I Dotclear.

Hors ligne

#3 2016-05-18 07:48:53

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : Problem with pictures

Hi

Thanks for your answer.

But the information in the linked thread doesn't help - there is not the question about up- and download the pictures with a dot at the beginning of the filename with an FTP client. The problem is dotclear internal when these smaller pictures should be inserted in a post - so they can't be read - there is an error 403. What was the idea to give the filenames this dot?

For the moment the insert of a smaller picture is unusable.


Salutations / best regards
Tin

Hors ligne

#4 2016-05-18 08:23:47

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Problem with pictures

Tin a écrit :

The problem is dotclear internal when these smaller pictures should be inserted in a post - so they can't be read - there is an error 403. What was the idea to give the filenames this dot?

For the moment the insert of a smaller picture is unusable.

The insert works for a lot of people ;) Maybe something is not usual in your server's configuration.

The 403 error code comes from your server, and could mean that the rights on public files and folders are not sufficient. Could you please check that first ?

Then, if it is not the reason, are the thumbnail images generated at all (ie do you see them your ftp program) ?

Hors ligne

#5 2016-05-18 09:00:19

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : Problem with pictures

Hi

I set the picture folder and all pictures in this folder as test to 777 - but still error 403.
And all pictures are in the folder - the resized one with the point at the beginning of the filename.

And it's dotclear which has created the picture folder - so I can't really see why we should have here a permission problem here.


Salutations / best regards
Tin

Hors ligne

#6 2016-05-18 09:27:06

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Problem with pictures

If it not a question of rights, it might be that your hosting provider has an Apache directive stopping all files beginning by a dot to be publicly accessible. This is not a standard configuration.

Try adding this in your site's .htaccess file

<FilesMatch "^\.">
    Order allow,deny
    Allow from all
</FilesMatch>
<FilesMatch "^\.ht">
    Order allow,deny
    Deny from all
</FilesMatch>

Hors ligne

#7 2016-05-18 09:49:20

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : Problem with pictures

Bingo! C'était exactement ça.
Thank you.


Salutations / best regards
Tin

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map