Dotclear

Vous n'êtes pas identifié(e).

Annonce

#176 2016-07-18 17:30:46

script
Membre
Inscription : 2009-10-01
Site Web

Re : [Extension Muppet] support

Bonjour,

Je rencontre un petit bug en ce moment. J'ai installé le plugin Muppet récemment. C'était la toute première fois, pour un nouveau blog (pas celui dans mon profil).

Muppet fonctionne parfaitement et c'est exactement l'outil que je cherchais. Je remercie ++ son créateur, Osku.

Cependant, lorsque Muppet est là, même si désactivé dasn la liste des Plugins, aucune image (screenshot.jpg) ne s'affiche dans le premier onglet de l'éditeur de thèmes. Dans le 2e onglet, celui où on voit les thèmes disponibles sur Dotaddict, tous les screenshots s'affichent. Et les captures d'écran des thèmes installés reviennent lorsque je supprime Muppet et vide toutes les caches.

J'ai la dernière version de Dotclear, 2.9.1, et une installation en multiblogs, Php 5.7,  JQ 2.2 (essayé 1.4 ou 1.11 mais ça ne change rien). Tous mes plugins sont à jour, je crois. En fait, j'ai "tout" essayé pour régler le problème depuis 2 semaines et je ne trouve rien. J'ai supprimé et réinstallé nombre de fois... toujours pareil.

J'ai vraiment besoin de ce plugin et surout besoin d'aide, s'il vous plait.

Merci d'avance.

Hors ligne

#177 2016-07-18 17:46:35

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : [Extension Muppet] support

Pas de pb en php5.5, 5.6 et 7.0.8 (chez 1&1).
Le premier onglet de Apparence du blog -> "Thèmes installés", on est bien d'accord ?

Dernière modification par pierrevg (2016-07-18 17:47:55)

Hors ligne

#178 2016-07-18 18:03:55

script
Membre
Inscription : 2009-10-01
Site Web

Re : [Extension Muppet] support

Merci pour votre réponse.

Oui, c'est bien dans Apparence du Blog --> Thèmes installés.

Et c'est le même bug pour chacun des Blogs de mon installation, qui partagent les mêmes thèmes.

Autre détail : l'utilisateur est "superadmin" [juste moi].

Question : vous avez installé Muppet  pour la première fois sur DC v.2.9.1, vous aussi ?

Je crois que ceux qui avaient Muppet avant l'une des plus récentes versions de DC, j'ignore laquelle, n'ont pas ce bug, sinon, ça se saurait ! [intuition]

P. S. : Je suis en php7 et non en 5.7. Désolée pour la coquille plus haut.

Dernière modification par script (2016-07-18 18:05:57)

Hors ligne

#179 2016-07-18 21:54:04

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : [Extension Muppet] support

Aucune idée de quand j'ai installé Muppet (1.4.0RC). Je suis aussi logué en superadmin.

script a écrit :

Je crois que ceux qui avaient Muppet avant l'une des plus récentes versions de DC, j'ignore laquelle, n'ont pas ce bug, sinon, ça se saurait ! [intuition]

C'est du grand nawak cette phrase. Des suppositions qui reposent sur du rien, c'est quoi l'intérêt ?

Sinon ce n'est un bug très bloquant : la visualisation du screenshot des thèmes installés, c'est franchement pas primordial...

Hors ligne

#180 2016-07-19 10:58:16

script
Membre
Inscription : 2009-10-01
Site Web

Re : [Extension Muppet] support

J'ai réinstallé Muppet. Le problème signalé au #176 est toujours là. Et :

1) Dans la sidebar du Blog, côté public, la présentation des widgets "Liste des Catégories" et "Liens de souscription" a changé pour tout le blog = décalage du bloc, et police de taille et famille différentes pour le titre de ces deux widgets seulement.

2) Côté admin de Muppet, quand je clique sur « Afficher les filtres et options d'affichage » du type créé, j'ai bien le menu et je peux choisir des filtres, mais impossible de les enregistrer. Lorsque j'appuie sur le bouton  « Appliquer », ce message s'affiche : « Le plugin que vous essayez d'atteindre n'existe pas ou n'a pas de page d'administration. »

Hors ligne

#181 2016-07-19 11:09:45

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : [Extension Muppet] support

1/ une url ? celle de ton profil : rien de visible depuis chez moi.
Et de toute façon, Muppet n'agit pas sur les widgets de dc de base (ni sur aucun autre).

Si tu as la possibilité de passer à un php anté 7, ça donne quoi ? Tes bugs sont toujours présents ?

Hors ligne

#182 2016-07-19 11:36:32

script
Membre
Inscription : 2009-10-01
Site Web

Re : [Extension Muppet] support

Je n'utilise pas Muppet sur le Blog inscrit à mon profil, mais sur un nouveau Blog en développement.

J'ai désactivé et supprimé Muppet, vidé les caches, et le Blog a repris son apparence "normale". Je vais donc le réinstaller dans quelques minutes, pour vous montrer. C'est ici :  http://www.almanachgourmand.com

Hors ligne

#183 2016-07-19 12:03:12

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : [Extension Muppet] support

Tu es sûre que ton installation est bonne ? Les widgets syndication et catégories ne disposent pas de la class widget, c'est pour ça que la typo n'est pas conforme.
Tu as effectué comment ton installation ? Est-elle nativement en 2.9.1 ou est-ce une mise à jour ? Auquel cas, comment as-tu effectué cette mise à jour ?

Perso, je ferai une nouvelle mise à jour en manuel (via FTP), depuis une archive neuve de dc et ferai gaffe à bien tout mettre à jour (plugins et thèmes).

A noter que j'ai un écran en 1280 et que j'obtiens un ascenseur horizontal avec ton url.

Hors ligne

#184 2016-07-19 12:37:13

script
Membre
Inscription : 2009-10-01
Site Web

Re : [Extension Muppet] support

"Tu es sûre que ton installation est bonne ?" Je n'ai pas vérifié récemment. Concernant les 2 widgets, la class widget était là avant Muppet et elle "reviendra" dès que je l'aurai supprimé, comme d'habitude.

Mon Dotclear a été mis à jour plusieurs fois, et j'en prends bien soin. Je fais les maj automatiques dès qu'elles sont disponibles, et celle vers 2.9.1 aussi. Je me souviens avoir utilisé fakemeUp parce que ça coinçait, je ne me souviens plus dans quels fichiers.

Donc, je vais :
1) vérifier mon installation avec le plugin kifaitça (oublié son nom, mais je le retrouverai);
2) télécharger un 2.9.1 tout neuf par FTP;
3) m'assurer que plugons et thèmes sont à jour.

Un ascenseur horizontal en 1280 ? Pour l'url d'almanach ? Possible. Je suis loin d'avoir terminé le design. Si c'est sur mon bog principal (profil), c'est plus grave !

Hors ligne

#185 2016-07-19 16:56:33

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : [Extension Muppet] support

Pour les widgets, c'est normal, le plugin n'est pas à jour de ce point de vue. Ajoute dans le champs class le mot widget et ça sera ok pour ton thème.

Hors ligne

#186 2016-07-19 17:08:11

script
Membre
Inscription : 2009-10-01
Site Web

Re : [Extension Muppet] support

Rien fait avec le plugin SysInfo car rien compris.

Réussi une mise à jour manuelle de 2.9.1 [avec FileZilla]  en suivant la doc point par point.

Vérifié les plugins : n'ai gardé que ceux dont j'ai besoin. Ils sont tous à jour (selon la liste sur dotaddict). 10 au total : stopForumSpam 0.2, sitemaps 1.2, relatedPages 1.6.2, emailNotification 1.1, myFavicon 0.8.1, my meta 0.5.2, magnifie-popup 0.3, contactMe 1.6.1, citations 1.8, bigfoot 0.3.

Vérifié les thèmes : n'ai gardé que celui en usage actuellement sur chacun de mes blogs, et ils sont à jour [2 thèmes enfants de Berlin indépendants l'un de l'autre] et BlowUp sur un autre blog. Recopié un Berlin tout neuf dans mon répertoire Thèmes.

Ensuite, j'ai vidé le cache des templates et du navigateur, puis installé Muppet : les mêmes bugs sont là. Les 2 widgets déformés sont visibles côté public via l'url du billet #182, tant que je n'aurai pas supprimé le plugin ni trouvé le remède à ces bugs.

J'ai sélectionné Berlin comme thème actif. Résultat = les 2 widgets s'affichaient bizarrement là aussi, avec des gros titres en bleu et pas de class widget. J'ai donc remis mon thème enfant.

Par ailleurs, l'éditeur de billets de Muppet fonctionne (dcLegacy et xhtml).  Voici un billet  test créé avec Muppet (http://www.almanachgourmand.com/coco/un … our-tester).

Mais dès que j'essaie d'appliquer des filtres, j'ai le message pré cité sous Système>>Plugin introuvable.

Y a-t-il autre chose que je puisse faire ?

Hors ligne

#187 2016-07-19 17:14:58

script
Membre
Inscription : 2009-10-01
Site Web

Re : [Extension Muppet] support

Oups ! En allant sur Widgets de présentation pour renseigner le champ class avec widget, je vois que Muppet m'a remplacé ces deux widgets de base par : Muppet>catégories et Muppet>souscription.
J'ai bien mis le mot widget là où il faut, et ça ne change rien.

Hors ligne

#188 2016-07-19 18:20:47

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : [Extension Muppet] support

Ligne 962 de style.css (mal foutu ton fichier css), tu ajoutes la class widget h2 aux autres class et ça devrait être bon pour ton pb de widget.
Pour le reste, je pense que le plugin n'est plus à jour, et/ou incompatible avec php7.

Hors ligne

#189 2016-07-19 19:26:24

script
Membre
Inscription : 2009-10-01
Site Web

Re : [Extension Muppet] support

Vous avez tout à fait le droit d'estimer que mon fichier css est « mal foutu », cependant j'en suis satisfaite. C'est une copie presque conforme de la feuille de style de Berlin (grand merci à Franck), et je ne l'ai modifiée que pour adapter les valeurs nécessaires au désign de ce Blog.  Je n'ai pas beaucoup touché aux  div pour les widgets qui se retrouvent dans les tpl, pour le moment, et ne le ferai pas si je ne rencontre pas de problèmes ou si j'en ai pas besoin. Mon blog est valide côté html et je n'ai pas de bugs majeurs hormis cette mauvaise expérience avec Muppet.

De plus cette feuille de style aussi « mal foutu » soit elle, je l'ai retravaillée afin qu'elle soit valide css3, et elle l'est ! Il me reste, comme mentionné ce matin, à bidouiller pas mal de choses dont les mediaqueries parce que ma résolution d'écran est de 1980, et que j'ai modifié quelques marges ici et là sans vérifier ce que ça donnait sur différentes tailles d'écran, plus petits. On ne peut pas tout faire en même temps.

Les titres de mes widgets dans la sidebar sont en h3 et ils sont ok. je ne vais pas les mettre en h2. Dans la sidebar, il y a déjà 2 div h2 et cela concerne des titres pour blognav [Blog menu] et blogextra [Extra menu], titres qui ne s'affichent pas sur le blog (voir lignes 210 et 226 du code source), le tpl "sidebar.html" est fait comme ça (voir dotclear/inc/public/default-templates/currywurst).

Pour la suite, j'ai supprimé Muppet une fois de plus et attendrai la prochaine mise à jour avant de le réinstaller. Bonsoir et merci.

Dernière modification par script (2016-07-19 19:33:55)

Hors ligne

#190 2016-07-19 20:35:05

pierrevg
Membre
Inscription : 2005-04-13
Site Web

Re : [Extension Muppet] support

C'est mal foutu en ce sens que les widgets embarquent une class widget et qu'il me semble plus simple de passer par elle.
Pour les plugins non mis à jour, ils ont un h2 pour titre et non un h3. C'est le pourquoi de l'ajout proposé (que vous n'avez pas testé mais c'est votre choix).
De rien et merci aussi ;)

Hors ligne

#191 2016-07-20 07:06:54

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : [Extension Muppet] support

script a écrit :

Vous avez tout à fait le droit d'estimer que mon fichier css est « mal foutu »...

Ne pas se froisser à cause du vocabulaire de pierrevg, il est malheureusement désagréable assez souvent mais aussi de bon conseil ;)

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map