Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2016-12-29 15:05:05

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

DB Error after upgrade

Hi

Just upgraded doclear to version 2.11.2.

In the admin panel everything seems to be ok - but when contacting the entry page of the blog I get

Dotclear
no such column: post_firstpub (1)
Something went wrong while loading template file for your blog.

Seems the the DB wasn't updated. So how to start the update process manually?

Thanks, tin


Salutations / best regards
Tin

Hors ligne

#2 2016-12-29 15:34:07

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : DB Error after upgrade

You should empty the template cache → Maintenance plugin.


Dotclear addicted since 2004

Hors ligne

#3 2016-12-29 15:40:58

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : DB Error after upgrade

Sorry, this doesn't help.


Salutations / best regards
Tin

Hors ligne

#4 2016-12-29 15:47:08

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : DB Error after upgrade

Could have a look inside your DB tables, specially the dc_post?

If yes, could you tell me if the post_firstpub field is present or not?


Dotclear addicted since 2004

Hors ligne

#5 2016-12-29 15:57:31

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : DB Error after upgrade

So post_firstpub is NOT present in dc_post - DB upgrade seems not do be finished....


Salutations / best regards
Tin

Hors ligne

#6 2016-12-29 17:06:03

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : DB Error after upgrade

What is the DB driver you use? mysqli, postgresql or sqlite ?


Dotclear addicted since 2004

Hors ligne

#7 2016-12-29 17:13:39

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : DB Error after upgrade

It's sqlite.


Salutations / best regards
Tin

Hors ligne

#8 2016-12-29 17:34:05

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : DB Error after upgrade

Tin a écrit :

It's sqlite.

Ok, I understand. The SQLite DB cannot be upgrade so you must install a fresh new version (with a new DB), export data from old DB and then import them in the new one.


Dotclear addicted since 2004

Hors ligne

#9 2016-12-29 18:45:18

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : DB Error after upgrade

But how to import old DB? There is no feature in the dashboard to do so.

Now back to version 2.10.2 - this one runs with old DB.

BTW do you have a How-To description to upgrade dotclear when using LiteSQL DB - seems quite puzzling.

Dernière modification par Tin (2016-12-29 19:22:11)


Salutations / best regards
Tin

Hors ligne

#10 2016-12-29 20:43:19

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : DB Error after upgrade

1. You backup your data and theme using Maintenance plugin

1.1 Download database of all blogs
1.2 Download active theme of current blog (and so for every other blog you have)

2. You backup your media folder using Media manager (on root folder choose Backup content of “Media manager”)

3. Install fresh new 2.11.2 Dotclear (for example in dotclear-new folder)

4. Using Theme manager install your saved theme(s)

5. Using Media manager upload the archive of media folder and then unzip it (you may also do it by FTP, as you whish)

6. Using Import/Export plugin import, Flat file import, upload the saved data (1.1) in the Multiple blogs section

Then verify your preferences and settings, you should have a fresh copy of your old installation.

If everything is ok, rename old dotclear folder to dotclear-old and the new one, dotclear-new to dotclear, assuming your old one was named dotclear.


Dotclear addicted since 2004

Hors ligne

#11 2016-12-30 21:03:43

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : DB Error after upgrade

Ok, thanks a lot for the list.
I just finished the upgrade and dotclear 2.11.2 seems to run w/o problems.
Well, some settings with plugins are lost with the new installation and are not included in the backups. For the future I think I have to change the DB...
BTW if you want to see the result :-)


Salutations / best regards
Tin

Hors ligne

#12 2016-12-30 21:18:33

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : DB Error after upgrade

Glad to see your blog online again!

Unfortunatly, learning german during 2 years only (long long time ago) is not enough for me to understand what you publish there ;-)

Anyway, could you identify which plugins have lost their settings? We should have a look to see if it may be fixed for a further release?


Dotclear addicted since 2004

Hors ligne

#13 2016-12-31 09:03:51

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : DB Error after upgrade

The settings of the plugins "ContactMe", "External Links" and "Gravatar" were lost and had to be edited again.

And not everything of your upgrade list above worked well:

1. The backed up and re-installed theme "berlin" (which I changed a little bit in the old version) didn't work correctly
2. I made a database backup of "all blogs" (but I have only one). After importing the backup the admin dashboard  had a CSS problem - the display was messed up. So I started again with DB backup in old version and imported this backup in the new one - here it worked perfectly

Some more questions:

- In CKEditor the spell checker seems not to be enabled. Any chance to do so? With the CKEditor Addon Plugin I couldn't enable it neither.

- The language file (locale de) for German seems to be not very up-to-date. Perhaps I can look into it as contribution for dotclear ;-)


Salutations / best regards
Tin

Hors ligne

#14 2016-12-31 09:50:19

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : DB Error after upgrade

Thanks Tin, I will have a look on all of this


Dotclear addicted since 2004

Hors ligne

#15 2016-12-31 16:31:56

Tomek
Moderator
Inscription : 2006-04-12
Site Web

Re : DB Error after upgrade

Tin a écrit :

- The language file (locale de) for German seems to be not very up-to-date. Perhaps I can look into it as contribution for dotclear ;-)

You're welcome! Check this page for more info: https://dotclear.org/translate

Hors ligne

#16 2016-12-31 19:50:33

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : DB Error after upgrade

Hmm - the German files in the folder you mentioned in the link above are quite old (2011). And the de files (text strings) doesn't reflect the recent version 2.10.2 of dotclear - I think.

So to have an actual translation it would be necessary to start from scratch - from the English (or French) files, right?


Salutations / best regards
Tin

Hors ligne

#17 2017-01-01 00:33:49

Tomek
Moderator
Inscription : 2006-04-12
Site Web

Re : DB Error after upgrade

Well, I can't tell. Maybe a good start would be to subscribe to the translators list and ask about this?

Hors ligne

#18 2017-01-02 12:24:01

nikrou
Membre
Inscription : 2007-10-02
Site Web

Re : DB Error after upgrade

Or you can checkout the whole project from bitbucket and you can find the actual translation for german :
https://bitbucket.org/dotclear/dotclear … at=default

If you need help or if it's too technical for you, don't hesitate to ask for help.


Je préfère être atteint de parkinson plutôt qu'alzheimer : je prefère renverser un peu de ma bière plutôt qu'oublier de la boire !

Présentez vos photos simplement avec Phyxo !

Hors ligne

#19 2017-01-02 18:50:19

Tin
Membre
Lieu : Suisse
Inscription : 2016-04-08
Site Web

Re : DB Error after upgrade

Ok, just updated de/public.po and sent a commit - let's see if this way and the technical configuration with Bitbucket is working ;-)


Salutations / best regards
Tin

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map