Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2018-11-13 05:32:57

ben_griffith
Membre
Lieu : Wiltshire
Inscription : 2009-09-28

[Solved] https and no images in New post and no comments

I'm on Linux meanwhile, and I have to save an entry first before I get the images shown. This is okay for me.

Recently, I have tried to use https but noticed that when I write a post, the images are not shown even after saving my post in Dotclear. They are on the website but not in the Dashboard -> Entry.
I hoped that changing the config admin url to https would do the trick, but no luck.

Do you know, what else I could change?

Dernière modification par ben_griffith (2018-11-14 05:06:13)


I Dotclear.

Hors ligne

#2 2018-11-13 06:07:15

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : [Solved] https and no images in New post and no comments

May be a CSP (content-security-policies) issue.

Check about:config, system section, csp_admin_img item and check if there is still a http://your-blog in the setting

You may also disable CSP: set csp_admin_on to false


Dotclear addicted since 2004

Hors ligne

#3 2018-11-14 04:34:00

ben_griffith
Membre
Lieu : Wiltshire
Inscription : 2009-09-28

Re : [Solved] https and no images in New post and no comments

Hello Franck.

Thanks for looking into it.

I understand csp_admin_img 'self' data: https://media.dotaddict.org blob: for the case you use the Media Manager. But I don't use it, I have always uploaded my pictures in my own directory. I tried it with http but no change.

I turned csp_admin_img off and it works now. Great.


Another issue I noticed this morning is that comments don't work.

I type a comment and send it. But there is no confirmation that "Your comment has been submitted ...". There is also no comment in the Dashboard.

[Update] Solved: In System -> Blogs there is a setting for Blog URL: I had to change it here to https too.

Dernière modification par ben_griffith (2018-11-14 05:05:48)


I Dotclear.

Hors ligne

#4 2018-11-14 06:12:53

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : [Solved] https and no images in New post and no comments

ben_griffith a écrit :


[Update] Solved: In System -> Blogs there is a setting for Blog URL: I had to change it here to https too.

Oh, I thought you have had initially change it before!

So everything is fine now \o/


Dotclear addicted since 2004

Hors ligne

#5 2018-11-15 05:26:00

ben_griffith
Membre
Lieu : Wiltshire
Inscription : 2009-09-28

Re : [Solved] https and no images in New post and no comments

I had never reason t look into that part in the last 9 years since I use Dotclear.

Yes, it works now. :-)


I Dotclear.

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map