Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2020-03-18 21:02:15

umitn
Membre
Inscription : 2020-03-18

[SOLVED] WYSIWYG (visual) Editor not working

Hello, I'm new on the forums, but I have used Dotclear on and off for about 1 year now.

I'm using version 2.16. A few months ago I had a visual editor for posting content, like a B, I, U for bold, italic and underline, and other buttons for Images, attachments, etc. But now I don't see that anymore, and in the settings I have "WYSIWYG Editor" checked but I still only get a plain editor where it tells me I can use Wiki or XHTML syntax. Last time I used Dotclear on my server I remember the visual editor working one day but then it disappeared the next day, so I switched to WordPress. Now I'm back and I still don't know how to enable the visual editor.

How do I get back the visual editor?

(One more question: How do I change the admin page theme? I see very nice themes on some old screenshots but I don't see a "change theme" for the admin/management pages)

Thanks so much

Dernière modification par umitn (2020-03-20 14:12:00)

Hors ligne

#2 2020-03-18 21:57:59

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : [SOLVED] WYSIWYG (visual) Editor not working

Hi,

It may help to empty the browser cache.

The admin pages don't have themes, only a dark/light switch (see your user preferences)


Dotclear addicted since 2004

Hors ligne

#3 2020-03-18 21:59:02

umitn
Membre
Inscription : 2020-03-18

Re : [SOLVED] WYSIWYG (visual) Editor not working

Franck a écrit :

Hi,

It may help to empty the browser cache.

The admin pages don't have themes, only a dark/light switch (see your user preferences)

OK. I will try that and get back to you.

Hors ligne

#4 2020-03-18 22:03:24

umitn
Membre
Inscription : 2020-03-18

Re : [SOLVED] WYSIWYG (visual) Editor not working

Hm. That didn't work.

BTW this is what I see, it's just a plain editor and not the visual editor despite the checkbox:
https://drive.google.com/file/d/1WfOGDw … sp=sharing
(yeah, I'm not sure what is going on with the right side either).

If it's relevant, I am using Firefox. The same thing happens on Chromium (not the sidebar, it's OK on chromium).

Hors ligne

#5 2020-03-18 23:09:52

umitn
Membre
Inscription : 2020-03-18

Re : [SOLVED] WYSIWYG (visual) Editor not working

Is there any information on this problem? I love the way Dotclear looks, especially many of the themes. Using it as an alternative to my Wordpress website would be excellent, it loads at least three times faster.

Dernière modification par umitn (2020-03-18 23:10:40)

Hors ligne

#6 2020-03-19 05:52:39

ben_griffith
Membre
Lieu : Wiltshire
Inscription : 2009-09-28

Re : [SOLVED] WYSIWYG (visual) Editor not working

Hello umitn

please respect that people in Europe sleep at 22:00. This is a forum where people help each other. We are not paid for this.
Thanks!

Now back to your issue:

There is definitely something not right with the settings:
Top right side:
1. My Preferences - My Options, scroll down to Edition and set:
Preferred editor for xhtml: DCLegacyEditor
Preferred editor for wiki:DCLegacyEditor
Preferred format: XHTML

In left sidebar:
2. In Users -> YOURNAME, check Preferred format: XHTML

3. In about:config, go to
dcckeditor and set active: "yes"
dclegacyeditor and set active: "yes"

4. In Plugins Management, make sure that you have the
dcCKEditor, dcLegacy and dcLegacyEditor installed an active.

If these steps don't work, then back up your blog and reinstall Dotclear 2.16from scratch. This has always worked.


I Dotclear.

Hors ligne

#7 2020-03-19 11:11:05

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : [SOLVED] WYSIWYG (visual) Editor not working

Hello. Often, when visual editors don't work (particularly dcCkEditor) it is necessary to check if the value of DC_ADMIN_URL in dotclear/inc/config.php is exactly the same as your admin URL

Hors ligne

#8 2020-03-19 20:28:34

umitn
Membre
Inscription : 2020-03-18

Re : [SOLVED] WYSIWYG (visual) Editor not working

Hi ben_griffith and Philippe. Sorry, I see that I sounded like an entitled user when I did not mean to.

(Edited) I had a suspicion and disabled Cloudflare for my website. When I did that, everything worked as expected, the visual editor and everything. When I re-enabled it, it stopped working again. So it's not a Dotclear issue!

For any reader with the same issue: Turn off "RocketLoader" for JavaScript in the "Speed" section of Cloudflare. That was the culprit.

Thank you for the help.

Dernière modification par umitn (2020-03-19 21:14:14)

Hors ligne

#9 2020-03-20 03:22:33

ben_griffith
Membre
Lieu : Wiltshire
Inscription : 2009-09-28

Re : [SOLVED] WYSIWYG (visual) Editor not working

Glad that is works now and you found the culprit.

Please change the subject to [Solved].

Thanks for letting us know.


I Dotclear.

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map