Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2020-10-04 18:23:45

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Versions Dotclear et versions php

Tests...

using php 7.3.5 with Dotclear
-----------------------------
(Deprecated: Functions)
Dotclear 2.9 need php 5.6 - error with php 7.3.5
Dotclear 2.10 need php 5.6 - error with php 7.3.5
Dotclear 2.11 need php 5.6 - error with php 7.3.5
Dotclear 2.12 need php 5.6 - error with php 7.3.5
Dotclear 2.13 need php 5.6 - error with php 7.3.5


using php 7.4.1 with Dotclear
-----------------------------
( Deprecated: Array and string offset access syntax with curly braces)
( Deprecated: Function get_magic_quotes_gpc())
Dotclear 2.14 need php 7.3.5 - error with php 7.4.1
Dotclear 2.15 need php 7.3.5 - error with php 7.4.1


(seems ok)
=======
Dotclear 2.16 & php 7.4.1 - no error with php 7.4.1
Dotclear 2.17.2 & php 7.4.1 - no error with php 7.4.1

----
(philippe)
Dotclear 2.18-dev php 7.4.5 (build avril 2020)

------------
à suivre et compléter si vous le voulez bien ;-)

Dernière modification par nanart (2020-10-04 18:55:20)


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#2 2020-10-04 18:32:20

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Versions Dotclear et versions php

Dotclear 2.18-dev php 7.4.5 (build avril 2020) : pas d'erreurs

Hors ligne

#3 2020-10-05 06:25:58

Franck
Footer de merde
Lieu : Paris
Inscription : 2004-11-09
Site Web

Re : Versions Dotclear et versions php

Je vois pas bien l'intérêt de tester des vieilles versions de Dotclear avec les versions de PHP les plus récentes, versions qui n'étaient pas encore utilisées à l'époque.

C'est quoi l'idée ?


Dotclear addicted since 2004

Hors ligne

#4 2020-10-05 18:05:33

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Versions Dotclear et versions php

Je suis parti du principe que tous les utilisateurs de Dotclear ne mettent pas à jour systématiquement (déjà vu sur ce forum).
Par contre les hébergeurs mettent souvent à jour leur version php. Les utilisateurs, quant à eux, peuvent changer de version php à un moment donné.

Ainsi, en partant du constat :
* quelle version Dotclear ?
* quelle versions PHP ?
on peut confronter le pb rencontré aux erreurs expliquées.

Par ailleurs des plugs ont été créés sous d'anciennes versions Dotclear (et php >= 5.6 toujours en vigueur en prérequis)
Un passage sous php 7 renvoie - couramment vu, des erreurs qui informent sur le conflit / version php.

Enfin, pour ce qui concerne les plugs plus récents (ou maj), tester le plug :
* sur des versions Dc < stable actuelle
* php 5.6 et php 7.x
permet, amha, d'assurer un minimum de continuité de fonctionnement.

Mébon, c'est aussi pour moi un "pense-bête"
et, in fine, apporter une info sur la maintenance parfaite de Dotclear ;-)

Dernière modification par nanart (2020-10-05 18:28:51)


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#5 2020-11-15 10:41:57

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Versions Dotclear et versions php

important La future version Dotclear 2.19 nécessitera une version php >= 7.0


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map