Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2020-11-21 08:20:41

hyperion66
Membre
Inscription : 2008-12-01
Site Web

Balise EntryFirstImage et format Webp

Bonjour,

Est-ce que la balise EntryFirstImage gère le format d'image Webp ? Si ce n'est pas le cas, comment la rendre compatible ?

Merci

Hors ligne

#2 2020-11-21 09:44:05

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Balise EntryFirstImage et format Webp

Je ne crois pas. Sauf erreur, EntryFirstImage repose sur la fonction EntryFirstImageHelper dans /inc/public/lib.tpl.context.php qui recherche le motif

$pattern = sprintf('/<img.+?src="%s(.*?\.(?:jpg|jpeg|gif|png))"[^>]+/msui', $pattern);

Il faudrait demander à Franck d'ajouter les formats webp et, tant qu'on y est, svg. Le mieux serait d'ouvrir un ticket ;)

Ticket créé ici : https://git.dotclear.org/dev/dotclear/issues/73

Hors ligne

#3 2020-11-21 15:20:53

hyperion66
Membre
Inscription : 2008-12-01
Site Web

Hors ligne

#4 2020-11-22 15:23:37

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Balise EntryFirstImage et format Webp

Je crois que c'est pour bientôt. En attendant tu peux l'implémenter chez toi, et lors de la prochaine mise à jour utiliser Fake Me Up ;)

Hors ligne

#5 2020-11-22 16:15:37

hyperion66
Membre
Inscription : 2008-12-01
Site Web

Re : Balise EntryFirstImage et format Webp

Je dois modifier quel fichier ?

Hors ligne

#6 2020-11-22 16:29:29

hyperion66
Membre
Inscription : 2008-12-01
Site Web

Re : Balise EntryFirstImage et format Webp

Parfait, j'ai trouvé, c'est dans \inc\public\lib.tpl.context.php, ligne 486.

Désormais, ça semble fonctionner, ce qui va permettre d'alléger ma page d'accueil.

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map