Dotclear

Vous n'êtes pas identifié(e).

Annonce

#26 2021-02-06 17:45:19

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Prévisualisation et envoi de commentaires impossibles

De mémoire, tester d'abord :

connexion admin, en bas, undefined-pb de connexion -> me connecter en mode sans echec
=>  Vous êtes en mode de secours. Tous les plugins ont été temporairement désactivés.

Avant que de désactiver les plugs, un a un...


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

#27 2021-02-06 20:07:42

je-mattarde
Membre
Lieu : Au bistrot
Inscription : 2011-07-29
Site Web

Re : Prévisualisation et envoi de commentaires impossibles

De mémoire, tester d'abord :

connexion admin, en bas, undefined-pb de connexion -> me connecter en mode sans echec
=>  Vous êtes en mode de secours. Tous les plugins ont été temporairement désactivés.

Pas trouvé.


Mais il y a un bouton pour désactiver TOUS les plugins dans la page des plugins. Je les ai donc TOUS désactiver. Mais la prévisu et l'envoi des commentaires ne fonctionnent toujours pas.
C'est embêtant.

Dernière modification par je-mattarde (2021-02-06 20:11:17)


Gilles

Hors ligne

#28 2021-02-07 12:15:04

je-mattarde
Membre
Lieu : Au bistrot
Inscription : 2011-07-29
Site Web

Re : Prévisualisation et envoi de commentaires impossibles

Je me demande si le bug de Pollux (coincidence étrange) remonté aujourd'hui ne pourrait pas être le même problème que sur notre site.

Pour résumé, ce qui a déjà été testé :
- remplacer les dossiers dans httpdocs/themes/ et /allblogs/ par les thèmes non modifiés de l'archive 1.18
- activation du theme ductile et blowup non modifié
- vidage du cache des templates
- désactivation de TOUS les plugins

Rien y fait, les commentaires ne fonctionnent toujours pas.
(je suis revenu à notre thème provisoirement en attendant d'autres idées)

Dernière modification par je-mattarde (2021-02-07 12:53:11)


Gilles

Hors ligne

#29 2021-02-07 13:45:08

je-mattarde
Membre
Lieu : Au bistrot
Inscription : 2011-07-29
Site Web

Re : Prévisualisation et envoi de commentaires impossibles

Le dernier commentaire passé était en novembre 2019. On ne s'était pas spécialement étonné d'avoir aucun commentaire en 2020 de nos visiteurs. Cela coïnciderait avec la mise à jour Dotclear 2.15.3 qui corrige :

   

Effet de bord avec le compresseur de script javascript
    Insertion d'un média non image, vidéo ou audi dans une entrée au format XHTML
    Gestion de la case à cocher « Se souvenir de moi » pour les vieux thèmes

Ce peut-il que cette correction sur le "compresseur de script javascript" soit en cause ?


Gilles

Hors ligne

#30 2021-02-08 08:49:46

je-mattarde
Membre
Lieu : Au bistrot
Inscription : 2011-07-29
Site Web

Re : Prévisualisation et envoi de commentaires impossibles

Je suis passé à côté de ce fil lors de mes recherches sur le forum :
https://forum.dotclear.org/viewtopic.ph … 16#p310016

Je vérifierai ce soir le contenu de mon fichier .htaccess si ce dernier n'est pas en cause comme pour DoubleZoe.

Cependant je ne sais pas ce que je dois m'attendre à y trouver, la documentation dotclear associée à ce fichier est brève :
https://fr.dotclear.org/documentation/2 … g/htaccess
Pouvez-vous me dire quel est le contenu par défaut de ce fichier suite à l'installation d'un blog ?


Gilles

Hors ligne

#31 2021-02-08 10:51:42

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Prévisualisation et envoi de commentaires impossibles

Par défaut, dotclear n'utilise pas de fichier htaccess. Peux-tu poster ici le contenu du tien ?

En ligne

#32 2021-02-08 14:01:00

je-mattarde
Membre
Lieu : Au bistrot
Inscription : 2011-07-29
Site Web

Re : Prévisualisation et envoi de commentaires impossibles

Bonjour Philippe, trouvé dans /httpdocs/inc/ et voici le contenu :

# Apache 2.2
<IfModule !authz_core_module>
  Deny from all
</IfModule>

# Apache 2.4+
<IfModule authz_core_module>
  Require all denied
</IfModule>

Vous pensez que je peux utiliser les lignes de la règle que vous avez indiqué à DoubleZoe ?


Gilles

Hors ligne

#33 2021-02-08 14:10:06

je-mattarde
Membre
Lieu : Au bistrot
Inscription : 2011-07-29
Site Web

Re : Prévisualisation et envoi de commentaires impossibles

Ah mer... !!!
Je viens de me souvenir que j'avais déjà fait quelque chose autour de ça en 2011 : https://forum.dotclear.org/viewtopic.php?id=45763

Mon blog est sur un serveur web IIS et non pas Apache.


Gilles

Hors ligne

#34 2021-02-08 14:23:34

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Prévisualisation et envoi de commentaires impossibles

je-mattarde a écrit :

Bonjour Philippe, trouvé dans /httpdocs/inc/ et voici le contenu :

Ce n'est pas le fichier dont je parlais, celui-ci ne devrait pas être touché et n'a pas d'effet sur la partie publique du blog.

Celui que je mentionne devrait se trouver à la racine du blog, au même niveau que le fichier index.php. Mais il est possible qu'il n'y en ait aucun, en effet comme je le disais dotclear ne le crée pas, par défaut, car il n'est pas obligatoire pour son fonctionnement. En général, les utilisateurs l'ajoutent pour réécrire les URLs (par exemple pour supprimer index.php? dans les adresses) ou pour d'autres améliorations de performances.

Lorsqu'on tente de poster un commentaire, une redirection est opérée vers la racine du blog, à tort manifestement. Reste à savoir ce qui la provoque, mais je ne connais pas du tout IIs, et ne pourrai pas vous aider pour ce type de serveur, désolé.

En ligne

#35 2021-02-08 15:59:31

je-mattarde
Membre
Lieu : Au bistrot
Inscription : 2011-07-29
Site Web

Re : Prévisualisation et envoi de commentaires impossibles

Merci Philippe.

J'avais dû laisser tomber le basculement vers la méthode d'url PATH_INFO puisque :
- je suis toujours configuré en QUERY_STRING
- je ne trouve pas de fichier web.config (l"équivalent de htaccess pour IIS) qui pourrait opérer une redirection

Philippe a écrit :

Lorsqu'on tente de poster un commentaire, une redirection est opérée vers la racine du blog, à tort manifestement. Reste à savoir ce qui la provoque, mais je ne connais pas du tout IIs, et ne pourrai pas vous aider pour ce type de serveur, désolé.

Est-ce qu'il ne faudrait pas que je traduise les règles que vous avez écrite pour DoubleZoe dans le format xml de web.config afin de faire la "bonne" réécriture d'url?

Dernière modification par je-mattarde (2021-02-08 16:15:28)


Gilles

Hors ligne

#36 2021-02-08 16:58:34

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Prévisualisation et envoi de commentaires impossibles

je-mattarde a écrit :

J'avais dû laisser tomber le basculement vers la méthode d'url PATH_INFO

Si possible, ce mode de lecture des URLs n'est pas conseillé, voir ici pour les explications

Pour la traduction des règles de réécriture je répète que je ne connais pas IIs, donc aucune idée malheureusement

Toutefois, ces règles ne sont absolument pas nécessaires et ne devraient pas être utilisées tant que tout ne marche pas comme il faut. Il faut réussir à faire fonctionner les commentaires sans réécriture avant tout ;)

En ligne

#37 2021-02-08 18:37:25

je-mattarde
Membre
Lieu : Au bistrot
Inscription : 2011-07-29
Site Web

Re : Prévisualisation et envoi de commentaires impossibles

Bon. Je ne sais pas si je dois m'en réjouir mais cela est tombé en marche en modifiant l'url du site saisi dans les paramètres du blog :
J'ai saisi http://je-mattarde.com/index.php? au lieu de http://www.je-mattarde.com/index.php?

Est ce normal de devoir enlever les "www." ?


Gilles

Hors ligne

#38 2021-02-09 13:34:41

nanart
Membre
Lieu : Roubaix
Inscription : 2007-08-19

Re : Prévisualisation et envoi de commentaires impossibles

je-mattarde a écrit :

Est ce normal de devoir enlever les "www." ?

Le fait que ce soit retomber en marche est le signe que vous utilisez plusieurs url (http et http//www) et qu'il y a un "traitement" de l'url "quelque part"

(peut être une redirection dans un fichier de confg ? )
Par ailleurs une autre url de type https répond aussi à votre site...

Le pb initial est donc latent.

En attendant je vous conseille :
1) de faire une sauvegarde de votre site (base de données et dossiers via ftp)
2) éventuellement de reconstituer une version locale qui servira aux tests et vérifications

et de vous renseigner quant à l'utilisation d'un fichier htaccess ou équivalent pour votre systeme

Dernière modification par nanart (2021-02-09 19:44:20)


Dernière version stable Dotclear sur wampserver et chez ovh
Versions testing & unstable en local
https
php: 5.6.40 & 7.3.5

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map