Dotclear

Vous n'êtes pas identifié(e).

Annonce

#1 2021-08-30 13:25:16

Kysban
Membre
Lieu : Paris
Inscription : 2006-04-11

Besoin d'aide au sujet de tpl:EntryImages pour les valeurs de alt

Bonjour,

J'utilise la balise tpl:EntryImages : j'ai bien compris comment obtenir un title (avec bubble="entry") mais je n'ai pas compris le fonctionnement de la balise pour alt qui prend les valeurs "none" ou "inherit" selon la doc. Comment fonctionne inherit dans le contexte ? Où dois-je indiquer le contenu de alt pour que inherit fonctionne ?

Le cas échéant, ne serait-il pas possible d'ajouter une valeur "entry" pour alt ? Cela résoudrait mon problème sur de nombreux sites.

Merci d'avance pour votre aide :-)

Dernière modification par Kysban (2021-08-30 13:26:53)

Hors ligne

#2 2021-08-30 14:37:03

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Besoin d'aide au sujet de tpl:EntryImages pour les valeurs de alt

Bonjour

La question concerne le plugin listImages

L'attribut inherit permet de récupérer l'attribut alt de l'image qui, dans la médiathèque, correspond au "Titre du fichier".

Pour le remplacer par le titre du billet, il faudrait modifier le code de la fonction EntryImagesHelper dans /plugins/listImages/public.php, mais peut-être que le alt bien renseigné serait suffisant ?

Edit : sinon, pour que l'attribut alt de l'image soit toujours le titre du billet, tu peux remplacer les lignes 287 et 290 dudit fichier par :

$img_legend = $rs->post_title;

Dernière modification par Philippe (2021-08-30 14:43:00)

Hors ligne

#3 2021-09-01 14:25:22

Kysban
Membre
Lieu : Paris
Inscription : 2006-04-11

Re : Besoin d'aide au sujet de tpl:EntryImages pour les valeurs de alt

Bonjour, un grand merci pour cette réponse qui résout parfaitement mon problème. :-)

Selon les sites concernés, une des deux méthodes conviendra.

Hors ligne

#4 2021-09-06 08:09:16

Kysban
Membre
Lieu : Paris
Inscription : 2006-04-11

Re : Besoin d'aide au sujet de tpl:EntryImages pour les valeurs de alt

Désolé, je viens seulement de tester, et malheureusement ce n'est pas aussi simple qu'il n'y paraissait pour moi.

Comme tu me l'as expliqué, j'ai indiqué l'information de l'attribut alt dans la médiathèque au niveau du "titre de fichier".
J'ai testé pas mal de chose mais rien n'y fait, l'attribut alt reste vide.

En revanche, j'ai renseigné l'attribut alt à l'endroit où l'image est appelée dans l'éditeur de billet.
Et là, l'attribut alt est désormais bien renseigné dans tous les autres contextes : page d'accueil, page catégorie, page archives, page article et section billet connexe de la page article.

Est-ce que c'est finalement censé fonctionner comme cela ou est-ce que je m'y prends mal ?

Je n'ai pas encore testé la modification de code dans le plugin, ce sera la prochaine étape. :)

Dernière modification par Kysban (2021-09-06 08:10:19)

Hors ligne

#5 2021-09-06 09:35:07

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Besoin d'aide au sujet de tpl:EntryImages pour les valeurs de alt

Kysban a écrit :

Comme tu me l'as expliqué, j'ai indiqué l'information de l'attribut alt dans la médiathèque au niveau du "titre de fichier".
J'ai testé pas mal de chose mais rien n'y fait, l'attribut alt reste vide.

Il faut insérer l'image à nouveau pour que la balise <img> soit régénérée, et prenne bien le nouvel attribut alt, puis enregistrer.

Sinon, comme tu l'as fait, ajouter le alt dans le code directement (en wiki ou en mode source pour le html) puis enregistrer

Hors ligne

#6 2021-09-19 21:53:10

Kysban
Membre
Lieu : Paris
Inscription : 2006-04-11

Re : Besoin d'aide au sujet de tpl:EntryImages pour les valeurs de alt

Merci beaucoup pour les explications. :-)

J'ai fait les modifications dans le fichier du plugin comme tu me les as suggérées, mais ça ne fonctionne pas.

Finalement, j'ai testé ça et ça fonctionne :

                                // Gestion option alt : inherit / none
                                if ($alt == 'none') {
                                    $img_alt = '';
                                }
                               // Lignes ajoutées  
                                if ($alt == 'inherit') {
				    $img_alt = $rs->post_title;
                                }

Est-ce correct ?

Dernière modification par Kysban (2021-09-19 22:06:41)

Hors ligne

#7 2021-09-20 08:37:37

Philippe
Stagiaire
Lieu : Toulon
Inscription : 2004-06-13
Site Web

Re : Besoin d'aide au sujet de tpl:EntryImages pour les valeurs de alt

Ben si ça marche comme tu le veux, n'y touche surtout plus :D

Hors ligne

Vous n'êtes pas identifié(e).

Pied de page des forums

Sites map